Update error message

[LEFT] Hello,

[FONT=Roboto Mono][size=3][FONT=Roboto Mono][size=3] I use TW with Gnome.[/size][/FONT]
I have been receiving this error message at start from 3 days:

Software Update Failed
An important OS update failed to be installed

Failed To Update
We're sorry:the update failed to install. Please wait for another update and try again. If the problem persist, contact your software provider.
Detailed errors from the package manager follow: 
Download (curl) error for 'http://download.opensuse.org/tumbleweed/repo/non-oss/repodata/repomd.xml': 
Error code: Connection failed 
Error message: Could not resolve host: download.opensuse.org

In this morning I update to TW-20200904.
I tried with

zypper refresh -fdb
zypper clean -all 

The message is still here.

My repositories:

# | Alias                                | Name                       | Enabled | GPG Check | Refresh 
1 | download.opensuse.org-non-oss        | Main Repository (NON-OSS)  | Yes     | (r ) Yes  | Yes 
2 | download.opensuse.org-oss            | Main Repository (OSS)      | Yes     | (r ) Yes  | Yes 
3 | download.opensuse.org-tumbleweed     | Main Update Repository     | Yes     | (r ) Yes  | Yes 
4 | google-chrome                        | google-chrome              | Yes     | (r ) Yes  | Yes 
5 | openSUSE-20200901-0                  | openSUSE-20200901-0        | Yes     | (r ) Yes  | Yes 
6 | packman.inode.at-openSUSE_Tumbleweed | Packman Repository         | Yes     | (r ) Yes  | Yes 
7 | repo-debug                           | openSUSE-Tumbleweed-Debug  | No      | ----      | ---- 
8 | repo-source                          | openSUSE-Tumbleweed-Source | No      | ----      | ---- 

Thank you.[/FONT][/size]

Message comes from GNOME Software - PackageKit, so refreshing zypper state is not going to change anything. Look under /var/lib/PackageKit, what files do you have there? Most likely there is indication of failed update which is not removed automatically.

As a general comment - you should not use PackageKit and anything that is based on PackageKit to update Tumbleweed. The only command that works is “zypper dup”. I use GNOME Software as indication that updates are available and then perform update on command line.


Thanks for the answer.

I update only with “zypper -vvv dup”. I never use something else.

In /var/lib/PackageKit I have “offline-update-completed” and “transactions.db”.
This is “offline-update-completed”:

[PackageKit Offline Update Results] 
ErrorDetails=Download (curl) error for 'http://download.opensuse.org/tumbleweed/repo/non-oss/repodata/repomd.xml':
Error code: Connection failed
Error message: Could not resolve host: download.opensuse.org

Simply delete this file.

I update only with “zypper -vvv dup”.

Well, there was attempt to perform offline update, so obviously at least once you (may be by accident) tried something else.

It works.
Thank you.

So I followed along this thread because I have a similar issue. I did a new TW install with basic gnome gui option and whenever I open the software app to try and get more apps it tells me: download (curl) error for ‘http://download.opensuse.org/tumbleweed/repo/-non-oss/repodata/repomd.xml’:, now I checked my var/libs/packagekit folder and only have the transactions file. what else can I try?

Don’t use Gnome Software to install applications on openSUSE/TW, use YaST2-Software instead, the main software tool for this distro.
If you are still facing problems, start a new thread with details about the error you see, attaching to an old thread is not a good option generally.

Actually my comment above is wrong (it already was wrong when I made it, I was not aware that PackageKit was fixed). Today PackageKit on TW performs equivalent of “zypper dup”; corresponding changes appeared this spring (March/April 2020). Every now and then there are different issues but in general gnome-software is usable. I use gnome-software on GNOME TW (not intentionally, it simply was set up this way by default) and I use native KDE tool (I have no idea how it is called correctly) in KDE TW. Both work just fine for updating TW since at least couple of months when I switched back to using them.


In this case we do not need to disable packagekit no more. Good news.