update conflict

Leap 42.3 but with extra repositories.

I am totally confused, It says there is a conflict, then suggest a vendor change.

I don think I want that, I want the stuff from packman. I switched all packages to packman in yast.


These are my repositories:


mpg123 is not available on Packman anymore, as it is included in the distribution now (since 42.3) because the MP3 patents have expired.

You apparently installed it from multimedia:libs though.

The actual problem likely is that mpg123-esound doesn’t exist anymore in multimedia:libs. I would recommend to uninstall it, esound has been dropped years ago anyway.

Also, you maybe have a mixture of different package versions.
What does “rpm -qa | grep mpg123” print?

Also, your repo setup is likely to cause you problems at some point.
multimedia:libs and multimedia:apps contain the latest multimedia packages, possibly even newer than Packman, so they would be preferred. But they are crippled of course.
I would recommend to give Packman a higher priority (lower priority number) to force it to be preferred also for new packages.

The vendor switch to Packman you did is a one-time action, that won’t affect newly installed packages.

May I suggest the following:

  1. Lower the priority of the Packman repository: I tend to set Packman to a priority of at least 115.
  2. Lower the priority of the “home” repositories: my suggestion is to set them to a value of at least 130.
  3. Lower the priority of the Multimedia Apps and Multimedia Libs repositories: I tend to set such openSUSE repositories to a priority of at least 100 but, a higher priority than that of any non-openSUSE repositories.
  4. Lower the priority of the Google Chrome, Libdvdcss and Adobe Flash Player repositories: I tend to set such repositories to a priority less than that of any openSUSE repositories but, higher than the priority of the Packman repository.
  5. Do not change the system packages to the Packman repository.

The version of libmpg123-0 in the openSUSE Multimedia Libs repository is newer than the one pointed to by the openSUSE-2017-1139 patch:

  • You may have to temporarily disable the Multimedia Apps and Multimedia Libs repositories to get the openSUSE-2017-1139 patch installed.

[HR][/HR]AFAICS libmpg123 and mpg123-esound are not available from the Packman repository.

[HR][/HR]On this Leap 42.3 system, mpg123-esound and libmpg123-0 are provided by openSUSE.
The patch openSUSE-2017-1139 is installed:

 > zypper patch-info openSUSE-2017-1139
Loading repository data...
Reading installed packages...

Information for patch openSUSE-2017-1139:
Repository  : Hauptaktualisierungs-Repository
Name        : openSUSE-2017-1139             
Version     : 1                              
Arch        : noarch                         
Vendor      : maint-coord@suse.de            
Status      : applied                        
Category    : security                       
Severity    : moderate                       
Created On  : Tue Oct 10 09:00:04 2017       
Interactive : ---                            
Summary     : Security update for mpg123     
Description :                                
    This update for mpg123 to version 1.25.7 fixes the following issues:

    - CVE-2017-10683: Improvement over previous fix for xrpnt overflow problems (boo#1046766)

    The following changes are also included in version 1.25.7:

    - Do not play with cursor and inverse video for progress bar when TERM=dumb
    - Fix parsing of host port for numerical IPv6 addresses
Provides    : patch:openSUSE-2017-1139 = 1   
Conflicts   : [58]                           
    libmpg123-0.i586 < 1.25.7-10.1
    mpg123-esound.x86_64 < 1.25.7-10.1


We seem to agree to disagree: my usual recommendation is to make sure that any non-openSUSE distribution repositories have a lower priority (higher priority number).
I’ve broken my rule only once: with some KDE repositories …

But that would have the effect that the crippled openSUSE packages are preferred over Packman’s.

I would rather recommend the opposite, as I wrote.

Do not change the system packages to the Packman repository.

This is necessary to have full multimedia support.

Please don’t post such completely wrong advise.
Or do you want to advocate the Fluendo codecs again? :wink:
Won’t help much with software not using gstreamer though.

AFAICS libmpg123 and mpg123-esound are not available from the Packman repository.

No, because they are included in the standard distribution now, as I wrote.
The MP3 patents expired about a year ago, so there are no legal problems with shipping MP3 support anymore.

I read what you’re saying and heed your request.

No. The Fluendo codecs are only interesting for MPEG > 3. >:)

There is also an MP3 codec by Fluendo.
It even was/is shipped in openSUSE, in the non-oss repo.

But as the MP3 patents expired, it’s no longer necessary anyway, the standard gstreamer packages contain an MP3 plugin now as well (in gstreamer-plugins-ugly). That actually uses (lib)mpg123 for the decoding btw… :wink:

Off-topic here anyway though, as this is about a problem with the official mpg123 update from openSUSE’s Update repo.
And that’s a conflict between the standard repos and multimedia:libs (which contains the latest mpg123).
Packman doesn’t play a role here neither.

From what you’ve described in your original Post, you had Leap 42.2 installed and have upgraded to Leap 42.3; two of the repository names need to be changed to reflect the current Leap 42.3 status quo but, that’s a minor issue related to confusion.

You also seem to be very dependent on the Multimedia repositories, possibly because the main openSUSE repositories possibly contain multimedia support which may be viewed as being “crippled”.

You don’t need to explain why you need the openSUSE Multimedia repositories but, please be aware of this openSUSE Wiki statement: <https://en.opensuse.org/Restricted_formats>.
There’s also these Wiki pages: <https://en.opensuse.org/Concepts_multimedia>; <https://en.opensuse.org/Codecs>.

The packages in multimedia:libs and multimedia:apps are “crippled” too. These are actually the devel projects for the distribution.

Only Packman contains the full versions.

Thank you guys.

I removed esound, and that solved the update problem.

I need to think, and maybe do a fresh install of leap 42.3. (not format home) and or disable the thumbleweed repository.

I am having allot of issues all related to multimedia, because of me trying to compile a program myself.

The program was lmms, and the compiling needs a lot of libs (and dev files)
That was the reason why I added the thumbleweed repository, because I could not find the libs and dev files in the standard repositories.
Compiling is not that hard, but in the case of lmms, you really need to install allot of extra stuff.

All those extra libs, and dev files, keep causing me issues, and prob the fact my 42.3 is an update from 42.2, and the 42.2 was an update from 42.1.
So I am dragging along allot of history.
To some extent I am surprised it still works. :slight_smile:

For now I will give the thumbleweed repository a lower priority then the packman repository.

Going off topic:
The good news for people who want to use LMMS, is that we don’t need to compile it anymore.
LMMS now has a file we can download and run. (appimage)

This makes compiling release candidates myself, not necessary anymore.

I do not know why there are so many problems with lmms.
I do now its not just openSUSE, its every distro around.

Maybe it has to do with wine? To load vst into lmms, you need wine.
For some reason allot of the distro’s give lmms with out vst support.

I once talked with packman, and they admitted not really knowing lmms, so they need users like me (us) , to tell them if its not working as it should.
Because I talked with packman, I found out the problem was with LMMS and not with openSUSE.

For a reason beyond my understanding, lmms worked fine on 42.1, but not on 42.2 (and other distro’s )
That’s why I started to compile it myself. The compiling it self did work out, I had the latest lmms running ( a release candidate), with vst support.

I did not change the priority of the thumbleweed repositories, as I stated in my previous post

I did give packman a higher priority. Its now set to 90, all others are 99 ( default )

lets see how that works out. :slight_smile:

Possibly, a new, fresh, install is not needed; please be aware of the upgrade information here: <https://doc.opensuse.org/documentation/leap/startup/html/book.opensuse.startup/cha.update.osuse.html&gt;.
You’ll also need this Wiki article: <https://en.opensuse.org/SDB:System_upgrade&gt;.

Please pay particular attention to the need to have only the openSUSE System repositories enabled before the upgrade (“zypper dup”) is initiated.

  • openSUSE repositories such as the Multimedia repositories should be disabled before the upgrade commences.
  • External repositories such as Packman should also be disabled before the upgrade commences.

In addition to performing a system wide backup before the upgrade is initiated (common sense), it pays to document the packages installed on your system before the upgrade is initiated – you’ll need that information once the upgrade has completed to bring in the packages you need for a working system from the non-System and external repositories.

Once the upgrade has completed and, before the changes with respect to things such as Multimedia are made, please make sure that you execute “rcrpmconfigcheck” from the the user ‘root’ to catch all the changes made to configuration files by the upgrade – work through all the configuration changes until the ‘config check’ reports only “Searching for unresolved configuration files”.
[HR][/HR]Provided that, all the hints in the openSUSE documentation are followed, and the hints in the Wiki are followed, and “rcrpmconfigcheck” doesn’t find anything, with the openSUSE versions published over the last few years, a new, fresh, installation is not needed.

I already did an update from 42.2 to 42.3, after I had first disabled all extra repositories.

Asked on this boards, which repositories I needed, and that update did not go smooth. :slight_smile:

It ended with a grub error.

That grub error is prob also because of history I am dragging along. ( three hard disk, two leap, and one windows )

Right now I have to fix that grub issue, but I am gonna start a new topic on that.

The update conflict is gone, and the two multimedia thumble weed repsositries, I have , now have priority 110, all other repositories the default 99.

So packman and the “normal” opensuse repositories have a higher priority then the thumbleweed ones.

To make one thing clear, I am on leap, and not on thumbleweed.

TW repositories?
I thought you’re having issues with 42.3?
please post the output of

zypper lr -d

inside the

 tags (press the # button in the lower right corner of the page formatting tools)

and tell us what you did and what you want to do?
generally speaking when doing an upgrade from 42.2 to 42.3 or even TW you should only keep the 2 (4) main repositories the OSS and the OSS-update (non-OSS and non-OSS update too) all extra repositories should be disabled (better removed) and all 3rd party binary blobs removed (propitiatory nvidia/ati drivers) 
TW now uses vendor stickiness so repo priority numbers mean nothing on TW, as LEAP uses zypper up for updates those numbers are meaningless for LEAP users too I tend to give packman a priority of 90 but that has no real effect on LEAP or TW

Yes, it’s about 42.3.

The “Tumbleweed repositories” he referred too are actually multimedia:libs and multimedia:apps (for 42.3).
I mentioned that they are development projects for Tumbleweed, hence the “confusion” I suppose…

And he already posted his repo list.

The original problem is solved already anyway, it was caused by the fact that mpg123-esound has been dropped from multimedia:libs.

TW now uses vendor stickiness so repo priority numbers mean nothing on TW, as LEAP uses zypper up for updates those numbers are meaningless for LEAP users too I tend to give packman a priority of 90 but that has no real effect on LEAP or TW

That’s true to some degree only.

As I wrote already, the priorities do affect from where newly installed packages are taken. And also updates can pull in new packages…
In his case, multimedia:* would likely be preferred over Packman as they tend to have higher versions, so it probably is a good idea to give Packman a higher priority.