Update/Compile my Kernel after changing param.h file

I’m running openSuse 11.1 with Kernel 2.6.27.29.01-default x86_64

because of problem with VMware workstation 6.5.3 I needed to change the value of #define HZ to 1000 instead of 100 in file “/usr/src/linux-2.6/include/asm-x86/param.h”. I did that.

The problem is how do I recompile my kernel. Do I need to recompile it would be good to know. And after I recompile it is that variable changed?

I have read several threads about updating/recompiling the kernel. I have changed to different directories and typed “make” and “make install.sh” and no luck.

Someone PLEASE, give me exact instructions. I’m only 5 years old and need very simple instructions. Open a terminal window as SU. Go to …directory…, type …command1…command2…

Try looking at this: How To Compile A Kernel - The SuSE Way | HowtoForge - Linux Howtos and Tutorials

Thanks!

This is a little scary for a newbie like me. It’s about a million steps!

I just changed one line a config file!

Is it required that I do all those steps? Can it be done in the GUI YaST?

Newbie(whimp)

did you ran VMWare after changing the value in param.h ? if it works correctly, then there’s no need to recompile the kernel, which honestly is not an easy task for a 5-years old chap

Hi
Just rollback to 6.5.2 to get rid of the rtc error? Sometimes the
latest isn’t the greatest and wait for a fix… I also see it on 7
beta as well.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
up 1 day 15:09, 2 users, load average: 0.17, 0.29, 0.18
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Thanks Malcolm but I had this error on 6.5.2 also. My Hz is set at 100, but the problem is I’m so new to Linux, I don’t know how to recompile my kernel without the million step process, much of which I’m sure I don’t need. I just don’t know what I need and what I don’t.

This is a little much to do just for making one change to one one configuration file. Do I need to do all these steps?

I rebooted the whole machine and it still does it. I just need to figure out the best way to recompile the kernel in a way I understand.

On Thu, 17 Sep 2009 22:56:01 +0000, bobcal2000 wrote:

> This is a little much to do just for making one change to one one
> configuration file. Do I need to do all these steps?

The change that you’re making isn’t just a change to a configuration file

  • it’s actually a change to the kernel source code.

Jim

Jim Henderson
openSUSE Forums Moderator

Thanks,

That answers my question about the change I made requires a recompile of the kernel.

Now I need the answer to one more question before I backup all my data, hold my breath, and move from the newbie level to a dangerous novice.

That document is from 2006 on 10.1, I have 11.1. Isn’t there a newer document? Looking through those instructions it talks about downloading source files. Don’t I have all the files on my computer already from the installation? I need to know for sure I need to do all those steps?

bobcal,
It’s not as drastic as that. As long as you have a separate /home partition,you won’t lose anything by installing the new kernel.
All you want to backup is the contents of /boot (a bit of an overkill, but it’s easier for a novice than to find all the relevant files). All you are doing is changing the kernel which live in /boot.
If something goes wrong, make sure your have a live cd handy to restore your old /boot.
There is more general documentation in the how-to’s. Go to tldp.org and do a search for the kernel how to.
Good luck and enjoy - it gives you immense satisfaction when you’ve got it right.

Here’s how you do it - make sure to have the development stuff (gcc, make, qt-devel, etc) installed

  1. change the values in param.h
  2. in console, login as root and ‘cd’ to /usr/src/linux
  3. type: ‘make xconfig’ and this will bring the kernel configuration GUI
  4. in general settings, change the localversion variable from -default to -somethingelse (you choose what). If you don’t do that, it’ll overwrite the existing kernel when you do ‘make install’ at end of compilation. You don’t want that
  5. save the changes, close the GUI and type: ‘make’
  6. when it’s done, type: ‘make modules_install’
  7. after that, type: ‘make install’
  8. type: ‘make clean’
  9. type: ‘make prepare’
  10. type: ‘make modules_prepare’
  11. reboot system and choose your new kernel with the -somethingelse string

All of the above without quotes

Good News and bad news.

First the Good news: I bought a book, I read way to much about linux kernels, I compiled my first kernel, and I get to fix my first broken kernel. The bad news my kernel is now broke.

I installed all the Linux Kernel Development, Qt3 and pkg-config, then I followed your instructions to the letter (which were just a little different than the book), except one thing which I’m not sure did anything bad. “make xconfig” did not work(qconf couldn’t connect to xserver), so I used “make menuconfig” to change the kernel localversion. During the compilation, several warning about variables went by, but it did finish with any hard errors. The rest of the commands worked very well.

I held my breath and rebooted: KDE 33.5 will not start, I believe because the nVidia driver will not load. I only know how to load the driver thought the KDE.

Help again!
Bobby

if the kernel boots, it means it’s compiled correctly. Your kde does not start because you probably use the proprietary NV drivers which need recompilation after each kernel upgrade so just recompile them. If you have installed them manually, just login on console as root and execute the driver with the -K option (to build the kernel module only). If you use the NV prop drivers from the repo then you can’t “fix” it and the only way to get back the NV drivers working for your own compiled kernel is to (re)install them manually which is actually very easy to do

btw: to use the VESA driver which will allow you into GUI but without acceleration, type as root on console: sax2 -r -m 0 vesa

If you can boot with the new kernel, then it is working.
The kde/x-window problem is because the nvidia driver you have is for the old kernel.
Since you compiled a new kernel, you have to remake and install the driver for your kernel.
There are instructions on how to do this in other threads as well as on the nvidia site’s download page for you video card.
Well done in getting this far.

Microchip:
Bump, we were both replying at about the same time!

More good news!

I looked thought the posts for installing the NVidia driver manually, worked! My KDE is up and running on my new kernel. A few questions and one last problem.

1 - First the problem VMware v6.5.3 will not recompile into the kernel. I have done this a few times before, and it have always worked. Now it just asks for the root password and stops running, no errors. I have tried to reboot and I’ve tried several times.

2 - make xconfig still does not work, I get qconf cannot connect to xserver; make[1] ***xconfig error 1; make ***xconfig error. How to I fix this? If I open a KDE window it does works.

3 - What do the different color mean in the “ls” or “dir” command?

Bobby
openSUSE Very Dangerous Novice User
(I’m getting business cards made)

1 - this is probably a VMWare issue and I can’t help much on it since I don’t use it, at work or at home. I use Virtual Box

2 - make xconfig requires the QT4 development packages

3 - different colors indicate different types of files, directories, etc

To get a better idea, try plain ls and then ls -al and you will see what we mean.

1 - Fixed VMware by reinstalling it.

2 - Still broke - Installes libqt4-development. I didn’t see any just qt4 like qt3. Is this the correct one? Still does not work. Anything else you know of?

3 - is there a document with what each color means?

Thank You for all your help! Both of You!

Bobby