Update causes Plymouth to core dump on all machines

I just updated Tumbleweed (“zypper up”) on several machines and Plymouth is broken now.

I get as boot message:

[FAILED] Failed to start Show Plymouth Boot Screen.
See ‘systemctl status plymouth-start.service’ for details.

This gives me:

● plymouth-start.service - Show Plymouth Boot Screen
Loaded: loaded (/usr/lib/systemd/system/plymouth-start.service; static; vendor preset: disabled)
Active: failed (Result: core-dump) since Mon 2017-01-30 19:32:44 CET; 7min ago
Process: 528 ExecStartPost=/usr/bin/plymouth show-splash (code=exited, status=2)
Process: 502 ExecStart=/usr/sbin/plymouthd --mode=boot --pid-file=/run/plymouth/pid --attach-to-session (code=exited, status=0/SUCCESS)
Main PID: 523 (code=dumped, signal=SEGV)

Jan 30 19:32:44 prometheus systemd[1]: Starting Show Plymouth Boot Screen…
Jan 30 19:32:44 prometheus plymouth[528]: error: unexpectedly disconnected from boot status daemon
Jan 30 19:32:44 prometheus systemd[1]: plymouth-start.service: Main process exited, code=dumped, status=11/SEGV
Jan 30 19:32:44 prometheus systemd[1]: Failed to start Show Plymouth Boot Screen.
Jan 30 19:32:44 prometheus systemd[1]: plymouth-start.service: Unit entered failed state.
Jan 30 19:32:44 prometheus systemd[1]: plymouth-start.service: Failed with result ‘core-dump’.

Core dump doesn’t look to good and happens on 32bit and 64bit machines with Tumbleweed.

What can i do?

id start by using the correct update mechanism = zypper dup --no-allow-vendor-change

zypper up is doing just that…updating while not following a vendor change.

zypper dup should never be needed to my understanding as tumbleweed is a rolling release.

Sorry, but “zypper dup” is sometimes needed, precisely because it is a rolling distribution.

Sometimes packages get renamed or version numbers get changed to incompatible values. And “zypper dup” can handle that, while “zypper up” cannot.

There are some plymouth issues in recent updates. I have not yet installed 20170129. With 20170128, plymouth did not prompt for the LUKS encryption key. I had to use “nosplash” on the boot command. But I am not seeing signs of plymouth crashing.

Alright…did the following:

zypper dup --no-allow-vendor-change

followed by:


It updated a few packages, but plymouth was not among them.

The crash is still the same.

I happened to see this on the mailing list. Maybe you can give this a try: https://lists.opensuse.org/opensuse-factory/2017-01/msg00511.html

nosplash loads plymouth then plymouth crashes.

The error only goes away by disabling plymouth with: plymouth.enable=0

Unfortunately this will also remove all those intermediate booting messages. I don’t want to receive all messages by removing the “quiet” parameter in the booting line, but still receive the confirmations of successful started system services without using plymouth.

Is this possible?

Sorry but I know nothing about this.

This bug has been reported and is being processed here: https://bugzilla.opensuse.org/show_bug.cgi?id=997200

I experience the same problem since today.

First I also tried “plymouth.enable=0” but afterwards there was no message to enter my PWs for my HDDs.
When I combine adding “plymouth.enable=0” and removing “quiet” I see the messages and can enter the PW, but it is annoying because I have to enter the PW twice (two encrypted HDDs).
So I went with the following solution: I just deleted the “quiet” parameter from the boot line. Now I see for one or two seconds the kernel messages but then Plymouth kicks in and I can enter the PW.

But I have no clue why that works …