Update broken in 11.1

Tried this about a week ago and recieved NO replies…
Have done a fresh install of 11.1, and (it was…) mostly all good, but trying to setup online update, and going in to Yast>Software>Online update config and I am told “Current Update Repository: None”. If I do Advanced and “Register for support and get update Repository” and “Configure Now” it goes off and does stuff, and comes back and says “Software Repositories did not need to be changed”. Going out and back in still gives the same message… So far haven’t had any updates…


This does not mean it’s broken you can take it at its word. At this time there are no updates. Try this again in about a week-10 days, if it does it then you may have a problem.

hornetster wrote:
> Tried this about a week ago and recieved NO replies…
> Have done a fresh install of 11.1, and (it was…) mostly all good, but
> trying to setup online update, and going in to Yast>Software>Online
> update config and I am told “Current Update Repository: None”. If I do
> Advanced and “Register for support and get update Repository” and
> “Configure Now” it goes off and does stuff, and comes back and says
> “Software Repositories did not need to be changed”. Going out and back
> in still gives the same message… So far haven’t had any updates…
> Thanks.

I have the same problem, and it looks to me like there have been some
updates, so I’m pretty sure it’s broken. If you look at the update
repository when in “software management”, you will see many
patches/updates listed. You can get the updates in this fashion, but it
would be nice to have the updater working.

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing on Usenet and in email?


For example, I try Online Updates and I get an error,
Download failed:
Download(curl) error for ‘http://download.opensuse.org.distribution/11.1/repo/non-oss/content’:
Error code: Connection failed
Error message: Couldn’t resolve host ‘download.opensuse.org

Yet I go to an xterm and
#ping download.opensuse.org
PING download.opensuse.org ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=54 time=252 ms

Which tells me my box has a working DNS, something in the update widget is not using the DNS info correctly.


And Oh, BTW, if I hit skip enough I will find there are four updates available, two recommended and two security. So now I click apply and I am at a Error, download failed . . .couldn’t resolve host routine.

And it really does not do a download.
The only one of the YaST2 Software options I do not see something similar in is the Media Check. Make going to the CD for a little more code a painful ordeal.

Not sure it is related but I always seem to get another error message window that says
Xlib: extension “RANDR” missing on display “:4.0”.
This shows up twice on the window but I might get the window more than once, depends how much I thrash around with the update processes. Since my servers are in the farm upstairs and I am working on VNC display :4, I wonder if the two are really related issues.


I just updated from 11.0 to 11.1 and something wasn’t quite right with the Online Update Configuration. The openSUSE Updater applet appeared in my system tray but said it wasn’t configured with an update source, and it had no back end selected (and none to choose from either). Trying to set this up in YaST failed.

IIRC it was only after going to the regular ‘Online Update’ option in YaST (as opposed to the ‘Online Update Configuration’ option) that something magically kicked in and things began working. The applet suddenly had the PackageKit Plugin selected and all now seems well. However, all of this may have something to do with me doing an update rather than a fresh install.

Hello everybody,

I can confirm this issue:
“yast2->Software->Online Update” is always empty

I assume, this problem has a dependency with the confusing setting “Current update Repository” is always set to “(none)” under
“yast2->Software->Online Update Configuration->Current Update Repository:”.

Maybe anybody can me give some information how I can set the “Current update Repository” to an usefuel entry? With “Advanced → Register for support and get update repository” I had no success…

Thanks in advance for your help

Guys, I think the problem might be because of the main openSUSE repositories residing on a slow network/server. At least in my case, the update never happens in openSUSE either with the default repositories, and I get many of the messages mentioned earlier in the thread. The user is supposed to be automatically transferred to the nearest fast repository mirror, but I do think this is pretty much broken.

Here’s the best thing to try- has so far always worked for me. So here goes, the gui way- change your mirrors to faster ones.

  1. Open Yast->Configure Repositories
    Uncheck the 3 openSUSE repos- oss, non-oss, and updates. Make sure they are disabled for refresh, and otherwise too.

  2. Browse to Mirrors Released Version - openSUSE
    Click on ‘up to date list of mirrors for openSUSE 11.1’

3 Now try adding, say, the OSS repositories from one of the listed servers. You will have to do a bit of trial here to find a fast mirror. Judge by how fast you can add a repository from the server. Details to add a repo follow…

  1. Let’s try to add a OSS repository. Note down the URL in yast of the OSS repository- we will choose a similar directory structure from the mirror servers to ensure that the new OSS repository is properly chosen.

  2. In the browser choose a mirror. Let’s say, you think a swiss mirror is likely to be fast. Let’s choose ‘SWITCH - Serving Swiss Universities’ mirror

  3. Click HTTP next to this server ( or FTP if you prefer ). And ensure you can navigate to
    Index of /ftp/mirror/opensuse/distribution/11.1/repo/oss This URL is the one we need for OSS repositories. Copy it

  4. In Yast window, press ‘Add repo’ button, choose URL option.
    Paste the above URL in the provided space. Now wait for the repo to be added. Might take a little time, and you might have to accept some terms or a license.

  5. Now is the time to judge if the mirror feels adequately fast. Did it take too long to add the repository? You might want to try adding another one to compare. Choose the best ( fastest, reliable ) one. But at one time enable “only one set!” of OSS, non-OSS and update repositories. Feel free to delete the slow ones you don’t want.

  6. Now that we have finalized a server. Add the non-oss repository similarly, the URL is very similar to the oss URL.

10.For update repository, the directory structure will differ. See the Index of /ftp/mirror/opensuse/update/11.1 branch. Choose the URL closest to that in the original update repository.

  1. Please don’t blindly add switch.ch for your mirrors- this was just an example.

  2. Note a bug I find in the repositories configuration- if you edit a repository and change its name, an additional entry appears and this will only go away once you save and close the window, so that you won’t see it the next time. Maybe this was a bug in 11.0 and is fixed in 11.1, not sure.

  3. In your 3 new repositories, make sure that they are enabled and set for auto refresh.

  4. While doing a 1-click install in the future, decline to add the OSS, non-OSS and update repositories that might be suggested to you ( hint: uncheck them ). Our chosen mirrors should do just fine. If there could be some issues regarding this, any correction is welcome.

  5. Done.


Hello a59,

I have added as described this three repositories, the seem to work pretty fast. I have still the problem, that I have no updates and in yast2->Online Update Configuration->Current Update Repository:(none).

In yast2->Online Update ist still empty.

best regards,

My Yast-> Online Update Configuration also shows no update repos, yet I do get updates with the repositories set up as in the earlier post. As others pointed out earlier, there simply might not be updates available. Ubuntu seems to update a lot, while Mandriva and OpenSuse seem to have fewer updates- that’s just my observation based on a small timeframe.

2cents say you are alright!

It is broken here - my error says that SSL failed. I can add a repository as discussed here, but the 'register’portion fails.
Any ideas?

IIRC “PackageKit” - which replaces the 11.0 updater applet - needs a fix. I encountered this on RC 1, so can’t say positively the same is true on Final. Running Online Update from YaST installed the fix, and thereafter the updater worked.

I only had a Wine update and thats it. Online Update from YaST is empty.

I just took a look here Index of /update/11.1/rpm/i586. There are 2 package management updates, plus a number of other updates.

The 2 yast updates there I already have installed, so it seems.
They are from 19 and 20 December, which is around the date I upgraded to 11.1

All other packages are from before that, so no updates after that date?

I do have the same problem. I did a fresh install on my laptop and the update is broken (Current update repository: None). The same problem does occur in another 2 computers (desktops). In the last ones I did an update from 11 to 11.1 (net install).

Is there a patch for this problem?



That seems to be so. I have not seen any other info about this.

This is a non-critical issue. I’m just reporting a work-around for the benefit of others.

online_update_configuration just does not see the repositories which I have successfully configured with “yast2 repositories”. No matter what I do, The “Current Update Repository:” section of online_update_configuration is empty with no repositories to pick from.

I tried disabling ipv6 entirely, because the 11.1 installer has bugs wrt ipv4 vs. ipv6, but that had no effect on this repository invisibility problem.

However, contrary to what one would expect, in this situation, online_update_configuration seems to have absolutely no effect on either online_update or sw_single. My goal is to get frequent updates from my update server + third party repositories (my own partial mirrors of Mozilla and Packman). To accomplish this, you just use “yast2 repositories” to add your desired update repositories and make sure to set the priorities lower (higher priority) than the oss/etc. repositories. I.e., sw_single and online_update only see the first package of any name, based on priorities. To perform the update, use either sw_single or online_update menu Package / All Packages / Update if newer version available.

I see no difference between sw_single and online_update (maybe they have been merged?), but perhaps this can be automated with the later but not the former? I doubt Yast can be made to automatically apply liberal updates like I do through the menu (regardless that this use case was touted about 4 years ago), and at this point I wouldn’t trust it to do so automatically without corrupting my RPM dependencies anyways.

It appears that the Updater Applet is sensitive to the name of the update repository. After renaming my own mirror of the updates to “Main Update Repository” the updates were detected.

Uhm…i think updater in indeed broken in 11.1, because it never list updates, but in package manager they are listed…

Check this mockup combined from 2 images(those apps cannot run together)but that’s how it works. Updater don’t show updates, but when you launch package manager there are some available…