update broke the sound ...

Well, not much to add, Dell XPS laptop, on boot I would always have to do a rcalsound restart to get it to work, but a recent update this morning took out sound alltogether.

Just loading that gives me;
Starting sound driver: hda-intelFATAL: Could not load /lib/modules/2.6.25.16-0.1-default/modules.dep: No such file or directory

The full info on what the alsa debug shows can be seen here;
http://www.alsa-project.org/db/?f=c89d5cb07fd2561460a850e55e75c0aa6154a235

Any help or ideas is appreciated.

It looks to me like you updated your kernel ? openSUSE-11.0 comes with the 2.6.25.5-1.1 kernel. It was updated (for a brief time) to the 2.6.25.16 kernel, but it is now at the 2.6.25.18_0.2-4.1 kernel. Its possible your alsa driver is sensitive to the kernel version.

Please copy and paste the following into a gnome-terminal or kde konsole and post the output here.rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Alsa
alsa-plugins-pulse-1.0.18.git20081122-1.10
alsa-devel-1.0.18.git20081212-1.1
alsa-plugins-pulse-32bit-1.0.18.git20081122-1.10
alsa-plugins-1.0.18.git20081122-1.10
alsa-1.0.18.git20081212-1.1
alsa-firmware-1.0.17.git20081202-2.1
alsa-oss-1.0.17.git20080715-2.30
alsa-utils-1.0.18.git20081122-1.6
Pulse
pulseaudio-utils-0.9.10-26.5
pulseaudio-esound-compat-0.9.10-26.5
alsa-plugins-pulse-1.0.18.git20081122-1.10
libpulse-mainloop-glib0-0.9.10-26.5
pulseaudio-module-gconf-0.9.10-26.5
pulseaudio-module-x11-0.9.10-26.5
gstreamer-0_10-pulse-0.9.7-42.pm.1
libpulsecore4-0.9.10-26.5
pulseaudio-module-lirc-0.9.10-26.5
alsa-plugins-pulse-32bit-1.0.18.git20081122-1.10
libpulse0-32bit-0.9.10-26.5
libpulse-browse0-0.9.10-26.5
pulseaudio-module-bluetooth-0.9.10-26.5
pulseaudio-0.9.10-26.5
libpulse0-0.9.10-26.5
pulseaudio-module-zeroconf-0.9.10-26.5
libsound
libasound2-1.0.18.git20081212-1.1

Linux ZioN 2.6.25.18-0.2-default #1 SMP 2008-10-21 16:30:26 +0200 x86_64 x86_64 x86_64 GNU/Linux

options snd slots=snd-hda-intel
options snd-hda-intel model=3stack

u1Nb.vD9VbU_X1r7:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

Thanks!

I see you have gone and changed your configuration. You now have the 2.6.25.18 kernel as opposed to the 2.6.25.16 that you reported having earlier.

Hence I need you to run the alsa-info script again. Please open a gnome-terminal or a kde konsole and with your PC connected to the internet type:/usr/sbin/alsa-info.shthat will give you a URL. Please post that URL here.

Without knowing your precise configuration, I can not make a good recommendation.

In addition to running the script (to obtain up to date information), please, to test if your sound is working, I recommend you try copy and pasting the following into a gnome-terminal or a kde konsole:speaker-test -Dplug:front -c2 -l5 -twavyou should hear a lady’s voice saying “front-left”, “front-right” five times. Note Linux is case sensitive.

If that does not work, please try a shorter form version:speaker-test -c2 -l5 -twavIf you hear sound (ie if you hear the lady’s voice), then please post here, let us know this fact, and explain more as to what your sound problem might be.

speaker-test 1.0.18

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 16384
Period size range from 32 to 8192
Using max buffer size 16384
Periods = 4
was set period_size = 4096
was set buffer_size = 16384
0 - Front Left
^C (had to break as it hung)

speaker-test -c2 -l5 -twav

speaker-test 1.0.18

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 8192
Period size range from 1024 to 1024
Using max buffer size 8192
Periods = 4
was set period_size = 1024
was set buffer_size = 8192
0 - Front Left
1 - Front Right
Time per period = 2.878062

This one kept going (till I broke out), but no audio. I know the driver issue is a problem as the keyboard volume control used to display the current volume on screen as well which it’s not.

Thanks again.

ok, and reference my previous post? Did you rerun the script file? … ie this post:

To re-iterate, without knowing your precise current configuration (as provided by re-running the script), I can not make a good recommendation.

Sorry, well a few updates today didn’t help, but did remove the error’s on the rcalsound restart, see;

ZioN:/etc/modprobe.d # rcalsasound restart
Shutting down sound driver done
Starting sound driver: hda-intel done

Still no sound, but here is the updated config…

http://www.alsa-project.org/db/?f=e1208ad45e90af9bbac71a591c2017f3c78e95f5

A few updates today? What did you update? I confess I’m not smart enough to figure out why an update was done on your PC, when no details as to the update are provided. Can you explain ?

Anyway, when I looked at the script, I note this:

!!ALSA Version
!!------------

Driver version:     1.0.16rc2
Library version:    1.0.18
Utilities version:  1.0.18 

You have an alsa 1.0.16rc2 driver, with a 1.0.18 library and utilities. Not a good idea.

So when I look at this:

I see you are missing the driver! You are missing alsa-driver-kmp-default.

If you carefully read this page Alsa-update - openSUSE you will see there are six zypper commands that you must send to update your alsa. The last three commands add alsa-driver-kmp-default. So please resend the precise six zypper commands again (that you need). And then restart your PC and test your sound with:speaker-test -c2 -l5 -twav

If you can not figure out what the six zypper commands are from the URL that I provided, please advise, and I will post them here for you.

zipper commands were no problem. All were done, no errors given, updated info here;

http://www.alsa-project.org/db/?f=69dde91a61140905a93aafad72cacce362f1da3c/

I confess I’m not smart enough to figure out why an update was done on your PC, when no details as to the update are provided.

I just noticed there were a few updates waiting on the taskbar, checked and nothing was sound/alsa related, it might have been something from last week, etc, it was a long weekend, but just wanted to note that a rcalsasound restart no longer gave that error.

You have an alsa 1.0.16rc2 driver, with a 1.0.18 library and utilities. Not a good idea.

In the 1st post and after I saw no .16 when I queried (rpm -qa) and didn’t happen to catch it on the alsa info, but you will see from the updated config posted it now shows .18a.

The speaker test didn’t hang, but still no audio;
speaker-test -c2 -l5 -twav

speaker-test 1.0.18

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 8192
Period size range from 1024 to 1024
Using max buffer size 8192
Periods = 4
was set period_size = 1024
was set buffer_size = 8192
0 - Front Left
1 - Front Right
Time per period = 2.856397
0 - Front Left
1 - Front Right
Time per period = 3.008179
0 - Front Left
1 - Front Right
Time per period = 3.007935
0 - Front Left
1 - Front Right
Time per period = 3.008040
0 - Front Left
1 - Front Right
Time per period = 3.007966

Please, can you type in a gnome-terminal or a kde-konsole:rpm -qa | grep alsa
rpm -q libasound2
uname -aand post here the output so that I can do a quality check on your installed rpms ?

Now I see you have 3stack applied on your stac9228. I assume that is the setting that worked for you before ? I note for the stac9228 the following from the alsa-configuration.txt file:

	STAC9227/9228/9229/927x
	  ref		Reference board
	  3stack	D965 3stack
	  5stack	D965 5stack + SPDIF
	  dell-3stack	Dell Dimension E520
	  dell-bios	Fixes with Dell BIOS setup 

The fact that I see “stac9228” twice in the diagnostic script suggests to me once was from the autoprobe, and once from your /etc/modprobe.d/sound file. Hence I believe that to be correct.

I do not have that hardware, but I have some questions on your mixer (and suggestions):
!!Amixer output
!!-------------

!!-------Mixer controls for card 0 [Intel]

Card hw:0 ‘Intel’/‘HDA Intel at 0xfebfc000 irq 21’
Mixer name : ‘SigmaTel STAC9228’
Simple mixer control ‘Master’,0
Mono: Playback 100 [79%] -20.25dB] [on]
Simple mixer control ‘Headphone’,0
Front Left: Playback 100 [79%] -20.25dB] [on]
Front Right: Playback 100 [79%] -20.25dB] [on]
Simple mixer control ‘PCM’,0
Front Left: Playback 155 [61%] -20.00dB]
Front Right: Playback 155 [61%] -20.00dB]
Simple mixer control ‘Front’,0
Front Left: Playback 100 [79%] -20.25dB] [on]
Front Right: Playback 100 [79%] -20.25dB] [on]
Simple mixer control ‘Surround’,0
Front Left: Playback 127 [100%] [0.00dB] [off]
Front Right: Playback 127 [100%] [0.00dB] [off]
Simple mixer control ‘Center’,0
Mono: Playback 127 [100%] [0.00dB] [off]
Simple mixer control ‘LFE’,0
Mono: Playback 127 [100%] [0.00dB] [off]
Simple mixer control ‘Line In as Output’,0
Mono: Playback [off]
Simple mixer control ‘IEC958 Playback Source’,0
Items: ‘Digital Playback’ ‘ADAT’ ‘Analog Mux 1’ ‘Analog Mux 2’ ‘Analog Mux 3’
Item0: ‘Digital Playback’
Simple mixer control ‘Analog Loopback’,0
Mono: Playback [off]
I see you have Master @ 79%, PCM @ 61%, and Front @ 79% . This may be the optimal level to avoid distortion, but right now we are trying to sort basic functionality. Move them up to 95% for the tests. Once you have basic sound, you can move them back to their optimal levels.

I note you have Surround OFF, Center OFF, and LFE (bass) OFF, yet you have them up to 100%. What is your intention there?

I see you have chosen digital playback. Is that correct?

Your Analog loopback is OFF. I think that is correct, but it does not hurt to test to see what happens with it ON.

Please continue to use the sound test that I recommended. Also check your hardware connections (if this is a desktop). I’ve been fooled before by the wife (or the maid) mistakenly disconnecting/reconnecting the audio lines.

alsa-plugins-pulse-1.0.18.git20081122-1.10
alsa-devel-1.0.18.git20081212-1.1
alsa-plugins-pulse-32bit-1.0.18.git20081122-1.10
alsa-plugins-1.0.18.git20081122-1.10
alsa-tools-1.0.18.git20081201-1.3
alsa-1.0.18.git20081212-1.1
alsa-firmware-1.0.17.git20081202-2.1
alsa-oss-1.0.17.git20080715-2.30
alsa-driver-kmp-default-1.0.18.20081221_2.6.25.18_0.2-1.1
alsa-utils-1.0.18.git20081122-1.6

libasound2-1.0.18.git20081212-1.1

Linux ZioN 2.6.25.18-0.2-default #1 SMP 2008-10-21 16:30:26 +0200 x86_64 x86_64 x86_64 GNU/Linux

As for the volume’s and selections, they have changed since the audio stop as I have been testing numerous ways hoping to stumble upon something.

Tnx

I recommend, until you get your sound working, that you leave the volume levels at 95%.

I can’t help you with your mixer, if I do not see your settings.

From what I can see now, your sound is configured properly and should be working.

If you can not get this to function by tuning your mixer then you should raise a bug report.

k, thanks for everything.

It’s not ‘earth shattering’ but doing things, tests, is what really makes you learn the OS more, so I appreciate the help, feedback ideas and commands.

Lr