Update broke NSS

Hi all,

This morning I received a nss-mdns update (and some more) and now all applications using certs don’t work.

Mostly I get nss_error=-8023 and Error initializing NSS with a persistent database

I tried to search the web but the only browser I have currently is the one in my phone and I am not getting many useful hit.

Anyone else having problems?

What version is your nss-mdns?

Checked on one of my systems, it hasn’t been updated… is from the OSS and is version 0.10-68.3

Run the following

zypper info nss-mdns


hello, I also have this problem with Firefox and Chromium. How to solve the problem ?

Hello again,

I temporarily removed the Mozilla update repository

URL: http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_42.3/
Category: YUM

This is what I did. The problem was even bigger then my first post. When I rebooted, x didn’t start. Got a log file of NSS errors and files that couldn’t be written even when rights were set ok.

I ended up with zypper re-installing all installed packages. Mozilla-NSS was trippin over java 1.8 according to zypper. So I choose the option to remove java and install mozilla-nss and then my system worked perfectly again. Sorry for not posting the logs and stuff, but this was my work laptop and I am a self-employed contractor. So I couldn’t really wait for a solution. I also bought a second SSD disk for this work laptop and it now contains an image from my working Suse installation on the other SSD disk. But with less updates :slight_smile:

So now I can always go back a bit to a working system.