Update attempt after upgrade to 15.4 gives error message and sound cards are not working.

I dont understand why the upgrade from 15.3 to 15.4 has given me problems. This is the first time I have had difficulty upgrading a Leap release.

I could use some help in solving two problems with my upgrade from 15.3 to 15.4 When I attempt to update I get the message

  the to be installed patch:openSUSE-SLE-15.4-2022-2977-1.noarch conflicts with 'util-linux.x86_64 


How should I resolve this?

I wonder why my sound cards are not working? I cant configure them in YAST.

Any help appreciated. Thanks.

Show output from

zypper lr -d
sudo zypper up

There are multiple threads about various updates conflicting with opensuse-SLE-15.4* already. The mirrors are inconsistent. Zypper patch and yast patches cannot deal with it. I have no first hand experience with the failure, as in my 30 or so 15.4s I only update via zypper up.

Sound is working now bur conflict problem remains. The zypper up command did not solve this problem…
Any help appreciated. Thank you.

Problem apparently resolved with ‘zypper patch’ command

Post the full output (command prompt to command prompt) of:

zypper lr -d
zypper up
zypper patch

so we are able to see what you are seeing…

Edit: OK all is good, ignore my post.

Well, I thought all was good, however the zypper patch command wiped out my TP Link Archer T4U v2 USB Wireless adapter. Wow . . . the problems never end!!! It doesn’t even show as an available connection now. This is disappointing. Any advice? Should I start another thread under hardware? Thanks.

I downgraded from WPA3 to WPA2 and got my connection back. Maybe I should look for another adapter?

Depends whether you want, or need, the additional security offered by WPA3. Although you should consider the types of clients that must be able to connect to your WiFi network. WPA3 provides a more secure connection than WPA2, but many WiFi devices might not yet detect WPA3 and support only WPA2.