update and software instalation problem

processor: Intel® Core™ i3 CPU M 370 @ 2.40GHz × 4
graphics: Intel® Ironlake Mobile x86/MMX/SSE2
base system: openSUSE 13.2 (Harlequin) (i586) 32-bit

sir im not updating my system.it creates problem.
problem detail: Empty destination in URI: hd:///?device=/dev/disk/by-id/scsi-20001020000060804

please help me sir.

Use YaST > Software > Software Repositories. Then select the entry that has hd:///?device=/dev/disk/… in it. Uncheck the box Enables (below) and click OK.

It is your installation DVD that is still in the list, but not in your system.

sir, please help me which Software Repositories i enable and which not enable.

When you did nothing speacial after the install, the advice above is the only thing to do

When you are in doubt, post what you have

zypper lr -d

Post the output here between CODE tags (the # buton in the tool bar of the post editor.).


Like what Henk already told you. Disable the repos from yast (required to be root).

yast2 sw_single

That being said you can do it using zypper too. (but please consider using yast first)

If you want to check which url your repos it points to.

zypper lr -u | awk '$1 ~/^[0-9].*/{print $NF}'

Now if you want to filter out repos that is not http or ftp

zypper lr -u | awk '$1 ~ /[0-9].*/ && $NF !~ /http:|ftp:/{print $NF}'

That prints the repos that is most likely giving zypper an error.

If you want to disable it (as root) run

mapfile -t repos < <(zypper lr -u | awk '$1 ~ /[0-9].*/ && $NF !~ /http:|ftp:/{print $1}')
zypper mr -d "${repos@]}"


sorry it should be

yast2 repositories

not sw_single, my bad.

If I say anything here that you already know, do not be offended. The information is also meant for any completely fresh newcomers who may know less than you.

From your menu, launch Yast (it will ask for your root password).

In there, select this (the green highlighted module in this graphic):


When you have done that, it will take a few moments to refresh and load the repositories. You will then see this screen. In here, select the check marks as follows, make certain all other repositories do not have check marks, at least for now:


Any other questions, come back and ask.:wink: