Unwanted Chrome systray icon

Hi

Does anyone know how to get rid of the icon that Google Chrome puts in the systray? I’ve tried everything I could find to do. You can see it in the image next to the HP icon.

Cheers

Fred

Suse 13.2, KDE 4.14.8, Chrome 43.0.2357.130 (64-bit)

http://i100.photobucket.com/albums/m5/fred_jones2/Screen%20google%20icon_zpszwfkn0fs.jpeg

Check to see if any of the chrome extensions you have are causing an icon to appear. I checked with KDE Plasma 5 and don’t see an icon. Unfortunately, I don’t have KDE 4 installed on here to see if this is normal.

Right click desktop select unlock widgets. A almond appears in the tray at the right click. hover over icon close it to remove right click desktop lock widgets

Please don’t!
This will remove the whole system tray.

You cannot remove single system tray icons (you’d have to tell the application to not show one in the first place), you can hide specific ones in the “System Tray Settings” though (right-click on the small up-arrow to reach them, the icon should be listed in the “Entries” page).

OK, here’s where I am just now:

zen: Disabled all Chrome extensions; no change.

gogalthorp: I actually did that previously, and as wolfi323 says, it’s a bit overkill! :slight_smile:

wolfi323: Yes, that also occurred to me. The difficulty is that Chrome doesn’t appear as an entry in the list.

http://i100.photobucket.com/albums/m5/fred_jones2/Screen%20google%20icon2_zpshyeaqji3.jpeg

It’s probably that “ksystraycmd” entry.
If that’s the case, you seem to actually start it via ksystraycmd, and this creates the system tray icon (that’s its purpose).
So modifying the .desktop file/menu entry or the start script (not sure what applies, I don’t have Chrome installed) to start Chrome directly without ksystraycmd should remove the icon completely.

Yes, so you’d think setting ksystraycmd to “hidden” would remove the icon, but it doesn’t.

[/size]

Hmm. Don’t know where either of those things might be. >:(

Yes, it should.
Unless that’s something different.

The first reply in this thread seems to indicate that Chrome uses an old-style system tray icon (which are not supported in Plasma5 any more) though, I think those cannot be hidden as KDE’s system tray does not have any control over such icons.

Hmm. Don’t know where either of those things might be. >:(

You could just use the menu editor, or right-click on the starter icon to modify its settings.
If there’s a start script it’s probably in /usr/bin/ or /usr/local/bin/.

But I found this meanwhile, maybe that helps?
https://productforums.google.com/forum/#!topic/chrome/babyOtRtMuw

[FONT=Roboto]We’ve just released a new version of Chrome, 36, which provides more options for managing Chrome Notifications. In summary:

**Chrome Desktop Notifications: **[/FONT]We’ve updated your ability to manage which Chrome Notifications you receive and to hide or display the notifications icon. To learn more, please visit our help page here.

[FONT=Arial]To *manage your notifications: *Open Notifications, click on the gear icon and deselect websites and apps for which you don’t want to receive notifications. [/FONT]
[FONT=Arial]To hide the notification icon in Windows: In your system tray, click the notification icon, Click Customize and Change the Google Chrome icon behavior to “Hide icon and notifications”. This will put the icon in the overflow area of the system tray. [/FONT]
[FONT=Arial]To hide the notification icon in Mac: Click Chrome in your top menu bar. Select “Hide Notifications Icon” from the drop-down menu.[/FONT]

Just thought I would chime in here, because for me chrome definitely appears in the system tray list. The kicker is that setting them to “hidden” does not hide them. Instead, it seems to move them out of the system tray. Weird. I’m on on kde 4.14, opensuse 13.2.

Edit: I say “them” because I also have the Hangouts plugin icon next to it.

That does not remove the tray just the icon which you place mouse over

A tab pops with a wrench and a X press the X to remove the icon.

If you do this over a bare part of the panel you can remove it but if you are over an icon the icon/short cut is removed

If in the system tray then again unlock widgets press almond right click tray select system tray settings fix things there.

Note that programs that put them selves in the tray will do so any time they startup. You must adjust things in the program’s settings if any ae available.

The pic look like it is just a short cut on the panel not in the system tray??

Hm, Chrome/Chromium’s XEmbed system tray icon handling seems to be completely broken anyway:
http://code.google.com/p/chromium/issues/detail?id=419673#c32
Apparently installing libappindicator (not sure whether 1 or 3) might help, as Chrome should use that then for its system tray icons.

No. You cannot remove system tray icons that way. You can only remove the complete system tray.

You can do this with the application launchers on the left side of the screenshot, but not with the system tray icon on the right side (next to the HP icon).

If in the system tray then again unlock widgets press almond right click tray select system tray settings fix things there.

Yes, I’ve suggested this already, but apparently there is no Chrome entry there.

Note that programs that put them selves in the tray will do so any time they startup. You must adjust things in the program’s settings if any ae available.

Yes.

The pic look like it is just a short cut on the panel not in the system tray??

There is a Chrome icon in the system tray too (next to the HP icon), and the OP wants to remove that, as explained in the first post.

That looks like on short cut on the panel to me not on the system tray

No. It would be bigger then. Compare the size to the ones on the left side of the panel…

Ok I guess there is on on the tray also did not notice that one. Well it is chrome what do you expect?? It is broken by design. :open_mouth:

I sometimes use “chromium” (not “chrome”) to check my gmail. When I do, I see: “Click here to enable desktop notifications for gmail.”

I expect that if I were to click there, it would put something in the tray.

Yes! I started K Menu Editor as you suggested, and guess what - there’s a “Place in system tray” checkbox! So this is a KDE function. Uncheck and the icon disappears!

Many thanks

Fred

Yeah, right. That option actually uses ksystraycmd to run the application to place it in the system tray.

But it seems that Chrome can display a system tray icon by itself too.

Try clicking on the Chrome icon in the systray and deselecting “Let Google Chrome run in the background.” That might not be what you want, but that’ll get rid of the icon.