Unusable blank/artifacts screen after greeter


I recently upgraded from 42.3 to Tumbleweed and logging into my system is very unstable in that I can’t get to my desktop. OS boot up gets to the lightdm-gtk-greeter and displays that interface without any issue. Problems start when I type in my credentials and hit enter, and they’re usually a blank screen or the following artifacts:

Captures of the artifacts post greeter:

A ctrl+alt+del always works to force a restart. I briefly used the 4.10 kernel and did not experience these issues and I am now using the 4.16.6-1-default kernel.

I use the following kernel parameters due to this article, since the boot up process usually hangs after “fb: switching to amdgpudrmfb from VEGA VGA”:

**radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1**

Some system info:

System:    Host: Spectre2 Kernel: 4.16.6-1-default x86_64 bits: 64 gcc: 7.3.1 Desktop: Xfce 4.12.4 (Gtk 2.24.31)
           Distro: openSUSE Tumbleweed 20180502
Machine:   Device: desktop Mobo: ASRock model: X370 Taichi serial: N/A
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Hawaii PRO [Radeon R9 290/390] bus-ID: 2d:00.0
           Display Server: x11 (X.Org 1.19.6 ) driver: amdgpu
           Resolution: 2560x1080@60.00hz, 1920x1080@60.00hz, 1920x1080@60.00hz
           OpenGL: renderer: AMD Radeon R9 200 Series (HAWAII / DRM 3.23.0 / 4.16.6-1-default, LLVM 6.0.0)
           version: 4.5 Mesa 18.0.1 Direct Render: Yes

The system intermittently starts properly about one in eight attempts, or sometimes will start when I spam ctrl+alt+del and it produces a xfce login splash instead of rebooting. However, I will experience the issues described above if I log out and attempt relogin. I wish I knew how to better describe the problem, I’ve searched as well as I could and spent all day yesterday troubleshooting this issue.

Anybody have any guidance?

How did you upgrade?
Repos involved ?

zypper lr -d

Upgraded via Online Upgrade, repos:

# | Alias                                | Name               | Enabled | GPG Check | Refresh | URI                                                 --+--------------------------------------+--------------------+---------+-----------+---------+-----------------------------------------------------
1 | packman.inode.at-openSUSE_Tumbleweed | Packman Repository | Yes     | (r ) Yes  | Yes     | http://packman.inode.at/suse/openSUSE_Tumbleweed/   
2 | repo-debug                           | repo-debug         | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/tumbleweed/repo/debug  
3 | repo-non-oss                         | repo-non-oss       | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/tumbleweed/repo/non-oss
4 | repo-oss                             | repo-oss           | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/tumbleweed/repo/oss    
5 | repo-update                          | repo-update        | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/tumbleweed/     

I discovered, after typing in my user/pass at the greeter and experiencing the aforementioned issues, that I can hit ctrl+alt+del once and the artifacts disappear and my screens turn off. Providing some keyboard input turns them back on and I get the greeter once again. At that point, I am able to log into my desktop environment after entering my username/password again. This behaviour appears to be consistent.

While I can get to a working desktop, I’d like to know what I’m doing incorrectly.

Well, your repo list is OK, nothing wrong with that. Please have a look at the compositor settings, or try disabling the desktop effects,

… or, maybe even try switching to another Display Manager, see if problem goes away.

… and report back.

I switched to GDM (from lightdm) after the issue started in an attempt to resolve it. I’ve been using GDM the past few days and haven’t had much difficulty getting to a working system. I just now switched back to lightdm, and then attempted to use sddm.

Using lightdm required more effort to get to a working desktop - hitting ctrl+alt+del once after greeter was not effective and I had to reboot twice by spamming ctrl+alt+del. Using sddm proved to be the most difficult, with multiple reboots to get to a now working desktop.

One thing that did not exist before the TW upgrade - I have to login twice. Initial login will take me to the desktop (when it works), and then about 15 seconds later I’ll get kicked out of my desktop and back to greeter where Ill have to login again.

I have seen that problem on a couple systems with lightdm, installing and switching to kdm on those systems fixed it.

I have seen similar problems on several machines with sddm, and on those switching to lightdm would help some, switching to kdm on others helped them.

Note, also, that sddm does not support VNC, if you find you want it.

kdm is no longer officially supported, but it is in the repos, so you can find it in Yast software manager and install it, then switch to it.

AFAICT, the problem has to do with specific graphics: a couple or more specific intels, certain amd chipsets, and ???

As for the double-login problem, that rings a bell, so that has probably been dealt with in another thread or two in the forums, if you can find them.

I do not seem to have very good search skills when hunting for a specific thread on the forums, though, which makes me quite jealous of a few of the others here who seem to be able to find such things almost instantly.:stuck_out_tongue:

OP seems to indicate use of three displays. How are they connected, in a DisplayPort chain? If it was mine I’d be asking about this in the xorg-driver-ati@lists.x.org mailing list, a possible regression in kernel or amdgpu driver. Have you tried using the modesetting Xorg driver? I kept the TW kernel-default-4.15.13 rpm here. Let me know if you want to see what it does.

My R9 290 has 4 connections; 1 DisplayPort, 1 HDMI, 2 DVI. Two monitors use DVI, the other hdmi. I haven’t tried using the modesetting Xorg driver yet, and I’ll examine that as well as asking that mailing list for guidance.

Thank you for your suggestion.

Appreciate the info, Ill give a few other DMs a try as well. My forum search skills aren’t anything to brag about, but I definitely have the motivation to find those threads.

I realized that I was misusing terminology in describing my problem. I meant to write display manager where I have written greeter.

Having said that, I’ve noticed that GDM kept loading first regardless the changes I made to /etc/sysconfig:
ps aux | grep -i greet

gdm       1325  0.0  0.0 205872  8580 tty7     Ssl+ 17:19   0:00 /usr/lib/gdm/gdm-x-session gnome-session --autostart /usr/share/gdm/greeter/autostart
gdm       1354  0.1  0.1 572944 16764 tty7     Sl+  17:19   0:00 /usr/lib/gnome-session-binary --autostart /usr/share/gdm/greeter/autostart

^ Had kdm set as display manager, this was captured before I entered my login info by dropping into a console (ctrl+alt+f1).

Uninstalling GDM resolved all my aforementioned issues. I previously used gnome on this system before switching to xfce, but I’m not sure where the instruction to load gdm exist(s/ed).

Thanks again for all the help folks.

Glad you have it solved!

And thanks for coming back to let us know.:slight_smile: