unsupported screen resolution for install

howdy all!

I got my hands recently on openSUSE 10.2 (ppc) to put on my b&w powermac g3. i can boot from the cd and it gives me a text prompt and the choices install, rescue, and something to do with the network (which is whatever), and a not-very-helpful help option. so i type install, and my monitor says “input not supported.” i figure, “ok, that’s cool, i’ll just plug in one of my old crt monitors 'cause it must be trying to use a resolution lower than my fancy-schmancy one supports.” plug in the old one, restart, type “install,” same thing. i’m not new to linux, but i don’t really have any options with this prompt that any manner of googling or thread-hunting can uncover which allows me to specify the resolution at which the yast installer starts (or refresh rate, maybe that’s it…) or lets me keep it in text mode through the installation. I tried typing “install textmode=1” which seems to do nothing special (same result as just “install”) and just “textmode=1” (which is a fundamentally retarded approach, but what else am i supposed to do?). Once the operating system is installed and i can boot into a terminal, i figure can edit the xorg.config to use the resolution i want, but i can’t very well install the system without seeing what i’m doing! It’s just confusing 'cause it doesn’t seem to like any display i give it.

help please! thanks!

That is old hardware, and legacy OS version too. This wiki page states

The last offical openSUSE POWER/PPC release is 11.1.

Support from here will be limited. You might have to do more searching via google on this one.

I note this page

PPC Installation Issues - openSUSE

mentions another possible install option is to use

install acceleratedx=1

to use the native ATI Xorg driver during install.

Good luck.

Thanks a lot for your response, but I’m not sure the people who wrote that guide you pointed me to (which I read in its entirety, by the way) actually ever used the install disc; there are no options besides the ones I mentioned in my post above. This little bit from the guide looked promising:

"If there are troubles getting into the graphical installation screen (and you’re welcomed with a text based one), you may want to try the following variant when booting the system:

boot cd suseboot/inst32 video=radeonfb:1024x768@75 linemode=0"

until I realized that it simply doesn’t work. The prompt on startup is “boot:” - so i tried omitting that part (among SO many other things), but how am I supposed to try a variant when booting a system that has no system on it to boot? I can’t very well make changes to a CD at startup (or CAN I…?). Is the installer decidedly different in this shoot? And if so, why would it have been done this way? It just doesn’t make any sense to me. If all the community can do is just explain to me WHY it won’t work, I’d be happy and wouldn’t hate this distro for the rest of my life (that’s a joke, y’all). Seriously, though, I had debian on this thing once upon a time, but I don’t have anymore CD’s or money to go buy more. I figured when the internet told me 10.2 for ppc would install lickety-split on a b&w powermac g3, it was telling me the truth, and hey, I was suckered in (I’m usually a fedora/ubuntu guy) by that awesome lizard y’all have. Thanks again, guys, and just to be clear, not a single part of the above was written with any amount of hostility. I just hope you can help me out. Thanks!

The reality is 99.9% of us here would not be familiar with installing suse on ‘old world mac’ hardware like this. I wouldn’t even recommend using suse 10.1, as its no longer supported anyway. It may be better to try Ubuntu if it still supports ppc hardware. Some other places that might offer better support:

Why Run Linux on a Low-end Mac?


A thread I found with a google search using ‘mac g3 suse how to’

Installing SuSE Linux On iMac G3 PPC