Unsupported Character in Firefox

I newly installed openSUSE 11.1 with GNOME Desktop in my PC. Everything fine, except Firefox. When I using Firefox for internet browsing, it’s not supporting for south Indian language and shows unsupported characters :’(
Especially Tamil (Since I used to read lot of Tamil online news papers)

I also I tried some tricks suggested by various online help sites, but nothing works for me >:(. So can anyone please help me how to fix this problem to resolve it?

Thanks in advance
Vinoth T

In any case the package *indic-fonts *must be installed. It is very likely that you have it already, but when not, goto YaST > Software > Software Management, serach with *indic *in the search filed, select right and continue. Now at least your system has them.

I am not sure that FF works OK now. There are several threads here where we came to the conclusion that FF has its own set of fonts, seperate from what is on the system. And here I must stop, because I do not know how to add fonts to FF. Let us hope someone else knows and answers this.

I am an KDE user and I know that Konqueror does use the system fonts and thus gives different results from FF. I do not know what the default browser for Gnome is, but you can try Konqueror also under Gnome.

As you gave no demonstration/test URL to try things out, I can not add the results from a test from here (could not find a Tamil newspapaer that fast).

What exactly do you want? You want to use firefox to see south indian characters or something else?

Simple, Firefox shows Tamil language character as un-supported character, which should be fixed

Great, Just after my previous post, I’ve fixed it. I just installed indic fonts thru online. Now I could able to read tmail text in Firefox.

My special thanks to ‘hcw’

Thank you :slight_smile:

Never mind, it is resolved already!

You are welcome. It is easy, but it is not easy to find out yourself that that is the package to install.