Unstable wireless network connection.

Hi,
Some time back, I was having trouble with wireless internet connection when I was using K Network manager. I changed the network setting to ifup, and I felt ok.

But now I found, every minute or two internet will go down and it comes up after some time.
That is irritating.

Somebody please help me in solving this.

I am having opensuse 11.3

My device is
07:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection [8086:4229] (rev 61)
Subsystem: Intel Corporation Vaio VGN-SZ79SN_C [8086:1100]
Kernel driver in use: iwlagn

Thanks,
Binoy

This appears to be quite a common problem, and I have experienced it myself at one particular location (at an old job). I’ve read several threads on this subject, and it seems to me that it is not specific to using network manager, particular wireless chipsets, or authentication method, but often seems related to the router in question. This can esaily be tested of course by trying to connect to another at a convenient location. If the router is yours, try adjusting the encryption-settings or dhcp lease-time if applicable.

Thanks for the comment.
I am having a dual boot system. HP laptop.
At same location, when using windows, no issues with network or signal. very reliable.
I don’t know if I am missing some thing here.

Binoy

On 08/13/2010 05:36 PM, deano ferrari wrote:
>
> This appears to be quite a common problem, and I have experienced it
> myself at one particular location (at an old job). I’ve read several
> threads on this subject, and it seems to me that it is not specific to
> using network manager, particular wireless chipsets, or authentication
> method, but often seems related to the router in question. This can
> esaily be tested of course by trying to connect to another at a
> convenient location. If the router is yours, try adjusting the
> encryption-settings if applicable.

Dropping a connection might be caused by interference or by the router or …
Please post the output from dmesg detailing the reason for deauthentication.

If you control the router, you might try changing the channel. Pick from 1, 6 or
11, whichever is least congested or not currently being used. I will assume you
know enoughnot to use any other channels.,

Thanks for the comment.
I am having a dual boot system. HP laptop.
At same location, when using windows, no issues with network or signal. very reliable.

That was my experience. The windows networking was ok, but periodic disconection occurred with linux. Same behaviour regargless of ‘tradional ifup’, NM, or wicd.

Dropping a connection might be caused by interference or by the router or …

I’m no longer at this job, but my first (obvious) thoughts were interference, but it didn’t manifest when in a windows environment. It appeared to be related to the way this particular router behaved with the Linux wireless system. Maybe windows is more tolerent of dropped connections (with spurious noisy environments). I found connectivity was ok with other wireless networks. (It would have been nice to test another router in the same locality). Anyway, I’ve not experienced this elsewhere.

Here is the ouput of dmesg (last few lines)

395.561626] wlan0: authenticated
395.561796] wlan0: associate with 00:14:d1:56:5f:4a (try 1)
395.563997] wlan0: RX AssocResp from 00:14:d1:56:5f:4a (capab=0x431 status=12 aid=2)
395.564004] wlan0: 00:14:d1:56:5f:4a denied association (code=12)
395.564084] wlan0: deauthenticating from 00:14:d1:56:5f:4a by local choice (reason=3)
397.483364] wlan0: authenticate with 00:14:d1:56:5f:4a (try 1)
397.487415] wlan0: authenticated
397.487613] wlan0: associate with 00:14:d1:56:5f:4a (try 1)
397.489708] wlan0: RX AssocResp from 00:14:d1:56:5f:4a (capab=0x431 status=12 aid=1)
397.489714] wlan0: 00:14:d1:56:5f:4a denied association (code=12)
397.489792] wlan0: deauthenticating from 00:14:d1:56:5f:4a by local choice (reason=3)
399.312120] wlan0: authenticate with 00:14:d1:56:5f:4a (try 1)
399.313918] wlan0: authenticated
399.314097] wlan0: associate with 00:14:d1:56:5f:4a (try 1)
399.407811] wlan0: RX AssocResp from 00:14:d1:56:5f:4a (capab=0x431 status=0 aid=1)
399.407818] wlan0: associated
428.918089] SFW2-OUT-ERROR IN= OUT=wlan0 SRC=192.168.10.103 DST=130.57.4.15 LEN=831 TOS=0x00 PREC=0x00 TTL=64 ID=56803 DF PROTO=TCP SPT=40174 DPT=80 WINDOW=1002 RES=0x00 ACK PSH FIN URGP=0

Help is appreciated !

Thanks,
Binoy

Just searching (via google) ‘deauthenticating local choice (reason=3) denied association (code=12)’ and similar, yields hundreds of similar threads across multiple distros. I hope this can be nailed down to a particular cause in your case. While waiting for other responses, can you try using wicd instead, and see if the connection time improves for you before being deauthenticated…

Please post output of iwconfig as well:

/usr/sbin/iwconfig wlan0

Hi,
Thanks for looking in to my issue. I appriciate your help.
Here is the output for /usr/sbin/iwconfig wlan0

wlan0 IEEE 802.11abgn ESSID:“TRENDnet”
Mode:Managed Frequency:2.412 GHz Access Point: 00:14:D1:56:5F:4A
Bit Rate=54 Mb/s Tx-Power=14 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=63/70 Signal level=-47 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Regards,
Binoy

Any one have a solution to my problem ??

Have you tried using WICD instead ?

I had the same problem when Ktorrent was working. The wifi turned off when ktorrent was working, then I can’t connet to internet until I reset the router.
I found information in google about to configure ktorrent, then I changed the total conexion, and download-speed . Were you using ktorrent or similar when internet crashed?
I use networkmanager too, opensuse 11.2, Intel Corporation PRO/Wireless 2200BG, ipw2200

Excuseme my bad english,
from Spain

I have had the same problem with opensuse 11.4 and Ktorrent. I will start a torrent to download and after about 2 mins, the Torrent states stalled and I lose my wifi connection. What I did to fix the issue is make sure that I had my port forwarded in my router, opened up the ports in my firewall, and lastly turn my global connections down to 100 in the settings of Ktorrent itself. I have not had the issue since.