Unstable OpenSuSe 11.2 after hardware changes.

Recently, after a hard drive failure, I replaced my old boot drive, and IDE 60GB HD with an IDE 120GB HD, and as well, replaced two older generation 1 SATA (500GB and 350 GB) drives with 2 2TB SATA drives in Raid 1 (Hardware). This machines uses an older A7N8X motherboard with 100 MHz Ram (2 GB) and an AMD 1800+ CPU. The SATA Drives are fed from a silicon images 3124 card. The machine is using OpenSuSe 11.2 32 bit.

One partion of the 120GB drive is NTFS, the other is extended with swap, boot, /. The 2 TB Raid is /home.

No matter whether I used hardware raid or software raid, whenever I do any kind of activity that uses the hard drive a lot I get crashes that lock the machine up completely. Programs stop running, the mouse freezes, etc.

The only way to restart the machine is to turn off the power. It starts normally after it fixes the hard drive partitions.

My guess is that the motherboard is so old and slow it’s not able to keep up with SATA 3 hard drives. I don’t know whether upgrading the memory to PC 3200 (400MHz) and or the CPU - I can go up to an AMD 2800+ is likely to fix the problem or not.

Can some of you suggest whether I should just replace the mobo or the memory and cpu. My dilemma is that money is important, and I don’t want to replace the cpu and memory and then have to buy a new cpu, mobo AND memory.

Alternatively, is there something else I should check first?

Thanks, Bob.

I guess it’s not possible to try without the RAID?

Yes, it is. I’m going to try it this morning.

I’ve tried it without RAID and so far everything seems fine. Even copying three streams of data seems to go OK. I see when I get the TB of data copied over.

Figured it would be OK

It’s not. I was copying a file from one of the two sata 3 drives to another, and when I tried to play a game (pysol ifc) it locked up solid. I had to do a hard reset to get it to go again.

Guess I’ll have to upgrade the mobo , memory , cpu or all of it.

I used to have one of these with an AMD 2200+ as I remember, but this was a long time ago. I am thinking you kind of blew it away with those (2) 2 Terabyte hard drives, worth a lot more than that motherboard/CPU combo. It is kind of like attaching a couple of missile launchers to a Dinosaur. I never want to suggest to someone they should consider replacing a motherboard that works, but really, it is time to spend some money on the main foundation of your system. I would look at some Intel i7 LGA 1156 motherboards/CPU combos. You need to only add the DDR3 memory two sticks at a time and not three as the LGA 1136 line needs. These are getting cheaper since they are moving away from that format and the speed is beyond anything you have seen with that old 1800+. It is just a suggestion, but do consider it and good luck.

Thank You,

It might be worth, before replacing the CPU, to do some basic maintenance, if you haven’t already. A good (but delicate) dust up, remove and re-seat the expansion cards (check RAID card connector, clean with an eraser pencil if needed) and memory. Run memtest from oS install DVD for a few hours at least.

Robert, a few thoughts.

You talk about SATA 3 drives but I think you mean SATA 2 don’t you? (i.e. 3 Gbps drives)

The Sil 3124 comes in two versions 3124-1 just does SATA 1, 3124-2 does SATA 2. The 3124-1 drive may work with SATA 2 drives by downspeeding them. All the SATA 2 cards I’ve found are PCI-Express.

Most 3124-based cards are not hardware RAID, they’re fakeraid.

So the first thing I’d do is check exactly what hardware you’ve got and what drivers and raid configuration is running.

Your symptoms do sound to me like a hardware issue but I couldn’t say exactly what.

If you can’t make it work with your existing system, I wouldn’t bother upgrading just the CPU and RAM. I doubt that will help. I think you’d need to look at a new mobo.

I agree. I ordered a barebones kit from Tiger.ca this morning, and the mobo includes 4 SATA2 ports. Then I 'll just transfer the other hardware to the new case, including the 2 2T drives.

Thanks, Bob