Unresponsive icons on desktop

I don’t know what I did to cause this, but the icons on my desktop are unresponsive. When I click on them, nothing happens – it’s as though they weren’t there at all. I can tell via Dolphin that all the information in the desktop folders is still there. I tried adding a desktop folder and that added folder was visible via Dolphin, but it didn’t show up on the desktop. Even a hard reboot did not change the behavior.

So how can I resuscitate the folders and other stuff on my desktop?

Right click on desktop. Select “Refresh Desktop”.

I’m not sure if that will help, but it is worth trying.

When you talk about a desktop, you better tell first which desktop. Reading furtheron in your post the word Dolphin I assume it is KDE, but to make sure people understand what you are talking about the best thing is to tell them what you are talking about straightforward.

Yes, I am running KDE and I tried refreshing the desktop. Refreshing did not change the situation; clicking (or right-clicking) the icons on the desktop stilldidn’t work. But one observation: there was no difference in the result when I clicked on an icon versus when I clicked on empty space. I always got the normal choices when clicking on empty space.

I tried creating a new user, and saw that the problem did not arise with that new user. So it’s not a system-wide problem, just something wrong in my own user space.