Unpredictable NTFS mounting

My setup is a dual-boot Windows XP / SUSE Linux system, with three data partitions (Linux naitive, NTFS formatted empty space, and NTFS Windows filesystem) and the NTFS volumes are supposed to mount to /windows/C and /windows/D. Sometimes when I boot up, the files are where they should be, in those folders, sometimes they’re not; sometimes one is mounted, sometimes the other is.

Is there a way I can find out what’s wrong and perhaps fix this? I heard perhaps a disk error-check from the Windows side is necessary, but is there anything I can do from the Linux side?

Thank you,


If the windows partition is not shut down properly (hibernate is NOT enough) then you will have difficulty mounting the NTFS drives under Linux with the NTFS-3G driver. There is a work around to force the mounting, but IMHO its far better to shut down MS-Windows properly.

Do you know why this is? It seems strange that the filesystem would be affected by shutdown. Well, not really, if it was writing to the harddrive at the point of shutdown, some lines may not be completed, which makes sense.

Thanks for your quick answer, I’ll have to do some investigating :wink: but I have a feeling you’re right.


Correct. And in this case, you will see a respective warning if you boot in the verbose mode. Press Esc to switch to this mode and see, if this is the case or there are any other warnings.

Have a read of swerdna’s tutorial (forced and failed mounts sections).

There is an ntfsfix utility that has limited ability to correct some basic ntfs errors, but generally booting into windows is recommended along with chkdsk.

Thanks for all of your support. I’m unfortunately still having trouble mounting an NTFS volume that I formatted specifically as fileswap between Windows and Linux. The system sees that the drive is there, but it’s not mounted, and when I mount /dev/sda3, I get an error:

mount: wrong fs type, bad option, bad superblock on /dev/sda3,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

So I dmesg, and it spits this out:

FAT: bogus number of reserved sectors
VFS: Can’t find a valid FAT filesystem on dev sda3.

This is odd, because I’ve tried checking the filesystem in Windows, I’ve formatted it numerous times, and still nothing works.

/dev/sda1 is mounting to /windows/C perfectly, so theres some stress alleviated.

Any help would be appreciated, I’ve tried most anything and am considerably stumped.

What’s the command line or fstab line that mounts it? And can you reproduce here the output from the command:

sudo /sbin/fdisk -l

The output of

sudo /sbin/fdisk -l


Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xd65316e1

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1       10659    85618386    7  HPFS/NTFS
/dev/sda2   *       10660       12617    15727635   83  Linux
/dev/sda3           12618       19144    52428127+   7  HPFS/NTFS
/dev/sda4           19145       19457     2514172+  82  Linux swap / Solaris

And I don’t understand the other question you asked… I used

mount /dev/sda3 /windows/D

to try to mount it.

OK there it is. Chenge this:

mount /dev/sda3 /windows/D

to this:

ntfs-3g /dev/sda3 /windows/D

or equally effective alternative is:

mount -t ntfs-3g /dev/sda3 /windows/D

You have to use the special driver ntfs-3g with the NTFS drives.

Background: HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE 10, 11

A final question:
You are mounting sda3 by entering a command in a console window. Would you prefer to have sda3 mount permanently, automatically at boot time?

Wow, I had no idea. thank yyou so much, this makes my new Eee completely set with Linux! Sorry for being out of the loop for so long, I have forgotten how to do simple things…:frowning:

Yes, I would like it to mount every time I boot Linux, I think the reason it didn’t is because I altered the nature of the partition from a FAT32 to an NTFS after I installed OpenSUSE, and the system probably did the same thing I did, and tried to ‘mount’ the FAT filesystem instead of using NTFS-3G, hence the error: FAT: No valid filesystem.

Which config file do I have to modify? I probably have to delete a few lines to make sure it stops trying to mount it as a FAT32 drive.

Thanks once again, this forum is quick, to the point, and very helpful.

You edit the File System Table, a text file called fstab, located at /etc/fstab.

First take out the line (if any) referring to sda3. That should take care of the attempts to mount a FAT partition.

Then place this line in fstab anywhere:

/dev/sda3 /windows/D            ntfs-3g    defaults 0 0

Finally, make sure the last line is a blank line.

Next time you boot, the partition should auto mount into directory “D”

Other one:

I had the problem with my ext.HD can`t open in suse anymore.
What I did with the ext,HD backup your file and restart you PC go to winxp/vista reformat HD and it is finish you can go back and reinstall the files,what your back up into ext.HD .



Just two things to say here Mike:

  1. welcome back, yours was truly a short absence: Well I`m going:) - openSUSE Forums
  2. to format in this case would be absolutely the wrong thing to do