Unneeded Dependencies 11.2 Gnome

Hello, I am fairly new to RPM based distributions. I like OpenSUSE and the community here, and I wanted to ask a few questions.

I installed using the OpenSUSE 64-bit Gnome live CD. I used the one click installer to enable the Nvidia drivers. Doing so caused the system to want to install about 700mb of packages. I am assuming these are “recommended” packages that normally would be on the DVD with Gnome. There is no graphical way to “not” install them (other than using the QT interface, which I do not want) that I could find from the Gnome software installer, other than to perhaps uncheck them one by one.

I installed Nvidia drivers without such issues by using the “zypper in” command. I would like to use the Gnome interface without having to install all these files along with any package changes. Is there a way to do so?

My second question is related. When running a default upgrade, packages such as foreign locales and translations and the yast qt interface want to install which is making the download take a long time. I only need English. Is there an easy way to disable these from installing?

Like I said, I am new so please be patient with me. I did make an effort to search for such issues, with no avail. If such a thread or tutorial exists, please point it out, and I apologize for double posting. Thank you in advance!

A couple of things:

  1. The 700 M packages probably are updates (security and fixes). The 700 is the size of the packages when installed, not the download size.
  2. Installing the NVIDIA driver with ‘zypper in’ will pass the updates, only installs the driver (and it’s deps).
  3. Language files etc. will only be updated when you installed the languages

In general: Linux is not Windows. Leave the packages where they are.

I figured it out. I just needed to disable all the repositories, and then uninstall all the extra translations manually. That saved me a good hour or two of downloading.

I know Linux is not Windows, and I understand the concept of package management, just not the GTK interface of Yast. I got it working though, thanks for the clarification. I am loving those delta rpms.