unlocking gnome keyring by login process

opensuse 42.2
kde environment
kde framework 5.37(also 5.38) and plasma 5.10.5 (also 5.10.95)

i did not checked for 42.2 and 42.3 default installation. i guess this works.

some apps as skype uses gnome keyring then when you install it then it installs also gnome keyring.

you must chose same pwd for keyring as the user one

edit /etc/pam.d/sddm file

add these statements:

auth optional pam_gnome_keyring.so
session optional pam_gnome_keyring.so auto_start

original contents:

#%PAM-1.0
auth include common-auth
account include common-account
password include common-password
session required pam_loginuid.so
session include common-session

contents after editing:

#%PAM-1.0
auth include common-auth
auth optional pam_gnome_keyring.so
account include common-account
password include common-password
session required pam_loginuid.so
session include common-session
session optional pam_gnome_keyring.so auto_start

i adapted this tuto
https://wiki.archlinux.org/index.php/SDDM#SDDM_and_Gnome-keyring

since sddm 0.16 then sddm automatically unlock the keyring once you log in

see

jeu. 14 déc. 2017 13:00:00 CET || fabian@ritter-vogt.de| - Update to 0.17.0:
|—|—|

  • Added possibility to change border width of ComboBox widget.
  • Added missing utmp/wtmp/btmp handling.
  • Make greeter see icons set by AccountsServices.
  • Fix sddm.conf man page syntax error and update.
  • Fix ComboBox widget.
  • Fix connection of PropertiesChanged event for LogindSeat.
  • Avoid race conditions with Xsetup.
  • Update de translation.
  • Update lt translation.
  • Update zh_TW translation.
  • Adjust order of components in the default PATH.
  • Set default input method to qtvirtualkeyboard.
  • Update to 0.16.0:
    • Support non-latin characters in theme settings.
    • Support fish shell in Xsession and wayland-session.
    • Unlock GNOME keyring at login. <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
    • Configuration directory.
    • Make the default cursor themed.
    • Update date and time in elarun theme.
    • Fix theme metadata default values.
    • Fix session selection in elarun.
    • Do not truncate XAUTHORITY on login.
    • Make enabled property of Button functional.
    • Fix typos in documentation.
    • Re-use existing sessions.
    • Add ConsoleKit 2 support.
    • Stop assuming shadow(5) is always available.
    • Explicitely set XDG_SEAT when starting a user session.
    • Suppress errors when pam_elogind is not available.
    • Suppress errors when pam_systemd is not available.
    • Added possibility to change color of dropdown menu.
    • Add Hindi translation.
    • Completed Swedish translation.
    • Update French translation.
  • Move to system configuration dirs, replace sddm.conf with
    00-general.conf and 10-theme.conf
  • Refresh patches:
    • 0001-Revert-Rename-XDisplay-and-WaylandDisplay-config-sec.patch
    • proper_pam.diff
  • Rename patches:
    • sysconfig-support.patch:
      0001-Read-the-DISPLAYMANAGER_AUTOLOGIN-value-from-sysconf.patch
    • create_pid_file.patch:
      0001-Write-the-daemon-s-PID-to-a-file-on-startup.patch
  • Remove patches, now upstream:
    • 0001-Do-not-truncate-XAUTHORITY-file-on-login.patch
      |

with opensuse you need plasma 5.11.5

I see one issue here: GNOME doesn’t use sddm, but gdm ( IIRC )

@knurpht

the subject of this howto is about unlocking gnome keyring in a kde environment thus using sddm

however …

and …

http://www/files.zimpics.org/os/skype_keyring1.png
http://www/files.zimpics.org/os/skype_keyring.png


… must be some other reason???

Any ideas?

I have had that happen with Ubuntu. It was because I had changed my login password at some time. So I just entered the previous password there. That opened the keyring and reset the keyring password so that this didn’t happen again.

However, I was logged into Gnome at the time. I don’t know what happens if logged into KDE when this occurs.

yes i get this problem.

this problem occurs:

  • randomly
  • at each update of skype

hypothesis : slow answer from gnome keyring for autocompleting id and pwd when skype starts because baloo indexing does many disk accesses when opening a kde session.

in the past i get this problem with hangouts and kwallet.

there is not much to do. to minimize disk accesses perhaps don’t get new mails and akregator rss news during opening kde session for example.

also signal this problem to skype support : help > assistance or help > signal a problem.

check out

https://forums.opensuse.org/showthread.php/527173-unlocking-gnome-keyring-by-login-process?highlight=skype

That worked here

i wrote a bug report

https://bugzilla.opensuse.org/show_bug.cgi?id=1125686

for opensuse leap 15.0 see here https://forums.opensuse.org/showthread.php/531055-15-0-unlocking-gnome-keyring-by-logging-process-in-kde-environment(-gt-sddm)

Hello! That’s an spine -chiling stuff, excellent enough to make someday aspired. The citizens today has become a superlative one than one in the earlier days. So, this kind of post, articles, blogs and newsletters ignites not only the youth’s mind but the whole nation to do something extravagant in the societies development.