unknown problem causing wifi extreme sluggishness

I just installed a dual OS system and am running on the openSuse Leap 15.2 side. However the wifi is accessing the internet at 20-30 bps which is too slow to be usable anywhere.
I have verified:

  1. Cable modem - router (Motorola Arris SBG6580) is good
  2. Using Apple i6s phone verified 35.5 Mbs download 5.7 Mba upload speed via wifi channel 2 when standing in same location as the workstation.
  3. iwconfig shows wlan0 is set at 144.4 Mbs and 20 dbm. Quality is 40/70
  4. hardware is Asus PCE-AC51 PCI-express card supposedly capable of 433 Mbs
  5. Motherboard is HP Z420 workstation

However pinging the Arris SBG6580 cable modem shows that the ping time varied from 2.1 msec all the way to a whopping 329 msec with wierd bouncing between 2+ msec then 100-300msec
I did NOT see a stable ping time when letting ping run (no other programs loaded in the machine)

When connecting to the internet, the connect speed is an incredibly slow 20-30 bps and it becomes totally unusuable.

wlan0 is configured to IPV4 type

Any ideas on how to trouble shoot this issue? I loaded knoppix 8.6 into the system and tried it and it could NOT run the http://speedtest.xfinity.com speed test either. However I did use the Konqueror browser, got an 80% load of the page almost immediately, finally it loaded 100% and when I ran the test the browser was destroyed. Tried 2 more times, each time the Konqueror browser was killed.

It is almost as if molasses has been poured into the internet connectivity.

I need the internet to do the updates to the installed software.

  • Randall

Some issues found after checking with ISP supplier:

  1. The ISP supplier abandoned my cable-modem-router in the past but never bothered to tell me about it - they said it is unsupported
  2. The current CMR is the older 802.11n type called wifi-4
  3. The Asus PCE-AC51 card is 802.11ac dual-band type

I have ordered a compatible cable-modem wifi router which should clear up connection issues with the wifi-card

It remains to be seen if I have to order 801.11ac cards for my other two desktop computers.

I am hopeful that this is the source of my problems. My ISP guarantees me 75Mbs download speeds.

  • Randall
  1. You need proper placing for WiFi antennas. With PCIe it is rather difficult. Use USB WIFI card instead, or use cable extenders for WiFi antennas.
  2. Before using WiFi check connection with Ethernet cable.
  3. You need a proper driver to be installed. Supposedly for Asus PCE-AC51 chip is Realtek RTL8812AE. You need driver for it.
  4. If you’re using PCIe card, provide
lspci
  1. With WiFi 4 (802.11n) you can get up to 150 (144.4) MBit/s for 1 antenna. Do you need more?

Hi
I’ve found wavemon is a good tool to see what is what with wifi… it’s terminal based, not a GUI…