Unknown Horizons

Official Site - Unknown Horizons - Welcome to Unknown Horizons

From the downloads page:

openSUSE - Packman Repository

Packages of Unknown Horizons 2010.1 for openSUSE 11.3 can be found here. Does not work for openSUSE 11.4, cause of missing python2.6. If you can provide a rebuild of that package with python2.7, please contact us.

As a openSUSE 11.4 user at the moment I have hope to hope that someone will do the above so I can play this game :stuck_out_tongue:


I’ll take a look into this… keep checking the thread, I will have some news during next week.

I like it, will have to check it out after my last final !

Have now played it on Ubuntu and it has promise :slight_smile: … would be great if it is made available for oS 11.4 :smiley:


Ok, I’ve spoken with the Unknown Horizons developers and I was able to provide a few cool packages for:

  • openSUSE 11.3
  • openSUSE 11.4
  • openSUSE Factory
  • openSUSE Tumbleweed

The 11.4 packages, I did tested them myself, so I know they work… but since I don’t play the game, I’m not sure about their performance… I have also provided 1-Click installer features on the repository I’ve made for this. Please check on the official game page for information, as I’m sure they will have the 1-Click installers there within the next days :slight_smile:

Unknown Horizons :: Unknown Horizons - Welcome to Unknown Horizons

A quick preview…


Taken from: Unknown Horizons - Linux

*** openSUSE 11.3**

*** openSUSE 11.4**

*** openSUSE Factory**

*** openSUSE Tumbleweed**




(When I get a chance I will try it!)

Those installers are for a Development snapshot (has been stabilized, but might have minor issues), and I’ve also submitted the latest stable version (2011.1a) to the games repository (for openSUSE and Fedora).

You can find instructions on how to install the games repository on this article I wrote on my blog.

I installed it, worked the first time I played it. Looks very very good. But now whenever I try and play it it will open a window and then shut it down straight away. Any suggestions?

I would assume it’s a configuration problem with the package. You can try to run the following command to default your setting and see if that solves your issue:

unknown-horizons --restore-settings


As said earlier (and in case you picked an unupdated installer) you should migrate to games repository which holds the latest stable release. It’'s going to be updated in the next days with a few fixes and updated languages.

This can be done by following this steps:

1. Clear the system:
Start by opening YaST Software Repositories module and delete the current game repository you use.
Then open a console, log as root (su -) and proceed to removing the installed packages with:

rpm -e `rpm -qa | grep unknown-horizons`

**2. Add the stable repository (games)**
This can be done by typing the following command (for openSUSE 11.4):

zypper ar http://download.opensuse.org/repositories/games/openSUSE_11.4/games.repo

Now you need to refresh the package cache with:

zypper ref

**3. Install the game**
This is done with:

zypper in unknown-horizons

**3. Clear existing user data**
The game holds it's configurations and settings in ~/.unknown-horizons, we want to clear it.

rm -r ~/.unknown-horizons

Also, if this doesn't solve the issue, just run "unknown-horizons" from the console and link to a [susepaste](http://susepaste.org) document with the output.

Worked wonders thank you. Any ideas if the same would do with NAEV? Seem to have the same problem there really.

With ‘NAEV’ you mean this game[1], I really don’t know, I never heard of it. I would recommend you to file a bug report on it and provide the relevant information like log files or terminal output.

[1] - http://code.google.com/p/naev/

Updated to latest stable release… 2011.2.