"Unknown" display on Intel 945 GME with Opensuse 11.3 and Gnome

The subject pretty much says it all. I’m stuck at 800x600 resolution without 3D acceleration. Configure display settings identifies the monitor as “Unknown”. I’ve searched and found plenty of threads on drivers, but nothing yet about the display not being detected properly. I’m using the LCD display that’s a part of this Acer Aspire One netbook. I’m clueless as to where to look to find the source of the display problems. Any suggestions out there?
Thank you.
-tom

openSUSE Graphic Card Practical Theory Guide for Users

Thanks.
I came across that page earlier. I tried the Xorg -configure method to create the xorg.conf file. On rebooting, it goes into the text-based login screen after messages that the maximum number of X-display errors have been reached. I just login and remove the xorg.conf file to start over.
I did find earlier that the netbook is using the Intel legacy driver for the 945GME. It’s the monitor detection that I’m having a problem with.

I have 2 Intel laptops, neither 945 though. But both mine work out of the box so to speak.

Did you try editing the file xorg.conf as suggested here:

For all openSUSE versions (including 11.3) there is “Xorg -configure”. ie run with root permissions in run level 3

Xorg -configure

which will create the file /root/xorg.conf.new. Copy that file to /etc/X11 with:

cp  /root/xorg.conf.new /etc/X11/xorg.conf 

and then if necessary edit the xorg.conf file, using something like the vi editor . Pay attention to the “Device” section in the xorg.conf file as it will specify the Driver, with a line something like:

Driver  "intel" 

It may be necessary to edit that file/line to change the driver to “vesa” or “fbdev”.

I have tried that. With the driver option set to “Intel”, as Xorg -configure creates it, the Xserver reaches the maximum number of errors and doesn’t start. With the driver set to the other options, vesa and fbdev, it starts, but the problem still exists - the display is “Unknown”, and the resolution and other settings cannot be adjusted. I’ve included the xorg.conf file as the Xorg -configure command creates it.

Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib/xorg/modules/updates"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/misc:unscaled"
	FontPath     "/usr/share/fonts/TTF/"
	FontPath     "/usr/share/fonts/OTF/"
	FontPath     "/usr/share/fonts/Type1/"
	FontPath     "/usr/share/fonts/100dpi:unscaled"
	FontPath     "/usr/share/fonts/75dpi:unscaled"
	FontPath     "/usr/share/fonts/URW/"
	FontPath     "/usr/share/fonts/cyrillic:unscaled"
	FontPath     "/usr/share/fonts/misc/sgi:unscaled"
	FontPath     "/usr/share/fonts/truetype/"
EndSection

Section "Module"
	Load  "dri2"
	Load  "dbe"
	Load  "vnc"
	Load  "glx"
	Load  "record"
	Load  "dri"
	Load  "extmod"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"            	# <bool>]
        #Option     "SWcursor"           	# <bool>]
        #Option     "ColorKey"           	# <i>
        #Option     "CacheLines"         	# <i>
        #Option     "Dac6Bit"            	# <bool>]
        #Option     "DRI"                	# <bool>]
        #Option     "NoDDC"              	# <bool>]
        #Option     "ShowCache"          	# <bool>]
        #Option     "XvMCSurfaces"       	# <i>
        #Option     "PageFlip"           	# <bool>]
	Identifier  "Card0"
	Driver      "intel"
	VendorName  "Intel Corporation"
	BoardName   "Mobile 945GME Express Integrated Graphics Controller"
	BusID       "PCI:0:2:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Something you could try is to install the legacy Intel driver xorg-x11-driver-video-intel-legacy, and then remove your /etc/X11/Xorg.conf file (back it up some where), then go into /etc/X11/50-device.conf and change it to look like:

**Section “Device”
Identifier “Default Device”

#Driver “radeon”
Driver “intellegacy”

Required magic for radeon/radeonhd drivers; output name

(here: “DVI-0”) can be figured out via ‘xrandr -q’

#Option “monitor-DVI-0” “Default Monitor”

EndSection
**
and then reboot and test. (I hope I have that syntax right)

If that does not work, then just undo those changes to revert.

The intel legacy driver was already installed, so that left just removing the xorg.conf file and changing the device file as you instructed. It didn’t work, but thank you for the suggestion.
I’ll be home tonight where I can try a different distro to find something a little more netbook-ready.

We are having the same problem on a Gigabyte GA-945GCM-S2C board with on-board Intel video. Video looks good until you login. The desktop comes up with a bad sync and off centered image that is illegible after you login normally. Safe mode login provides a working desktop up to 1024x1280 and the monitor preferences shows unknown monitor and 0 Hz refresh which cannot be changed.

Everything worked fine on this system with 11.0 distribution. It broke on first login after upgrade to 11.3. Any ideas on how to fix this would be appreciated.

thanks,
dg