Unknown command 'ffmpeg'

installed - tovid 0.33-0.pm.1.1

installed - ffmpeg 0.6.26387svn-1.pm.2.1-i586

openSUSE 11.3 KDE 4.4…4 RELEASE 3

Have been using tovid for a few years and under different os’s [mostly opensuse] but have never had this problem before.

I open a terminal and enter my command to encode an .avi file to .mpeg.

labud@linux-2pci:/home/320VOL/Movies/Journey> tovid -ffmpeg -ntsc -dvd -noask -in JourneyToTheEdgeOfTheWorldS01E01.avi -out JourneyToTheEdgeOfTheWorldS01E01_encoded

This is what follows:

Creating '/home/labud/.tovid'

Creating '/home/labud/.tovid/tovid.ini'


    tovid [command] [arguments ...]

Where 'command' is one of the following:

    Command     Description                                 Formerly


    id          Identify one or more video files            idvid

    dvd         Author and/or burn a DVD                    makedvd

    menu        Create an MPEG menu                         makemenu

    vcd         Author and/or burn a VCD                    makevcd

    xml         Create (S)VCD or DVD .xml file              makexml

    postproc    Post-process an MPEG video file             postproc

    disc        Create a DVD with menus                     todisc

    gui         Start the tovid GUI                         todiscgui

    mpg         Encode videos to MPEG format                tovid

    titlesets   Start the titleset wizard                   (new)

Run 'tovid <command>' with no further arguments to get help on a command,

and what arguments it expects.

Unknown command: '-ffmpeg'


I have done it this way since I started using tovid and it has always worked before.
I am opening a terminal in the folder in which the .avi files reside and it is on a different drive than my home folder. But this is not new either. The ownership and permissions belong to labud [which is me.]

I have recently installed openSUSE 11.3 and this is the 1st time I have used tovid in 11.3.

Tried to google an answer, but nothing came up that was helpful to me.
Have also posted in the tovid ‘HelpDesk’ forum, no answer yet.

What could be wrong?

I assume you are trying to encode your .avi to MPEG? and it looks like your command line is wrong.

tovid mpg -ffmpeg -ntsc -dvd -noask -in JourneyToTheEdgeOfTheWorldS01E01.avi -out JourneyToTheEdgeOfTheWorldS01E01_encoded

I do not use tovid myself so you will need to check that the remainder of the command, after mpg, is still valid.

Neil Darlow

Not knowing anything about what this should do for you, but reading what you call and what you get, I would say that tovid asks from you that the first field has one of the commands it lists. It is clear that* -ffmpeg *is not among that list. Thus the error.

Now in it’s extensive message it also says that those commands had formerly other names (btw none of them again is -ffmpeg). This could point to the fact that the user interface has changed between a “formerly” version and this version of tovid. It is up to you to read the documentation about this. Isn’t there a man page or an info page on tovid on your system? Or some docs out on the Internet?

Yes that does make sense and it gives me somewhere to start. As I had stated I did not receive an answer from the tovid help desk and was at a loss of where to start.
I will certainly read man, now.

I did not have to state .mpg before but this is a new version, so I will check that out also. ty

Will report back my findings

ok it is working now

after I changed the -ffmpeg to mpg in the line of code I was using, it gave me another error - mjpeg2enc, m2enc -files were missing.
Doing a google on that I found that a file called mjpegtools was needed. I checked and found it was installed [from opensuse repo ver 1.9.0-9.3.1]
In the info I found it was suggested that the packman repo version [] was better.
I changed to that version, rebooted and it was working. I am running tovid on a .avi file now and hopefully it will be OK.

All seems to be OK.
Thanks for the Help.