Unity stuck at importing

the only thing preventing me from switching to tumbleweed is game engine: unity. It doesn’t support openSuse, only Ubuntu/Debian and RHEL/CentOS. But as RHEL is also rpm distribution I thought that I would try to install it and installing equivalent of missing dependencies. The only missing dependency it showed me was libuuid which I installed. Unityhub launches without any problem, but when I try to open project it’s stuck at importing. I tried waiting for an hour and nothing happened. Unity doesn’t support openSuse so writing for their help is pointless (someone once tried with another problem and they replied that they do not support this distribution). So I thought maybe you may have some clue that will help solving issue. My guess is that maybe it uses some library that fedora has installed with system and openSuse doesn’t.
Thanks in advance for any answers!

Forgot to mention, but on Fedora 36 it works without any problem. Project imports 2/3 seconds and the editor opens. On ubuntu also that’s how it works. So it’s something with openSuse that makes it hang at importing stage.

Now, Leap 15.4 is also affected. It’s not working there either. So something in tumbleweed and between 15.3 and 15.4 must have been changed that it’s not working anymore