UNISON 2.40.63 (opensuse 12.1) on old openSUSE 11.2

Hi
i want to use UNISON to sync files between my opensuse 12.1 pcs and an old opensuse 11.2 server on which iam not allowed to update (or reinstall) to opensuse 12.1.

The Problem is that the new version of UNISON which comes with opensuse 12.1 is 2.40.63 but the version i can install on the server pc is 2.27.157.
I tried to you it but got the error that both versions have to be identical.

How can i update the old UNISON to the new version?

What i already tried is to manualy download and compile the UNISON source (which worked) but the manual says “installing is as easy as copying the new executable over the old one” but i do not now where the old one is! i even tried to put the new one in /bin but this did not helped, the old one is still used when typing unison.

Where is the old one located? And can i simply overwrite it? I do not need the GUI.

When it executes when you type

unison

then it is in your PATH and can thus be found with

which unison

At the risk of stating the obvious, I recommend you make a backup copy of the old before copying anything to replace it.

Good luck.

Thank you both, i copied the new executable over the old one (and yes i did made a backup before :)) and then everything works fine.

It is nice that it works for you now and it is also nice that you said “thank you” (you are welcome), but you forgot the community. If ever a person comes to this thread through a search because he has (about) the same as you had, he now still does not know the story to the end.

Thus you should post here the output of the which statmenet I advised you to use, or another way you used to find where it is. Thus making the searching very light for others that come after you.