Uninstalling Amarok 2.2 beta svn

Yesterday after a really wild night dealing with packages, repos and libs I managed to install amarok 2.2 beta svn. Webpin wasn’t working and since many amarok’s functions weren’t available I wanted to upgrade. After upgrade amarok worked but the functions I want to have are still missing so I want to uninstall svn version and install the openSUSE version before giving up on amarok.

Yast won’t show me the installed amarok so I can’t do it throw it.

Any idea is pretty much welcome,

Pancho

if YaST doesn’t show it, which it should but whatever, you can uninstall it with the rpm command or zypper

as root on console: rpm -e name_of_package
or zypper rm name_of_package

But I didn’t install from a package but from source so I don’t know if your sollution applies. If it does then what would the name of the package be?

I couldn’t wait and I installed the openSUSE package from Webpin now amarok is dead

pancho@linux-9nu3:~/Downloads> amarok
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableSubtitlesChanged()
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableAudioChannelsChanged()
Object::connect: No such signal Phonon::Gstreamer::MediaObject::titleChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableTitlesChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::chapterChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableChaptersChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::angleChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableAnglesChanged(int)
Object::connect: No such signal BrowserCategoryList::leavingTree()
Object::connect: (sender name: ‘internet’)
InnoDB: The log sequence number in ibdata files does not match
InnoDB: the log sequence number in the ib_logfiles!
090910 14:55:21 InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files…
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer…
Object::connect: No such signal BrowserCategoryList::leavingTree()
Object::connect: (sender name: ‘root list’)
Object::connect: No such slot BrowserWidget::categoryChanged()
Object::connect: (sender name: ‘root list’)
QLayout: Attempting to add QLayout “” to Playlist::SortWidget “”, which already has a layout
QWidget::insertAction: Attempt to insert null action
QObject::connect: Cannot connect (null)::updatedContainment( Containment* ) to Context::AppletToolbarAddItem::updatedContainment( Containment* )
Object::connect: No such signal BrowserWidget::widgetActivated( int )
Object::connect: (receiver name: ‘MainWindow’)
Object::connect: No such signal CollectionWidget::home()
Object::connect: (sender name: ‘collections’)
Object::connect: (receiver name: ‘root list’)
Object::connect: No such signal ServiceBrowser::home()
Object::connect: (sender name: ‘internet’)
Object::connect: (receiver name: ‘root list’)
Object::connect: No such signal BrowserCategoryList::leavingTree()
Object::connect: (sender name: ‘playlists’)
Object::connect: No such signal PlaylistBrowserNS::DynamicCategory::home()
Object::connect: (receiver name: ‘playlists’)
Object::connect: No such signal PlaylistBrowserNS::PlaylistCategory::home()
Object::connect: (receiver name: ‘playlists’)
Object::connect: No such signal PlaylistBrowserNS::PodcastCategory::home()
Object::connect: (receiver name: ‘playlists’)
Object::connect: No such signal PlaylistBrowserNS::PlaylistBrowser::home()
Object::connect: (sender name: ‘playlists’)
Object::connect: (receiver name: ‘root list’)
Object::connect: No such signal FileBrowser::Widget::home()
Object::connect: (sender name: ‘files’)
Object::connect: (receiver name: ‘root list’)
amarok: symbol lookup error: /usr/lib64/kde4/amarok_service_mp3tunes.so: undefined symbol: _ZN6KDebug13hasNullOutputE9QtMsgTypei
<unknown program name>(13324)/: Communication problem with “amarok” , it probably crashed.
Error message was: “org.freedesktop.DBus.Error.NoReply” : " “Message did not receive a reply (timeout by message bus)” "

Thank you for your fast replay,

Pancho

then run from inside the source directory: make uninstall

I did as you sugested and I got this

linux-9nu3:/home/pancho/Documents/amarok-2.1.80/amarok-x.y.z-build # make uninstall
Scanning dependencies of target uninstall
CMake Error at cmake_uninstall.cmake:2 (MESSAGE):
Cannot find install manifest:
“/home/pancho/Documents/amarok-2.1.80/amarok-x.y.z-build/install_manifest.txt”

make[3]: *** [CMakeFiles/uninstall] Error 1
make[2]: *** [CMakeFiles/uninstall.dir/all] Error 2
make[1]: *** [CMakeFiles/uninstall.dir/rule] Error 2
make: *** [uninstall] Error 2

I don’t know what to do :frowning:

Pancho

did you “make clean” after you compiled and installed? if so, you need to configure it again and then run “make uninstall” when configure is done

also, make uninstall should be ran from the same directory you used make

I followed this tutorial to install amarok Compiling - Amarok Wiki

As yoou can see there is not a configure command to install but cmake…

As I’d installed the version from Yast over the svn I uninstalled it and the reinstall using those very same commands. Now when I try to uninstall it returns

pancho@linux-9nu3:~/Documents/amarok-2.1.80/amarok-x.y.z-build> make uninstall
– Uninstalling “/usr/lib64/libamaroklib.so.1.0.0”
CMake Error at cmake_uninstall.cmake:17 (MESSAGE):
Problem when removing “/usr/lib64/libamaroklib.so.1.0.0”

make[3]: *** [CMakeFiles/uninstall] Error 1
make[2]: *** [CMakeFiles/uninstall.dir/all] Error 2
make[1]: *** [CMakeFiles/uninstall.dir/rule] Error 2
make: *** [uninstall] Error 2
pancho@linux-9nu3:~/Documents/amarok-2.1.80/amarok-x.y.z-build>

The “/usr/lib64/libamaroklib.so.1.0.0” library is there but it seems it cannot be uninstalled.

Pancho

you need to be root on console when uninstalling (or installing) something, so login with “su” there (without quotes)

I love openSUSE, I love this forum and I love you guys. I’m really learning a lot :smiley:

Amarok svn is now uninstalled.

I installed it using the one click install from Webpin and it’s dead but this problem is solved since I could get the svn version to uninstall.

Thanks a lot!

Pancho

No problem. Keep asking and you’ll learn more :wink: