uninstall randr

Like so many before me, I can’t get my monitor to work at the right resolution because in the Control Centre I get the message “Your X server is using the RandR extension at version 1.2 or greater which doesn’t have any configuration yet”. Krandrtray only gives one resolution that fits my 16:10 monitor (Sony GDM-FW900), namely 1600x1024, which is just what I want, but annoyingly, that is the only one that does not work and gives me a black screen or bad flicker.

However, I don’t need a dynamic resolution, just 1600x1024. So can’t I just uninstall randr, so that I can set it in the Control Centre?


Update (didn’t know I could only edit my post for 10 minutes).

This happened with a Suse 11.0 installation. Note that I had no problems with Suse 10.3, an installation I fortunately kept, so I can check there or even completely revert to it. I restarted it and now see that I had randr installed there, too. There, I use that 1600x1024 resolution at 90 Hz. However, with Suse 11.0 in the console, ‘xrandr’ gives only 60 Hz for that resolution. Might that point to the problem?

Another update. I just checked with my Suse 10.3 installation, and it turns out I get the same message there in the Control Centre. However, I didn’t take notice then, because I had no problems. The only difference I can find is that in 10.3, I had 24 bit specified in Sax2. So I tried that with 11.0 too, but that just gives a garbled image, so I set it back to 16 bit.

And another thing. When I specify a resolution in Sax2 (in 11.0), I get a different one. For example:
1600x1000 gives 1280x960
1900x1200 gives 1600x1200
2560x1600 gives 2048x1536
3200x1200 gives 2048x1536
I am now using the second one, which is doable, except that the geometry is all wrong, which rather matters for me, with the amount of graphical work I do.

I suspect it’s sax that causes this. I just checked with a
sax generated xorg.conf on my system and could only get xrandr
to report 60Hz as max refresh rate. After commenting out the
only modeline in my xorg.conf xrandr reports correct results.
And Xorg.0.log reports 4 extra modelines. Maybe try that.

I’m sorry, I’m not that familiar with this stuff. I suppose you mean /etc/X11/xorg.conf. There, I don’t find the word ‘randr’. Nor ‘Hz’. Anyway, I commented out the only line in the section ‘modes’, thus:

Identifier “Modes[0]”

Next, I tried ‘xrandr’ in the root console, but that gives the same results as before, with only 60Hz for 1600x1024. Then I tried 1600x1024 in KRandRTray and then Suse crashed on me (Linux crashed!! - that’s new) and went into text mode, from where I didn’t know how to restart the gui (that’s X, right?). I could only restart normally after booting in safe mode and restoring my edit in xorg.config. Note that before crashing, the change with krandrtray gave me a black screen. This time I waited a bit longer than previously before hitting Control-Alt-Backspace.

I’m going to bed now (it’s night now in the Netherlands), but first I’ll give you the relevant sections in my xorg.conf.

Thanks for the help so far.

Section “Monitor”
DisplaySize 305 230
HorizSync 30-121
Identifier “Monitor[0]”
ModelName “GDM-FW900”
Option “DPMS”
Option “PreferredMode” “1900x1200”
VendorName “SONY”
VertRefresh 50-160
UseModes “Modes[0]”

Section “Modes”
Identifier “Modes[0]”

Section “Screen”
DefaultDepth 16
SubSection “Display”
Depth 15
Modes “1900x1200” “1600x1200” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1280x1024” “1440x900” “1280x960” “1366x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 16
Modes “1900x1200” “1600x1200” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1280x1024” “1440x900” “1280x960” “1366x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 24
Modes “1900x1200” “1600x1200” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1280x1024” “1440x900” “1280x960” “1366x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 8
Modes “1900x1200” “1600x1200” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1280x1024” “1440x900” “1280x960” “1366x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
Device “Device[0]”
Identifier “Screen[0]”
Monitor “Monitor[0]”

Section “Device”
BoardName “MGA G400 AGP”
BusID “1:0:0”
Driver “mga”
Identifier “Device[0]”
Screen 0
VendorName “Matrox”

No I was suggesting something like this:

Section “Modes”
Identifier “Modes[0]”

Modeline “1280x1024” 108.00 1280 1328 1440 1688 1024 1025 1028 1066


I’m a little puzzled by this section:

Section “Device”
BoardName “MGA G400 AGP”
BusID “1:0:0”
Driver “mga”
Identifier “Device[0]”
Screen 0
VendorName “Matrox”

The Screen option should be in the ServerLayout section and
the identifier should be “Screen[0]”, like this:

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
InputDevice “Mouse[3]” “SendCoreEvents”
Option “Clone” “off”
Option “Xinerama” “off”
Screen “Screen[0]”

Maybe try rerun sax.

I have rerun Sax many many times now, trying different resolutions.
I do have that line in the serverlayout section. Actually, to be sure, I’ll just give you all that’s in my xorg.conf file. First the bits before the above and then the ones after it.
Btw, how do you make those frames in your posts?


SaX generated X11 config file

Created on: 2008-07-13T20:22:03+0200.

Version: 8.1

Contact: Marcus Schaefer <sax@suse.de>, 2005

Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>

Automatically generated by [ISaX] (8.1)


Section “Files”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/local”
FontPath “/usr/share/fonts/75dpi:unscaled”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/Type1”
FontPath “/usr/share/fonts/URW”
FontPath “/usr/share/fonts/Speedo”
FontPath “/usr/share/fonts/PEX”
FontPath “/usr/share/fonts/cyrillic”
FontPath “/usr/share/fonts/latin2/misc:unscaled”
FontPath “/usr/share/fonts/latin2/75dpi:unscaled”
FontPath “/usr/share/fonts/latin2/100dpi:unscaled”
FontPath “/usr/share/fonts/latin2/Type1”
FontPath “/usr/share/fonts/latin7/75dpi:unscaled”
FontPath “/usr/share/fonts/baekmuk:unscaled”
FontPath “/usr/share/fonts/japanese:unscaled”
FontPath “/usr/share/fonts/kwintv”
FontPath “/usr/share/fonts/truetype”
FontPath “/usr/share/fonts/uni:unscaled”
FontPath “/usr/share/fonts/CID”
FontPath “/usr/share/fonts/ucs/misc:unscaled”
FontPath “/usr/share/fonts/ucs/75dpi:unscaled”
FontPath “/usr/share/fonts/ucs/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/misc:unscaled”
FontPath “/usr/share/fonts/hellas/75dpi:unscaled”
FontPath “/usr/share/fonts/hellas/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/Type1”
FontPath “/usr/share/fonts/misc/sgi:unscaled”
FontPath “/usr/share/fonts/xtest”
FontPath “/opt/kde3/share/fonts”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”

Section “ServerFlags”
Option “AllowMouseOpenFail” “on”
Option “ZapWarning” “on”

Section “Module”
Load “dbe”
Load “type1”
Load “freetype”
Load “extmod”
Load “glx”

Section “InputDevice”
Driver “kbd”
Identifier “Keyboard[0]”
Option “Protocol” “Standard”
Option “XkbLayout” “us”
Option “XkbModel” “microsoftpro”
Option “XkbRules” “xfree86”

Section “InputDevice”
Driver “mouse”
Identifier “Mouse[1]”
Option “Buttons” “4”
Option “Device” “/dev/input/mice”
Option “Name” “PS/2 Logitech Mouse”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
Option “Clone” “off”
Option “Xinerama” “off”
Screen “Screen[0]”

Section “DRI”
Group “video”
Mode 0660

Section “Extensions”

I just had the brilliant idea of comparing the xorg.conf files of the present Suse 11.0 installation and my previous Suse 10.3. The section “Device” has the same ‘screen 0’ line, so that wasn’t a problem there, it seems. But some other things are very different:

Section “Modes”: 10.3 has a whole bunch of modelines (about 100!), whereas 11.0 has none. For example:
Modeline “1600x1024” 212.67 1600 1720 1896 2192 1024 1025 1028 1078

Section “Monitor”: first, 11.0 has a line that 10.3 hasn’t:
Option “PreferredMode” “1900x1200”
And several differences in other lines (first 10.3, then 11.0 added between brackets for quick reference):
DisplaySize 452 283 (305 230)
HorizSync 29-121 (30-121)
VertRefresh 48-160 (50-160)

Btw, did you mean uninstall sax with yast and then reinstall it? Can I safely do that, without ending up in text mode (which I’m not too familiar with)?

No reinstalling sax wouldn’t make a difference. What you might try is to
simply copy the xorg.conf file from 10.3 to 11.0 and see what happens. Just
make a backup copy of your current 11.0 xorg.conf first. And remember
that running sax after this will take you back to your old xorg.conf.

Just had another brilliant idea. I copied the setup of the 10.3 xorg.conf (of course I made a backup first):

  • Monitor section: completely copied the 10.3 version
  • Modes section: added the abovementioned modeline
  • Screen section: moved all the 1600x1024’s to the front of the lines.

The result is better, but not quite good yet and a little weird. I have what appears to be a ‘virtual monitor’, or what is that called? I’ve seen this before. Parts of the ‘screen-image’ are hidden at the bottom or top, beyond the size of the physical screen. By moving the mouse pointer up or down I can make those visible. That’s about 90 pixels too much, so about 9% of the height. A 500 x 500 square is 14.5 x 15 cm, so also too high, except that that is about 4% too high. Hmmm.

DisplaySize 452 283 is the right ratio (16:10), so that’s not it.

Krandrtray still shows 1600x1200 (except at 90Hz in stead of the previous 85Hz). So I tried changing that to 1600x1024 again. Which it accepted instantly (at first I thought nothing had happened). So …


Well, not really, I suppose. This feels more like a workaround. And I suppose I should never run Sax again, because that would overwrite xorg.conf. But I’m happy for now. :slight_smile:

Ah, I just noticed you had already responded. And your suggestion is almost exactly what I said. :slight_smile:

However, I now notice that it’s still not quite perfect. The square is still not a square. So I changed the image size on my monitor to make is square and now I miss about 8 mm in height. That’s about 2.5% of the 305 mm height of the screen. So I miss a little screen size. I had preferred to miss that in width, but unless you come up with a better idea, I suppost this will do for now.

Seems that sax in 10.3 and 11.0 have different ideas about the sync
frequencies, you might try to comment out the lines HorizSync and
VertRefresh in your Monitor Section and see what xorg comes up with
on its own. Before doing that run the command xrandr save the output
and rerun it after this change, comparing those could give us some idea
about what’s going on.

First, I decided to completely copy the 10.3 xorg.conf to 11.0 in stead of just the sections I mentioned, but that didn’t make any difference. Anyway…
xrandr first gave the following output:

Screen 0: minimum 640 x 350, current 1600 x 1024, maximum 1600 x 1024
default connected 1600x1024+0+0 0mm x 0mm
1600x1024 90.0*
1600x1000 90.0 80.0 70.0 60.0
1280x1024 90.0 80.0 70.0 60.0
1440x900 90.0 80.0 70.0 60.0
1280x960 90.0 80.0 70.0 60.0
1368x768 90.0 80.0 70.0 60.0
1280x800 90.0 80.0 70.0 60.0
1152x864 90.0 80.0 70.0 60.0
1280x768 90.0 80.0 70.0 60.0
1024x768 90.0 80.0 70.0 60.0
1280x600 90.0 80.0 70.0 60.0
1024x600 90.0 80.0 70.0 60.0
800x600 90.0 80.0 70.0 60.0
768x576 90.0 80.0 70.0 60.0
640x480 90.0 80.0 70.0 60.0
1152x768 55.0
832x624 75.0
720x400 85.0
640x400 85.0
640x350 85.0

(Note that I figured out how to make that frame :slight_smile: )
And this is what it is after commenting out those lines:

Screen 0: minimum 640 x 480, current 1280 x 600, maximum 1280 x 600
default connected 1280x600+0+0 0mm x 0mm
1280x600 60.0*
1024x600 60.0
800x600 60.0
768x576 60.0
640x480 70.0

That hurt my eyes, so I instantly reverted the change.

I stumbled upon this topic because, like anyone using nvidia drivers under suse 11, I would dearly like to get rid of this RandR thing. In suse 10.3 everything worked fine, in suse 11 graphics appear to be a big problem. 3d no longer works, installing the nvidia drivers does not help. Running Sax hangs the entire system . . again: in suse 10.3 everything worked out of the box!
Can anyone please help me on how I uninstall / disable RandR?