Unhandled Exception. Monodevelop will now close

Hi folks,
up to yesterday I could work with the MonoDevelop-IDE without problems. Since yesterday I get the following message while launching MonoDevelop 2.2.2 from the KDE-Mainmenu (openSUSE 11.2):

Unhandled Exception. Monodevelop will now close.
System.IO.DirectoryNotFoundException: Directory ‘usr/lib/mono/1.0’ not found.
at System.IO.Directory.GetFileSystemEntries (System.String path, System.String searchPattern, FileAttributes mask, FileAttributes attrs) [0x00000]
at System.IO.Directory.GetFiles (System.String path, System.String searchPattern) [0x00000]
at System.IO.Directory.GetFiles (System.String path) [0x00000]
at MonoDevelop.Core.Assemblies.DirectoryAssemblyContext.OnUpdatePackages (System.Object o, System.EventArgs a) [0x00000]
at MonoDevelop.Core.Assemblies.TargetRuntime.BackgroundInitialize () [0x00000]

This message is displayed after the success-bar within the Monodevelop-startup-bitmap has reached ~50% of its total length.
What had happened before:
It was very late when I tried to force MonoDevelop to accept the namespaces System.Drawing and System.Windows.Forms. In order to fix that I added ‘usr/lib/mono/1.0’ to the configuration of one of my C#-projects. Please don’t ask me why I did this… it was late, I was to fast and I didn’t think in the problems which I would cause by doing so…
Since that time I can’t launch MonoDevelop anymore. Well, that is not completely correct… when I log in to the system as a diferent user (root, testuser…), mono can be launched without any problem. But logged in as the same user (let’s call him “baduser”) who caused the problem, mono doesn’t start. (maybe I simply should apalogize to Monodevelop ?) :slight_smile:

In order to find out what’s going on, at first I uninstalled the complete Mono-Software by yast in order to re-install everything once again… NO SUCCESS !!!
So I thougt: Anywhere within the system must be an information being kept (config-file?) which won’t be deleted by uninstalling the mono-IDE totaly and which will be read by mono during it’s start-up-procedure.

So I tried to find out, which files are used by MonoDevelop during it’s start-up-procedure… I did this by searching for all files which contain the ‘usr/lib/mono/1.0’ string and which are newer than the beginning of the monodevelop-start-up-test. (that means I searched for all files which have been used during the last ~10 seconds after launching MD). ----The result: There could no file be found with this properties.

Later I also tried to find out if it is possible to start mono when I’m logged in as a diferent user. As I wrote above yet, this works fine.
As ‘usr/lib/mono/1.0’ exits on the system, I also tried to add this path to some environment-variables… Once more without success :frowning:
But at this point I have to admit that I don’t know well which MD-environment-variables would have to be edited in order to solve the problem.

I also searched the web for help, but as this problem is a real self-made-problem, I couldn’t find any helpful information.

Now the questions to the experts:
From where takes the “brand-new-installed”-MonoDevelop the information about the “usr/lib/mono/1.0”-Directory and it’s relation to the “baduser” ?
Which environment-variables (beside the standard PATH-Variable of the Linux-System) do I have to edit in order to inform MonoDevelop about the “usr/lib/mono/1.0”-directory?
How can I tell MonoDevelop to forget about the stupid path-information related to the baduser ?

Any help is apreciated… I already spent a lot of time on this problem and now I don’t have further Ideas about a solution… :frowning:

Thanks a lot in advance… Rafael

From the MonoDevelop-Forum a user wrote the following solution:

mv ~/.config/MonoDevelop ~/.config/MonoDevelop.old

Now it works…Quiet simple… But I don’t understand why I couldn`t find this config-file by searching for used-files during the start-up-procedure ? Is it possible, that this file is used during system-start ? (instead of the MDevelop-start-up?)
Just for learning about the circumstances from this problem I would appreciate an explication to this question.

Thanks a lot in advance

It is a hidden file (the leading period means it is hidden).

It is also in your home directory (~/ indicates your home) and most likely has not a thing to do with system startup.