Unexplainable Sound Issue

Hi, All.

I’m having an issue that makes absolutely no sense whatsoever…

I can’t find any pattern with this except that it happens only with native programs and not anything run under WINE.

I’ll use a game as an example, as that’s easiest - though it does not happen with all games or programs and there seems to be nothing that sets certain programs apart.

Let’s say I’m running Torchlight 2…

  1. If I run the game directly from it’s folder I get sound. This works whether I run the program through the konsole or by just opening it through the Dolphin file manager.

  2. If I create a link to the game and place that link anywhere: Desktop, Home folder, a random folder, and run the game from the link, I also get sound.

  3. Now, if I create a link in the KMenu for the game, I get no sound whatsoever.

I don’t get it. There is no logical reason that I can think of that will cause this. I’ve never had this problem before and have checked everything from making sure there is no typo in the path, to having the correct working folder. I can even add the exact same working link that I create on the desktop and place it into the KMenu and then suddenly no sound - even after checking that all the fields are correct.

It just doesn’t make sense, there is no reason I should be getting no sound when running from a link in the KMenu.

Also, I’m not sure what information to give except that I’m using Leap 15.0 and have been using Linux since openSuSE 9.1

Thank you for any assistance.

Regards,
Craig

UPDATE: Don’t know what I was expecting to happen, but I logged out of Plasma and logged in with Cinnamon and when running programs from the Cinnamon panel menu that would otherwise have no sound when run from the KMenu in Plasma, they have sound. So it does somehow seem to be caused by running from the KMenu - though, again, I cant think of any logical reason whatsoever why this would be happening.

Check the sound settings in KDE’s Systemsettings.

I did check those but all were fine. However, problem seems to be gone now. Just disappeared as mysteriously as it appeared. Wish I knew what caused it though in case it happens again - that and there is no reason it should have been happening…