Unexpected behaviour of a LAN (Internet) Switch (Zyxel GS-105S V2)

This is not a support request related to openSUSE, but rather something I ran across earlier today that surprised me, that is technical related.

I purchased a Zyxel GS-105S V2 switch earlier this week, which is a very inexpensive 4 port Gigabyte switch. I already have a switch in our apartment that I use in my ‘study’ to connect 3 computers via one ethernet line to our router.

Our patio (outside) has one ethernet outlet and given both my wife and I like to sit outside at the same time, I picked up this inexpensive switch to use on the patio. Its small and lightweight and easy to take outside for use when we are both on the patio at the same time (using the web). We are using it for the first time today, and it works GREAT for both of us surfing at the same time via a wired connection.

What surprised me, is with this new Zyxel GS-105S V@ switch, some ports are blocked when in use with our router (a Fritzbox Fon WLAN 1&1 Home Server 50.000). My VPN ports are blocked, and also ports that I use with an office application are blocked. I can not even login to our router via this newt switch. Yet surfing works ok with this new switch. In comparison, I note with the other switch in my study (Level One GSW-0506) those same ports are not blocked, the VPN access works fine, the office application functions work ok, and I can login to the router.

After some investigation, I came to the initial (very tentative) conclusion that the problem is not this new switch per-se, but rather it is likely the Fritzbox router that is treating this switch differently.

I have not had the opportunity yet to check this out with our router (as it requires running in and out of the apartment to the server room) … but possibly sometime in the next few weeks I may check out our router - to see why it is treating this switch differently (assuming I have that assumption correctly).

This took me almost an hour to narrow down what I believe to be the likely culprit. … Of course my wife (in a teasing dig) said, it MUST be openSUSE Linux … to which we both had a laugh, as we knew it was almost certainly nothing to do with GNU/Linux, but we are aware that often GNU/Linux gets blamed for problems that are not understood.
Most interesting and never a dull moment in the oldcpu household. :slight_smile:

Eh, did you already try rebooting the Fritzbox just once? I have some vague memories of one of those boxes not accepting certain traffic, then after a reboot without issues.

And your wife is right, here’s what you get from running an amateur OS :smiley:

After reading your post, I ran to the server cabinet inside our apartment and rebooted the Fritzbox. It was a good idea to try, but unfortunately it did not work for the blocked ports. Again surfing and such works fine (I am typing this via this switch on the Patio (its a GREAT day outside)) but those other ports (login to router, VPN, some apps from where I work) are still blocked.

After confirming ports are blocked, I even rebooted the switch, and that also made no difference.

I’m going to have to dive in to the router settings when I get the chance, which needs to be done inside our apartment, and not outside the apartment from the patio. It is incredibly nice outside today … So I will likely save that more detailed router checking for a rainy day, when being out on the patio is not so nice (or maybe some evening after dark, although it does not get dark until close to 10pm here in Darmstadt Germany (sunset at this time of year is around 21:26 local time, and I try to cut back my PC activities that late in the evening, as leaving for my paid job comes early in the morning).

One big challenge with our router, is all menu entries are in German language, and my German language skills are next to pathetic (actually worse). … So I need to go through the router menu items slowly, translating the entries each step of the way.

As noted - its never a dull moment in the oldcpu household … fortunately we get a geeky perverse sense of fun doing all of this.

Here are some links to English resources on this switch…

Zyxel Product Page

Technical Specs


The main takeaway likely relevant to your description is its automatic and configurable QoS.
You’ll notice that the “low priority” ports grant you easy Internet access, my guess is that those are the ports you have least issues.
The other ports (see diagrams in the links) have default QoS settings which might mean that certain types of traffic seem blocked so that other types of traffic have highest priority.

There’s probably either an English version of the main documentation somewhere, or you can run your existing documentation through a translator… ie

  • If you have an file, then you can run through that through any translator.
  • If you have a paper document that came with your switch and an Android phone, Google Translate on your Android has a cool feature where you pass your phone over the text and the translation appears in real time… The experience is like looking through a magnifying glass except that you’re looking at translation, not magnification. I’m sure this should also work for your German menus on the screen.

Unless you’re gaming or video streaming to a dedicated device, you’ll probably want to turn off QoS altogether and use as an ordinary switch.


Thanks - I’ll check those out.

I should note that our router, a Fritzbox Fon WLAN 1&1 Home Server 50.000 is also known as a Fritzbox 7360 SL, and I have a translation of the German manual somewhere (I translated it via google years ago).

I’ll give the low speed ports on the switch a try in a few minutes.

I actually went to those web pages earlier today - but I do appreciate link. Note the ‘quickstart’ page is an FTP link. FTP is also blocked by the router with this switch.


I had to switch off the wired, switch to wireless and I was then able to download the PDF. … lol ! …

I still have the view I need to check what our Fritzbox router has to say about this switch … and I’m reluctant to go inside on such a nice day for something that is more a curiosity at this stage - but ultimately will be good knowledge to learn.

I’m still trying to avoid going inside (the apartment) to check this out.

But I made an obvious check just now, which is revealing … all of the PC’s inside our apartment have an IP address of 192.168.178.x … BUT the two laptop PCs connected to this switch currently outside on our patio are 192.168.179.x , which explains a LOT of things.

It reads like the router has assigned this switch (and the two PCs connected to it) to a separate LAN …

Curiousity may get the better of me … and I may soon find it necessary to check the router and stop it from having the new switch on a separate LAN.

Problem now solved ! (and thanks all for the feedback).

its now dark here in Germany, and while its still very nice outside, its close to bed time, so I just before bringing my laptop into the apartment for the evening, I could not resist one quick look at our FritzBox 7360 SL Router’s configuration to see if there was anything obvious.

Well there was … first I noted this - where I did not need to speak German to recognize the IP address was the laptop PC that was out in the patio connected to the new Zyxel switch:


I quick copy and paste of “Gastzugang” into Google translate told me it meant Guest Access. Immediately I asked myself, did the router setup a ‘guest lan’ ? I went to the next Tab and saw this:


which sort of translates from German to English to (thanks Google translate) :
[INDENT=2]Guest Access

Here you can provide your guests fast and secure access to the Internet. Activate the “Guest access for LAN 4 active” option and connect the guest device to the “LAN 4” socket on your FRITZ! Box. The connected device uses your guest network, but has no access to your home network.

x] Guest access for LAN 4 active

So I unselected Guest access, saved the settings in the router and I went back outside to check out the laptop. The laptop now had a new IP address with 192.168.78.x (and not

A quick test and I noted FTP functioning, VPN functioning, the work application functioning …

So that was the problem - the router had a configuration set that it would automatically add a new switch as a Guest LAN. Likely years ago, when I added my first switch, I did not have that option selected, and then some time afterward (?) I changed it , not knowing what it meant.

A non-openSUSE problem solved ! :slight_smile: