undefined symbol: _XGetRequest - /usr/lib/NX/nxagent: symbol lookup error: /usr/lib/libXcomposite.

I and coming back to suse 12.2 after a while …
and one of the key requirement is getting remote access up and runing

I have added repos for freenx
FreeNX - openSUSE

I did struggle a bit with freenx a bit (there ware problem with authenticated_keys file vs authenticated_keys2)

but now I run into more serious problem that looks like a build issue:

Session: Starting session at ‘Sun Oct 21 23:34:50 2012’.
Info: Proxy running in server mode with pid ‘18232’.
Info: Waiting for connection from ‘’ on port ‘5000’.
Info: Accepted connection from ‘’.
Warning: Connected to remote version 3.5.0 with local version 3.4.0.
Warning: Consider checking NoMachine NX - Desktop Virtualization and Remote Access Management Software for updates.
Info: Connection with remote proxy completed.
Info: Using ADSL link parameters 512/24/1/0.
Info: Using agent parameters 5000/10/50/0/0.
Info: Using cache parameters 4/4096KB/131072KB/131072KB.
Info: Using pack method ‘adaptive-7’ with session ‘unix-kde’.
Info: Using ZLIB data compression 1/1/32.
Info: Using ZLIB stream compression 4/4.
Info: No suitable cache file found.
Info: Listening to X11 connections on display ‘:1000’.
Info: Established X client connection.
Info: Using shared memory parameters 1/1/1/4096K.
Info: Using alpha channel in render extension.
Info: Not using local device configuration changes.
/usr/lib/NX/nxagent: symbol lookup error: /usr/lib/libXcomposite.so.1: undefined symbol: _XGetRequest
NX> 1006 Session status: closed

It seems to affect both i686 and x64 versions of opensuse 12.2
However the problem is manifested only when nxnode is starting - I can start X without problem (eg. login into kde)

I have googleed around and the closes thing I have found is this:
Gentoo Forums :: View topic - nxserver - symbol lookup error: /usr/lib64/libXtst.so.6

it appears that
a) the problem is with X11:RemoteDesktop and home:beyerle:IAC

so I would recommend using this repo:
==> http://software.opensuse.org/ymp/home:please_try_again/openSUSE_12.2/FreeNX.ymp?base=openSUSE%3A12.2&query=FreeNX

b) on my machine there was problem with rendering (display would not start)
and the following option has helped (in node.conf):


two other small issues

c) proper naming of authorized_keys
I was unable to connect untill I commented out the line in /etc/sshd/sshd_config restricting allowed name for authrozied keys and restarted sshd server

d) setting up / installing
there is quite usefull script for handling the mundane + testing if it works:

wget https://bugs.launchpad.net/freenx-server/+bug/576359/+attachment/1378450/+files/nxsetup.tar.gz
unpack it:
tar xvf nxsetup.tar.gz

and copy it over to directory where your nxserver file is.

P.S. I did find the following post usefull:
Linux + GNU = Humans Enabled: How to install FreeNX on Ubuntu 12.04 Precise Pangolin