Unable to upgrade from 42.2 to 42.3

I’m unable upgrade openSuse from 42.2 to 42.3. I did

sudo zypper dup

but Konsole couldn’t execute and the screen stands still. Please find attached photos of the issues when tried to update the repository (https://photos.app.goo.gl/eWzLpP409yOPzqlf2). Do you think there is an issue in repository? Please find below the

Repository priorities are without effect. All enabled repositories share the same priority.

| Alias | Name | Enabled | GPG Check | Refresh

1 | code | Visual Studio Code | Yes | (r ) Yes | No
2 | devel_languages_python3 | Python-3 modules (openSUSE_Leap_42.2) | Yes | (r ) Yes | No
3 | google-chrome | google-chrome | Yes | (r ) Yes | Yes
4 | openSUSE-42.2-0 | openSUSE-42.2-0 | No | ---- | ----
5 | repo-debug | openSUSE-Leap-42.2-Debug | No | ---- | ----
6 | repo-debug-non-oss | openSUSE-Leap-42.2-Debug-Non-Oss | No | ---- | ----
7 | repo-debug-update | openSUSE-Leap-42.2-Update-Debug | No | ---- | ----
8 | repo-debug-update-non-oss | openSUSE-Leap-42.2-Update-Debug-Non-Oss | No | ---- | ----
9 | repo-non-oss | openSUSE-Leap-42.2-Non-Oss | Yes | (r ) Yes | Yes
10 | repo-oss | openSUSE-Leap-42.2-Oss | Yes | (r ) Yes | Yes
11 | repo-source | openSUSE-Leap-42.2-Source | No | ---- | ----
12 | repo-source-non-oss | openSUSE-Leap-42.2-Source-Non-Oss | No | ---- | ----
13 | repo-update | openSUSE-Leap-42.2-Update | Yes | (r ) Yes | Yes
14 | repo-update-non-oss | openSUSE-Leap-42.2-Update-Non-Oss | Yes | (r ) Yes | Yes
15 | server_database | Databases (openSUSE_Leap_42.2) | Yes | (r ) Yes | No

sudo systemctl restart packagekit

returned without any issue while packagekit CLI utility

pkcon get-updates

doesn’t succeed. The output is

Getting updates =========================]
Starting =========================]
Refreshing software list ===== ] (20%)

Please help me in upgrading the system.

Hi, you have still all the 42.2 repositories enabled and NO 42.3 repo in your list.
To upgrade via “zypper dup” you need to edit the repositories so that they point to the 42.3 version (or add the 42.3 repos and disable the 42.2 ones).
It is also best to disable the “extra” repos and keep only the OSS, NON-OSS, OSS UPDATE and NON-OSS UPDATE (for 42.3) during the system upgrade at first, you can then enable the extra repos in a second pass, after you have successfully booted in the new system.

Many Thanks!

Should I also remove openSUSE-42.2-0 from the list?

Never mix version all repos must be 42.3. But disable the extra repos until after you upgrade

Many Thanks!

I’m able to change only Alias name. Could you please give me how to change by taking one row or an example. I’m new to Linux world, I need this support. If there are any documents in this regard, please share.

To be able to change repos you need superuser permissions; in a terminal type:

su -

and your password for root to become superuser.

zypper modifyrepo --all --disable

to disable all your current repos. Then, as you like, add the 42.3 repos:

zypper addrepo --refresh http://download.opensuse.org/distribution/leap/42.3/repo/oss/ "Main Repository (OSS)"
zypper addrepo --refresh http://download.opensuse.org/update/leap/42.3/oss/ "Main Update Repository"
zypper addrepo --refresh http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/ "Main Repository (NON-OSS)"
zypper addrepo --refresh http://download.opensuse.org/update/leap/42.3/non-oss/ "Update Repository (Non-Oss)"

At this point you should be able to perform a basic upgrade.
I suggest to use one of the terminal consoles, available for instance by pressing CTRL+ALT+F1, as the X-server might be restarted during the upgrade and leave you without a desktop, without a terminal and with an unstable system.
Login as root (or login as a normal user, then type “su -” again to gain superuser power) and issue:

zypper dup

The process should take some time, so don’t panic.
After you reboot to the upgraded system you should be able to add your other repositories and upgrade the other applications of your choice.
If you are new to zypper, I suggest you use YaST - Software to accomplish that.
Or ask on the forum if you meet with troubles.
Good Luck!

You could use YaST Software to edit the repositories as well, as suggested by this article https://forums.opensuse.org/content.php/202-Quick-Upgrade-from-Leap-42-2-to-Leap-42-3

The SDB Upgrade contains a sed command that will convert all your repositories from 42.2 to 42.3

I’d post the command by itself, but you should really read the entire SDB, particularly the guide for upgrading from 42.2 to 42.3 completely.


Thank you very much for all inputs. The upgrade failed owing to TimeOut Exception. Seems Download page is experiencing Performance issues for the past 3 days. I’ll keep thread posted about upgrade status.

Following the instructions provided below I just upgraded from Leap 42.1 Xfce 64 bit to Leap 42.3 with no problems, so far - thanks for that.

I’m getting the following error: Timeout exceeded when accessing ‘http://download.opensuse.org/distribution/leap/42.3/repo/oss/content

But I added only ’
http://download.opensuse.org/distribution/leap/42.3/repo/oss/’ Not sure how content gets added

Check the output from zypper lr -d and check the repo type is yast2 and not rpm-md.

I did check out zypper lr -d and found that they were in None or rpm-md. So I disabled and added the repository with yast2

zypper ar --refresh -t yast2 http://download.opensuse.org/update/leap/42.3/non-oss/ "Update Repository (Non-Oss)"

But still I’m facing the issue. I’m sure the issue is repository is accessing http://download.opensuse.org/update/leap/42.3/non-oss/console. Why so? Many Thanks for your support.


zypper ar --refresh -r http://download.opensuse.org/update/leap/42.3/non-oss/openSUSE:Leap:42.3:NonFree:Update.repo

apparently that description file calls for a type “rpm-md” and it works here…

Hurray!!! Your suggestion has worked.Thank you very much to everyone for their help. I’m able to install 42.3 92. But only x-server works and kde flunks. After command init 5 as su, screen flickers. Otherwise all look ok. Result of startkde command is $DISPLAY is not set or cannot connect to the X server. Please help me.

Yes. That’s your install DVD for 42.2. It won’t be useful with 42.3

Chances are that your HW is not compatible with drm-kmp-default: try to uninstall it.
If it is not there, try to boot with “nomodeset” appended to the kernel boot line and see what happens.

Also what video car and did you have a binary blob driver installed before? Generally an upgrade does not upgrade a proprietary video driver

Nothing has changed.Uninstalled drm-kmp-default from /lib/modules, but nothing happened. So added nomodeset to GRUB_CMDLINE_LINUX_DEFAULT in /etc/boot/grub and updated grub by grub2-mkconfig -o /etc/default/grub. When I visited back, found that /etc/default/grub & /boot/grub2/grub.cfg are same. Clueless on what to do next.

Nothing has changed.Uninstalled drm-kmp-default from /lib/modules, but nothing happened. So added nomodeset to GRUB_CMDLINE_LINUX_DEFAULT in /etc/boot/grub and updated grub by grub2-mkconfig -o /etc/default/grub. When I visited back, found that /etc/default/grub & /boot/grub2/grub.cfg are same. Clueless on what to do next.
I’ll check about video card.