unable to untar eclipse. md5 mismatch


I just installed OpenSuse 13.1 and am trying to install eclipse Kepler. Unfortunately, I am unable to extract the *.tar.gz file, downloaded from the official eclipse website. I keep getting the error message:

gzip: stdin: unexpected end of file
tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now

I’ve already tried downloading it from 7 different servers but to no avail. I noticed that none of the file’s md5 sum matched that of the file on the server.

Is there an alternative download location I can use to get eclipse from?

I cannot find eclipse on yast. It only lists eclipse Java compilers but not the IDE.

Any help will be appreciated.

Please, post what you do and get on the terminal complete: prompt, command, output, next prompt.
Now we only have some output withou any idea about what you tried to do.

The description suggests an incomplete/corrupted download.

Eclipse is downloadable from many mirrors (see the Eclipse Download page).
For the problems you’re describing, the proper solution is probably a download manager (maybe filezilla?). An ordinary HTTP (or even FTP) download will typically fail if interrupted. A download manager will understand how to download the file in chunks and do consistency checks.

As for downloading an Eclipse openSUSE package, you can do so at the following link if you wish, it looks like there are Factory packages (typically untested)

But, for many reasons downloading Eclipse from eclipse.org is typically preferred for at least the following reasons

  • You can get an Eclipse version tailored specifically for your use which can range from specific languages or use
  • Once extracted, Eclipse can be run from any locationyou
    If you download from Eclipse, you can then optionally tailor your installation, where and possibly with a Desktop or menu shortcut (I prefer to just launch from a root console)