Unable to switch to USB Headset

I have Opensuse 11.0 have problems with switching between my primary sound card and my USB headset. I can test both in Yast>Hardware>sound. But all the media programs will only play on desktop speakers. I have tried to switch from snd1 to 0 and all the sound on my machine just stops playing. I have turned off soundcard in BIOS. This did not do a thing. I have completely reloaded SUSE11 about 50 times. I can get it to work with SUSE10.3, SLED10, and even Ubuntu. Which I do not like… I love the new v11, but pleaged with this USB sound issue. I have followed all the post I can find, but may not fit my hardware. I run a Dell XPS 420 desktop. I run OpenSuse11 on an ext harddrive. Due to I do not want to destroy my orginal harddrive due to warranty time frame. It seems to work with all the other versions and distro mentioned above. So I would be very greatful for any help.

I have no such device, so in truth, I simply do not “know” the solution. I have lots of “speculative” ideas, but of course, trying out someone else’s speculative ideas can be tiring, to say the least.

I believe that for some usb sound devices, one needs “alsa-firmware” installed, so ensure you install that rpm. Then restart after installing that, to ensure modules associated with it are properly loaded. Test your headset then.

Anyway, in case you are in an adventurous, mood, you could try various /home/your-user-name/.asoundrc file combinations.

For example, IF your sound driver for your usb headset is snd-usb-audio, you could try creating this .asoundrc file, and saving in the location /home/your-user-name/.asoundrc (please note that makes it a hidden file):

       pcm.usb-audio {
          type hw
          card 1
       }
       
       ctl.usb-audio {
          type hw
          card 1
       } 

and then restart your sound by typing with root permissions:
rcalsasound restart and check you mixer, your headset …

My reference for that is here:
Matrix:Module-usb-audio - AlsaProject

I believe that is a very simple .asoundrc file, and I think that some USB devices need more complex files. So its possible more research is needed to use the file that is appropriate for your use.

Now its possible your headset uses a different kernel sound module. … To determine that it is possible “lsmod | grep snd” may indicate the module, but its more likely a diagnostic script will help. So it would likely be helpful if you run this diagnostic script with your headset connected to the internet:

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa'

when prompted for a password, enter the root password. That script will give you a URL when it is complete, … please post that URL here.

It might also help if you provided your alsa version, info on your pulse audio, etc … so please copy and paste the following in a gnome-terminal / konsole and post the output here:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Sorry, work keeps me alittle to busy. Here is the URL that was generated… tsalsa.txt - nopaste.com (beta)

rpm -qa | grep alsa

alsa-1.0.17.git20080802-6.1
alsa-driver-kmp-default-1.0.16.20080812_2.6.25.5_1.1-1.1
alsa-plugins-1.0.16-57.1
alsa-firmware-1.0.17.git20080617-2.1
alsa-oss-1.0.15-48.1
alsa-tools-1.0.17.git20080715-1.9
alsa-utils-1.0.17.git20080802-2.1
alsa-oss-32bit-1.0.15-48.1

rpm -qa | grep pulse

Nothing???

rpm -q libasound2

libasound2-1.0.17.git20080802-6.1

uname -a

Linux linux-dell 2.6.25.11-0.1-default #1 SMP 2008-07-13 20:48:28 +0200 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/sound

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

Thanks. Well, your USB headset is detected according to the script … I see both snd_hda_intel (for your XPS420 motherboard audio, a stac9227) is loaded and also snd_usb_audio, for your USB headset is loaded. The script also notes

Alsa cards:         
         0 [Intel          ]: HDA-Intel - HDA Intel        
                              HDA Intel at 0xfebdc000 irq 16        
         1 [default        ]: USB-Audio - C-Media USB Headphone Set          
                              C-Media USB Headphone Set   at usb-0000:00:1d.2-1, full speed  

with the assignment of card0 as your motherboard and card1 as your headset

I don’t see anything obviously wrong in the mixer either.

I note you updated some (not all) of the alsa rpms to a recent alsa.

You could try surfing the web to see how to set up alsa to handle multiple cards.

Its possible you need to create a .asoundrc file under /home/your-username. I don’t have such a headset, so its not something I can try. Some reading material:
.asoundrc file basics: .asoundrc - ALSA wiki](http://alsa.opensrc.org/home/w/org/opensrc/alsa/index.php?title=.asoundrc)
Some .asoundrc file examples: infofiles

Your best bet may be to install an irc chat program such as xchat and go to irc freenode #alsa and ask for help from the guru’s there.