Unable to switch to Cantonese input systems after install (IBus and fcitx)

Tried installing ibus-table-chinese-cantonese on a freshly installed Tumbleweed system. After adding CantonHK input and restarting the IBus daemon, I’m still not able to switch to CantonHK input. Specifically:

  1. The on-screen menu that shows up when I type the shortcut key combo shows that CantonHK input is selected
  2. The systray icon still shows the previous input system
  3. When typing the previous input system is still active

I’ve also tried replacing IBus with fcitx and installing fcitx-table-hk-cantonese, but the same behaviour happens.

My workaround: Go back to IBus and install the ibus-rime and brise packages to get Cantonese-language input. It works, but I would like to find out what went wrong with the other input systems.

You probably should post directly to the ibus-table Developers,

The project appears to be at

There’s plenty of info there for you you explore,
And links for support.

I suppose the first step is to determine how recent the data/language you’re trying to install is… Which would be an indication if support for the language is very new and “in progress” or years old and reliable. From what you’re describing, it may be a newly added language.


Thanks, TSU. I believe that at least the IBus version of cantonhk has been around for a couple of years, since there’s a reference to it being packaged in Ubuntu 14.04LTS. I’ve also managed to get the IBus cantonhk input working on a couple of Xubuntu 16.04 installs without incident.

I’ll go through the project wiki to see if it sheds any light on things.