unable to start virtualbox

I’ve installed virtual box and now it will not run. I’ve also tried starting it from CLI to see what happens:

:~> vboxgtk
/usr/lib64/python2.7/site-packages/gi/overrides/Gtk.py:46: RuntimeWarning: You have imported the Gtk 2.0 module.  Because Gtk 2.0 was not designed for use with introspection some of the interfaces and API will fail.  As such this is not supported by the pygobject development team and we encourage you to port your app to Gtk 3 or greater. PyGTK is the recomended python module to use with Gtk 2.0
  warnings.warn(warn_msg, RuntimeWarning)


(vboxgtk:4082): Gtk-WARNING **: Unknown property: GtkAboutDialog.license-type


(vboxgtk:4082): GLib-GObject-ERROR **: cannot create instance of abstract (non-instantiatable) type `GtkBox'
Trace/breakpoint trap
:~>

Here are the repos:

:~ # zypper lr
#  | Alias                         | Name                                | Enabled | Refresh
---+-------------------------------+-------------------------------------+---------+--------
 1 | Downloads                     | Downloads                           | No      | No     
 2 | KDE_4.9                       | KDE 4.10                            | No      | No     
 3 | Printing_1                    | Printing                            | No      | No     
 4 | Virtualization                | Virtualization                      | Yes     | Yes    
 5 | Wine                          | Wine                                | No      | No     
 6 | Wireless                      | Wireless                            | No      | No     
 7 | download.opensuse.org-Stable  | openSUSE BuildService - LibreOffice | No      | No     
 8 | download.opensuse.org-mozilla | openSUSE BuildService - Mozilla     | No      | No     
 9 | ftp.gwdg.de-suse              | Packman Repository                  | Yes     | Yes    
10 | google-chrome                 | google-chrome                       | No      | No     
11 | google-earth                  | google-earth                        | No      | No     
12 | graphics                      | graphics                            | No      | No     
13 | home:Lazy_Kent                | home:Lazy_Kent                      | No      | No     
14 | home:ocefpaf                  | home:ocefpaf                        | No      | No     
15 | kde-extra                     | KDE-extra                           | No      | No     
16 | libdvdcss repository          | libdvdcss repository                | No      | No     
17 | repo-non-oss                  | openSUSE-12.3-Non-Oss               | Yes     | No     
18 | repo-oss                      | openSUSE-12.3-Oss                   | Yes     | No     
19 | repo-source                   | openSUSE-12.3-Source                | No      | No     
20 | repo-update                   | openSUSE-12.3-Update                | Yes     | Yes    
21 | repo-update-non-oss           | openSUSE-12.3-Update-Non-Oss        | Yes     | Yes    
:~ #

I’d initially installed 4.2.10-78.6-x86_64 from the virtualbox repo.

I then re-tried with 4.2.6-78.6-x86_64 from the Oss repo. No difference.

:~ # uname -a
Linux p580.cutbeach 3.7.10-1.4-desktop #1 SMP PREEMPT Fri Apr 19 12:06:34 UTC 2013 (8ef74f8) x86_64 x86_64 x86_64 GNU/Linux
:~ # 

12.3 - 64 , KDE 4.10

did you added you user to vboxuser group???

First of all I think this Threat belongs to Forum:Vitualization.

Did you install virtualbox from the Oracle-Repo?

Please post:

zypper se -si vbox virtual

and

zypper lr -uP

I agree. Posting in he (sub)forum that most tightly fits ones problem will give one a better chance that knowledgable fellow users will se it.

CLOSED, will be moved to Virtualization.

Moved from Applications and open again.

So may I say you have a very lot of repositories installed into YaST and when you get more than nine (adding in just Packman) you can be asking for trouble. As for VirtualBox, you have installed it from the repository and I have no idea about the application for which you speak, but I do not use it. If this was me, I would remove all VirtualBox apps installed using YaST and all things for it you have installed and get VirtualBox from here as listed in this message: https://forums.opensuse.org/english/get-technical-help-here/virtualization/478410-oracle-releases-vm-virtualbox-4-2-a-2.html#post2547639 and I would follow this article on its installation: https://forums.opensuse.org/content/59-how-install-virtualbox-opensuse-11-4-12-1-tumbleweed.html and you do not use the application you have install outside of VirtualBox called vboxgtk. I just use the application name “VirtualBox” to start up VirtualBox.

Thank You,

Since you’re running KDE anyway, I would suggest you to install the package “virtualbox-qt” and just use the Qt version instead of the Gtk one.
You can run that by “VirtualBox” then and there also should be an entry in the KDE startmenu (System->Emulators).

This one works fine for me (haven’t tried the Gtk version)!

Did you note that all except the basic five are disabled? I only leave the others listed so I can re-enable them if needed in the future for updates and repairs.

As for VirtualBox, you have installed it from the repository and I have no idea about the application for which you speak, but I do not use it. If this was me, I would remove all VirtualBox apps installed using YaST and all things for it you have installed and get VirtualBox from here as listed in this message: https://forums.opensuse.org/english/get-technical-help-here/virtualization/478410-oracle-releases-vm-virtualbox-4-2-a-2.html#post2547639 and I would follow this article on its installation: https://forums.opensuse.org/content/59-how-install-virtualbox-opensuse-11-4-12-1-tumbleweed.html

Thank you very much for those two links. It’s sad that neither one showed up in the results of the search of the forums I did (on three separate occasions) for “virtualbox” >:(

I note that the second link mentions a newer version than offered in the repositories. I’ll try that, thanks

you do not use the application you have install outside of VirtualBox called vboxgtk. I just use the application name “VirtualBox” to start up VirtualBox.

I tried using “VirtualBox”, “virtual box”, and “vbox” as suggested in other postings both here and elsewhere. All with the same result…

:~> VirtualBox
If 'VirtualBox' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf VirtualBox
:~>

vboxgtk was one of the dependencies installed by Yast along with virtualbox and the command I found by going to Edit Applications in the KDE and looking at the properties of the Icon added when virualbox was installed. It is described as “VirtualBox GTK+ interface”.

That did it! Thanks wolfi323

Note: Still using 4.2.10-78.6-x86_64) from the Virtualization repo, however the URL offered by Yast is incorrect. The correct one is “http://download.opensuse.org/repositories/Virtualization/openSUSE_12.3/