Unable to start suse

Hi all,

I’m running opensuse 11.3 gnome and I’ve run into a problem.

My email client evolution would shut down sometime when sending an email so I decided to remove it. In this process I some how stopped the NetworkManager from working an issue with shared libraries I think. So I decided to try repairing the installation with my suse DVD.

Now when I try to boot suse I get the output below.

Starting Avahi daemon done
Starting mcelog… done
Starting service gdmgdm[1969] WARNING: GdmDislay: display lasted 0.001627 seconds
gdm[1969]: WARNING: GdmDisplay lasted 0.001581 seconds
gdm[1969]: WARNING: GdmDisplay lasted 0.001641 seconds
gdm[1969]: WARNING: GdmDisplay lasted 0.001530 seconds
gdm[1969]: WARNING: GdmDisplay lasted 0.001592 seconds
gdm[1969]: WARNING: GdmDisplay lasted 0.001553 seconds
gdm[1969]: WARNING:GdmLocalDisplayFactory: maximum number of X display failures reached: check X server log for errors
startproc: exit status of parent of /usr/sbin/gdm:1 failed
Starting Avahi DNS Configuration daemon done
Starting Name Service Cache Daemon done
Starting mcelog… done
Starting irqbalance done
starting cupsd done
Starting VirtualBox kernel module done
Starting mail service (Postfix) done
Starting CRON daemon done
starting smartd done
Starting the NetworkManager done
/usr/sbin/NetworkManager: error while loading shared libraries: libpolkit-govject-1.so.o:cannot open shared object file: No such file or directory
Starting Firewall Initialization (phase 2 of 2) done
Master resource Control: runlevel 5 has been reached
Failed services in renlevel 5: xdm
Skipped services in runlevel 5: nfs

Welcome to openSUSE 11.3 “Teal” - Kernel (tty1).

linux-5uh2 login: (Yast login)


Now I’ve tried entering my password for YasT again but this doesn’t work. Panic my box is now dead. All I can do it get the linux-5uh2 login request. I tried starting in failsave and the same.
It mentioned a firewall which was on it for windows (not installed by me). I’m trying to get that password to see if this will work. Any advice very very welcome. Also no idea what openSUSE 11.3 “Teal” is.

Thanks in advance


I’m not quite sure what your “Yast login” is. You have just booted into console mode, which isn’t really that big of a deal. Log in with the credentials you normally logged into X with. The username you chose on install and that password.
Once you’re in, just type “startx”
X may not work, you got a lot of Display errors. You may need to install graphics drivers.

“Teal” is just the codename as far as I know, similar to OS X’s “tiger” or “snow leopard.”

Oh, to not make the output take up so much space, please wrap “{CODE}{/CODE}” tags using ] instead of {} around it.

Thanks for the reply Ben.

used startx and the gnome desktop started but with no shortcuts, no toolbar, basically a green screen with a black cross for a cursor. As you mentioned and I was concerned about the display fault’s listed. I’ve manually mounted a usb and managed to copy all important files.


I’m going to reinstall suse 11.3. I’m concerned that there will be a clash with what’s already on the computer ie suse installed but with faults.

Thanks again for your help


Fixed the problem. I just used the DVD install disk to update the system and everything worked perfectly. I thought I’d have to mess around with firmware for the wireless and drivers for printers but everything was there the only thing needing adjusting was the clock, how cool is that! If I could get windows of my machine altogether I’d be happy.

Thanks for the help


Well, if you don’t mind re-installing again, you can use the openSuse installer to delete the partition tables, reformat the HDD, and just let openSuse have all of your disc.
I’m glad you got it working.