Unable to set up ad-hoc network

Hi there,

I’m using OpenSUSE 11.3 64-bit on a Lenovo G560. I’m able to establish both wired and unwired connections without problems. Now I’m in a situation where I’d like to share my laptop’s internet connection with other devices. My thought was to establish an ad-hoc network that another computer could connect to wirelessly in order to get into the Internet, because I’ve only got one ethernet jack.

First thought was to use Network Manager, since that manages all my connections. A left click on the Network Manager icon brings up a menu in which “Wireless 802.11, Create network connection…” is an option. If I click on that I see a list of all the networks available in the area, as well as all the networks I’ve set up in the past. Below that are two options: “New Ad-Hoc Network” and “Connect To Other Network With Wireless 802.11…”

“New Ad-Hoc Network” seems like the right option, but when I double click on it the window closes and nothing happens. No error message, nothing. Network Manager continues to run and my connection is unchanged. If I just left click on it and then click “Connect” at the bottom of the window, the same thing happens.

Any ideas? Thanks a bunch!

Sorry I don’t understand what you are asking.

Are you trying to setup your laptop as a gateway for other devices to access the network?

I think the “New Ad-Hoc” assumes there is an existing but new to you Ad-Hoc network you want to connect. It does not mean create a new Ad-Hoc network.

I suggest reading this thread to see if it helps
Suse 11.2 as NAT-Router

Hi there,

Sorry, I guess I wasn’t properly subscribed to this thread and didn’t see that you’d written back. Thanks for the quick reply!

Yes, I’m trying to set up my laptop as a gateway for another laptop to access the Internet.

Regardless of the intended function of “New Ad-Hoc Network,” I think it’s strange that when I open it nothing happens at all except that the window closes.

However, the links you sent me seem very promising. It’s really late over here but tomorrow I’ll give it a whirl and see if I can get it to run. Thanks! They look really helpful.

Some simple things not mentioned which shouldn’t be overlooked…

  • For your wired connection, if you use a hub or switch you need two “patch” (straight thru) cables, if you connect directly between your two machines you need a “crossover” cable. Inspect your NIC indicator lights to verify network connectivity.

  • Since it’s unlikely you’ll be setting up a DHCP server to support your “other devices” which will connect through your SuSE box, it requires some IP addressing know-how to avoid various pitfalls… like using the same network ID on multiple interfaces, configuring default gateways where you shouldn’t or wrong or missing gateways where you need them. Probably best solution if you’re a newbie at this is to post the existing IFCONFIG of your SuSE box, then anyone else can recommend how you setup everything else.


Alright, I tried setting up the network today again but failed. I followed the directions on the links that had been posted in the post by tararpharazon but never quite got around to trying out the wireless connection. The reason is due to the network I’m using - it requires 802.1x authentification and I couldn’t figure out how to do that without my network manager. At the moment I’m using a splitter and two ethernet cables to connect the two devices to the network. No wireless, but… At least it works. It would be really nice to have wireless, though.

However, if anybody knows of a good manual for how to get 802.1x authentification working without NetworkManager, I would be grateful to read it. At the moment I’m too swamped to look for it and would rather accept this less-than-optimal solution than actively search. I know, I know, never give up - but at the moment functionality is more important than optimality. Thanks a bunch for the support though!

Nonetheless, in case it’s helpful, here’s the results of ifconfig:

eth0      Link encap:Ethernet  HWaddr 88:AE:1D:35:CF:29  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::8aae:1dff:fe35:cf29/64 Scope:Link
          RX packets:15339 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6719 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2984416 (2.8 Mb)  TX bytes:1916859 (1.8 Mb)
          Interrupt:30 Base address:0x2000 

eth1      Link encap:Ethernet  HWaddr 00:26:82:AD:65:98  
          inet6 addr: fe80::226:82ff:fead:6598/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:7855 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7855 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:968683 (945.9 Kb)  TX bytes:968683 (945.9 Kb)

I just figured, since I have to disable NetworkManager in order to allow IP-forwarding and masquerading and that causes me to lose my internet connection, it’s better to stick with half the bandwidth for both machines and at least have them running :stuck_out_tongue:

You can use Yast to configure wired and wireless cards with authentication on the wireless card. Select the traditional ifup method so that NetworkManager will be disabled. Make sure that IP-forwarding is also switched on from the Yast tool. Once, this is done, set up the iptables for masquerading. (It is possible to set up iptables via SuSEFirewall too).

That’s really great with setting up wired cards with authentification. How does it work? I need to authentificate myself with 802.1x on the wired card. The goal is to have a connection through my wired card that I then share with the other computer using a wireless connection. It’d also be great if I could configure the wireless connection to require authentification.

I took another look at the Firewall tool in YaST and wasn’t able to find how to configure iptables. Are those tables that allow only certain IPs to work in certain settings? I found a “Routing Table” in YaST’s network settings, does that do the same thing? Sorry, I’m really a noob in this area. Thanks a bunch for the help!

I recommend you work on getting your Internet Connection Sharing working first then setup your firewall. Setting up a firewall/iptables while trying to establish connections and forwarding can only add problems for most users.

I guess you’re right about that, bis dato my Internet’s shut off as soon as I switch from NetworkManager to ifup lol!

I guess the first step would be to get 802.1x authentification to work with ifup. I found an introduction that talked about how to do that, but it was only for wireless networks. Sadly, I couldn’t find anything for wired networks. I guess it’s just not destined to be - I’d rather have guaranteed Internet access at the moment than try to get this to work and potentially kill my Internet connection - at the stage of the projects I’m in that’d be deadly. I guess the network’s won this battle, for now at least…:\

Shouldn’t you use DSL connection under NetworkManager instead of Wired? Unless your DSL/Cable modem provides sign-on your OpenSuSe would need to provide the sign-on like that “Net” command under Windows.

IMO, Wired is for router to modem when router supplies login?

Cable/DSL modem <-> Wired DSL | <- NAT -> | Wireless <-> wireless ?

Sorry, I don’t have enough information about your setup to offer more than guesses.

I use wired in NetworkManager because I’m connected to a LAN network. It’s the university network from my university - I’ve moved into dorm building and this is the only way of getting into the Internet. So I’m not using a modem at all.

The concept is:
Ethernet connection <-> Laptop <-> WLAN connection to provide Internet access to the other devices

I see it :
Wlan <-> dorm lan <-> ethernet connection <-> laptop <-> ? <-> other devices

IMHO, the simple solution would be
Wlan <-> dorm lan <-> ethernet connection <-> wireless router <-> laptop + other devices
But I understand your desire to run the laptop as a router. I thought I had provided a HowTo link for that, but you can google for “linux router howto” if I didn’t.

Hi there,

Thanks, I’ll take a look at those links. Be keeping my fingers crossed!lol!


I am trying to same thing as erget but I see from the proposed solutions that this could be a complex process. I don’t use Ubuntu but I have tried the last 10.04 for a couple days and I remember following these instructions How to create an Internet Hot spot using Ubuntu | Place to share anything I was able to set up an internet hotspot in no time. Is it really this complex a setting in our beloved distro?