Unable to select home directory for Suse installation

I am trying to install OpenSUSE 12.2 KDE. I have got an HDD with all partitions in NTFS except one which is in Ext4. I want Suse to select this partition as its home directory. But Suse is not detecting it automatically and I do not know how to manually select this partition to be my home partition. Please help.
[RIGHT]
Thanx for any help in advance…
[/RIGHT]

This is from memory.

In the first partitioning window, you need to select “Create partition”. Then, in the next screen, you might need to go to expert mode.

You should see a list of the existing partitions. You can right click on the “ext4” partition, and select “Edit”. Then change the options to:
Mount as “/” (probably without the quotes - there should be a selection with “/” there).
Format partition.

After that, you should be able to follow the prompts for the next step.

Are you planning a combined /home and / ?

Otherwise your ? is confusing

See: https://docs.google.com/open?id=0B3e0lLG3OdqEdE1SaUNZZUMxSW8

Your story is indeed very unclear. For installing openSUSE you need free space on the disk. It is easier when this free space is NOT prtitioned, so the the installer can use it and does not see it as in use allready. The installer will try to make 3 (three) new parrtitions out of that empty space, one for Swap, one for / and one for a seperate /home. You can vary on that

You can prepartition (as it seems that you have done), but you then definitely need not only one partition for a “home directory” (it is not clear what exactly you think that is imho). In any case when there is no free space on the disk, but allready partitions you would like to use you have to go to expert mode as @nrickert indicated.

When you want more advice, you must post the partition table as it is by booting from e.g. a live CD, or from the install DVD > Rescue mode and then do

fdisk -l

Thank You for your replies…

I went into the expert mode and did whatever nrickert](http://forums.opensuse.org/members/nrickert.html) said. I installed Suse but my computer is not detecting it as an OS. I am not getting any choice of OS during boot…nor am I being able to see the GRUB. Directly, I am being taken into Windows which I had installed previously.

Thanx…

I tried what caf4926](http://forums.opensuse.org/members/caf4926.html) said using the video. My installation went fine. But, my system is not detecting grub at all. I am being directly taken into Windows. Do yu know how to get that grub detetcted? I am not being able to open Suse.

Try this
http://forums.opensuse.org/content/128-re-install-grub2-dvd-rescue.html

I went to this site…I do not understand what you mean by the first sentence- Boot the Rescue from the DVD.

Thanx…

When you boot the install DVD there is a rescue option

Rescue option - where?
I have got a Live USB.
http://linuxtweaking.com/images/121liveboot.jpg

thnax again…

It needs to be a DVD USB then

I do not understand what you are trying to say. Please, can you explain from scratch how to get into the rescue mode? I have got OpenSUSE 12.2 Live KDE USB.

Will the commands given by you in that website work in the terminal (without going into the rescue mode)? Anyway, i am going to try that out.

[RIGHT]Thanx…[/RIGHT]

You can use a Live session to chroot in to the / partition of the installed system
Just boot to kde live
Open a terminal and follow the guide

Thanx for you reply. I tried reinstalling Suse with Boot from Master Boot Record and Write generic boot code to MBR in the Boot Loader Options enabled. This time I got two errors:

1) An error occurred during initrd creation:
Kernel image: /boot/vmlinuz-3.4.6-2.10-default
Initrd image: /boot/initrd-3.4.6-2.10-default
KMS drivers: i915
Root device: /dev/disk/by-id/ata-ST3160318AS_6VY0SXJH-part4 (/dev/sda4) (mounted on / as ext3)
modprobe: Module hid_generic not found.
WARNING: no dependencies for kernel module ‘hid-generic’ found.
Kernel Modules: hwmon thermal_sys thermal processor fan scsi_dh scsi_dh_hp_sw scsi_dh_alua scsi_dh_rdac scsi_dh_emc video i2c-core button i2c-algo-bit drm drm_kms_helper i915 libata pata_piccolo ata_generic pata_cs5530 sata_vsc pdc_adma pata_pdc202xx_old pata_ali pata_efar pata_sis libahci ahci sata_sx4 sata_qstor sata_svw pata_atiixp pata_acpi sata_sil24 pata_sc1200 ata_piix pata_cs5535 pata_artop pata_legacy sata_promise pata_hpt3x2n pata_pdc2027x pata_jmicron acard-ahci pata_cs5536 pata_sil680 pata_sl82c105 pata_ninja32 pata_it8213 pata_hpt366 pata_hpt37x pata_cs5520 pata_via pata_sch pata_cmd64x pata_cmd640 pata_amd pata_ns87410 pata_rdc pata_cypress pcmcia_core pcmcia pata_pcmcia pata_atp867x sata_inic162x sata_sil pata_mpiix pata_arasan_cf sata_uli pata_netcell pata_hpt3x3 pata_isapnp pata_rz1000 pata_ns87415 pata_marvell pata_serverworks pata_opti sata_nv pata_radisys sata_sis pata_it821x pata_oldpiix pata_optidma sata_mv sata_via pata_triflex ahci_platform usb-common usbcore ohci-hcd uhci-hcd ehci-hcd xhci-hcd hid usbhid hid-logitech-dj
Features: acpi kms plymouth block usb resume.userspace resume.kernel
Perl-Bootloader: 2012-10-01 22:41:34 ERROR: Command ‘/usr/sbin/grub2-install --force --skip-fs-probe /dev/sda >/var/log/YaST2/y2log_bootloader 2>&1’ failed with code 256 and output: /usr/sbin/grub2-bios-setup: warning: this LDM has no Embedding Partition; embedding won’t be possible.
/usr/sbin/grub2-bios-setup: error: embedding is not possible, but this is required for RAID and LVM install.

There was an error generating the initrd (1)

**2) ****Error occurred while installing GRUB2:
**[FONT=Sans Serif]/usr/sbin/grub2-bios-setup: warning: this LDM has no Embedding Partition; embedding won’t be possible.
/usr/sbin/grub2-bios-setup: error: embedding is not possible, but this is required for RAID and LVM install.
[/FONT]

I also tried out what you said and I got an error similar to error 2.
[RIGHT]Thanx a lot…[/RIGHT]

It would really help if you provided output of “fdisk -l” as already requested.

But no one is telling me how to go into the rescue mode…

Thanx…

I tried.

If you only have the Live kde CD, you can get to chroot (as in the rescue mode).

But first. Boot the live cd and post for us the result of

su -
fdisk -l

Here’s the output:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x6e21e828

  • Device Boot Start End Blocks Id System*
    /dev/sda1 63 2047 992+ 42 SFS
    /dev/sda2 2048 206847 102400 42 SFS
    /dev/sda3 206848 57462783 28627968 42 SFS
    /dev/sda4 * 57462784 312579759 127558488 42 SFS

Disk /dev/sdb: 1017 MB, 1017117696 bytes
64 heads, 32 sectors/track, 969 cylinders, total 1986558 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x31a43a44

  • Device Boot Start End Blocks Id System*
    */dev/sdb1 * 64 1374207 687072 83 Linux

*My root is installed in sda4.
[RIGHT]Thanx for keeping on helping me…[/RIGHT]

*Device Boot      Start         End      Blocks   Id  System*
*/dev/sda1              63        2047         992+  42  SFS*
*/dev/sda2            2048      206847      102400   42  SFS*
*/dev/sda3          206848    57462783    28627968   42  SFS*
*/dev/sda4   *    57462784   312579759   127558488   42  SFS*

I think this means it a dynamic disk
And from what I can tell you may have trouble. But read this
[SOLVED] How to convert dynamic to basic volume without losing data? - Ubuntu Forums](http://ubuntuforums.org/showthread.php?t=1692248)

Additionally. If that’s 4 primary partitions then you need to delete at least one
To make room for extended space