Unable to run VMware workstation 10 on opensuse 13.2

Hi today I have installed opensuse 13.2 and tried to install and run VMware workstation 10 on it but failed.

After installing the os I have run VMware workstation 10 installer and completed successfully but when I ran the command ******vmware-modconfig --console --install-all ******I am getting a number of errors.

Previously in opensuse 12.3 I got similar errors and while using opensuse 13.1 there was no such errors and at present same has been repeated.

Can you suggest how to run VMware workstation 10 on opensuse 13.2.**************


Upon visiting some other web site I found a suggestion to copy version.h file from /usr/src/linux/linux-3.16… to /lib/modules/build/include/linux and so I followed and succeeded I mean errors have been reduced.

When I ran VMware workstation it started VMware kernel module updater and failed and so it suggested to visit its log file.

Upon visiting the log file and searching for failed I have found only the following sentences
PREF Failed to load user preferences
Failed to build vmnet. Failed to execute the build command

And so main problem is due to vmnet.

If this has issue has not been resolved install the package kernel-syms.


The package you specified already installed.

As Sauerland already posted, have a look here for a patch to make vmnet build on openSUSE 13.2:

The patch specified in the above link is for kernel 3.17 and so can we follow the same procedure.

Well, try it. I don’t know.
But if it is for kernel 3.17, it should work with kernel 3.16 as well.

Follow the instructions and download the patch from the link on the wiki.archlinux.org site below:


You must install first kernel-source, kernel-syms and the base development pattern in Yast > Software > Install Unistall > View > Patterns

I have just installed version 10.0.3 in opensuse 13.2 64 bit and that’s all you have to do

Looks like the Archlinux wiki removed the links to the patches and installation instructions.

I’ve included a link to the vmware-3.16.patch for download here: http://img.susepaste.org/17094108
On openSUSE Paste, click on the word Simple. Copy and paste the code to kate or kwrite.
Click on “Save As” and use the name at the top of the page “vmware-3.16.patch” as the name of your patch.

Follow the instructions on this link: https://communities.vmware.com/thread/494201 and you will be good to go.

Good Luck!

same problema after upgrading from opensuse 12.3 to 13.2. (kernel 3.16.x.x)

I was working only with vmplayer 6 since i no longer have a valid workstation license.

After the upgrade i had the problem of vmnet service not running.

Downloaded last vmplayer , version 7, and it works without any patch or changes.

Hope this helps.


Correct. I’ve tested both Workstation Beta 11 and Player 7x and they work with kernel 3.16x and higher.

Check the VmWare website. You can download a trial with a temporary key and test out Workstation 11.

Same here, version 7.0.0 build-2305329. No problems installing and creating/opening VMs.

Do yourself a favor - buy Version 11 of the Workstation - its fine with all the latest Linuxes.