Unable to run BOINC in OpenSUSE (Tumbleweed)


I’m brand new to OpenSUSE, and Linux. I decided to use Opensuse a few days after doing the distrochooser test and this distro was at the top of the list - and I liked the colours and the feel!

Anyway, I’m really enjoying it. I think it’s a really beautiful distro and seems to be capable of a lot.

One of the main applications I use is BOINC to run distributed computing projects on my computer 24 hours a day, and i’m a bit behind because I’m having great trouble getting the client to run.

When I first installed suse a few days back I accidentally didn’t create a user account, and started installing software etc into the root account, including BOINC. Afterwards I started having trouble with applications in the root account, so created a normal user account. Boinc does not run/connect to the client after installation on a normal user account in opensuse. I’ve tried several times installing/uninstalling, and using instructions from Fedora installation on the World Community Grid website (found here: https://www.worldcommunitygrid.org/download/fedora)

The result is the same: I click to open the BOINC Manager, it opens and says ‘retrieving current status’ - stays like this for several minutes then I get an error message saying it can’t connect or something.

I posted the problem into Reddit, and an Opensuse user recommended I need to run boinc manually. To be honest, his/her instructions are beyond me as I am new to Linux/Opensuse and have no experience with this level of technical ability. I’ve pasted the user’s recommendation at the bottom of this post. If this is the way to run boinc I’d be grateful for some assistance. Although it would really be good if BOINC would just open and run automatically - I’ve tested it on other distros like Ubuntu and it works normally.

I’d really like to get this working in opensuse as I don’t want to move to another distro right now because I enjoy using opensuse.

I appreciate any feedback.

Recommendation from Reddit post:

To run boinc client you need first start boinc server. On my opensuse there was not service boinc, so i created it manually instead of running it as a process.

First create boinc user without loging in. Set its home directory to /var/lib/boinc or etc you want.
boinc:x:455:455:BOINC Client:/var/lib/boinc:/sbin/nologin
Of course do this with system commands not pasting my passwd line.
Then you create file for service for example /etc/systemd/system/boinc.service
It is how it looks like on my pc
Description=Boinc client



That’s how I solved in my machine powered by Tumbleweed:

  1. Test the status of the task with: systemctl status boinc-client
  2. If is stopped then run: systemctl start boinc-client
  3. go to path: /var/lib/boinc
  4. Check the content of the file with: sudo cat gui_rpc_auth.cfg
  5. Copy that key
  6. Open Boinc client
  7. Choose computer and in the window fill: localhost
    and in the key the key we copy in step5 1. Now we can open a project. There I choose Rosetta.
    And create and user login. 1. wait to download the projects.

*I shared this how to in spanish in my blog](https://victorhckinthefreeworld.com/2020/04/05/pon-la-potencia-de-tu-linux-a-luchar-contra-el-covid-19/) *


What do you mean at step 5. “choose computer”? On the Boinc client all the menu items are greyed out, except changing the view to advanced and the help menu, and the first page in ‘other options’.

I get the following return at step 1:

○ boinc-client.service - Berkeley Open Infrastructure Network Computing Client
Loaded: loaded (/usr/lib/systemd/system/boinc-client.service; disabled; vendor preset: disabled)
Active: inactive (dead)
Docs: man:boinc(1)

When I type in **systemctl start boinc-client **the password prompt comes up, and then nothing happens after.

This has frustrated me for years. The easy, inelegant, way to run boinc:
open a terminal
make it root by typing su and then root password
next, type boincmgr

boinc will start and run immediately.

I know people will scream at me for running stuff as root, but this is the only way I’ve gotten it to work. You must do it each time you reboot. To summarize: open a root terminal and type “boincmgr” which is the boinc manager gui. To be clear: there are no quotation marks around the command boincmgr.

After that run again **systemctl status boinc-client
should be running

Thanks this worked!

I’ve been running boinc in a Lubuntu virtual machine for the time being.

Installed both boinc-manager and boinc-client, invoked boinc-gui, done.