Unable to Resume from Suspend (Monitor not Responsive)

Hey all,
So after looking through the Googleverse I was unable to find a solution to this problem: when I resume my machine from suspend or hibernate the computer it self resumes but the monitor is not responsive. I have to hard reset in order to get back into the OS to login. The only thing I could think to do was to disable to screen locker but it made no difference. I think it must be something to do with the video card itself. I’ll post my system details and my pm-suspend log below.


  • OS = openSUSE 13.1
  • DM = XFCE
  • Screenlocker = gnome-screensaver
  • Videocard = Radeon HD6900 (with FGLRX drivers)
  • Swap partition = 8 GPs (on the storage partition)

**Pm-Suspend Log = http://paste.ubuntu.com/8167924/
Any help with this issue would be greatly appreciated.

  • Greg

Well, I can only suggest two things regarding this:

  • Look in your BIOS settings if there’s an option like “Repost Video on S3 Resume” or similar and try to change that.
    Maybe try to play with the other power management related settings there as well.

  • Try to uninstall “pm-utils” and see if it works better then.

Well, I can resume from hibernate, I guess it’s just suspend which is causing the issue. Removed pm-utils (didn’t make a difference) and checked my BIOS but no settings which look like what you’ve described.

It’s not a huge thing but it is pretty annoying:.

  • Greg

S3 is Standby/Suspend, your computer keeps running with low power consumption.
Whereas when hibernating, the computer is turned off completely (after storing the state on the hard disk).
This might explain the difference.

Removed pm-utils (didn’t make a difference) and checked my BIOS but no settings which look like what you’ve described.

Pity. I did experience a similar problem as you years ago, changing that option fixed it.
Some BIOSes only show all options after you press Ctrl+F1 or similary though (to enable “Expert Mode”).

You could try a newer kernel, maybe this might help.
Just install one from here:

This will not replace your current kernel, you can still boot the old one in “Advanced Options” in the boot menu if you should have problems with the new one.


Have a older laptop and had the same problem.

I changed from the kernel-desktop to kernel-default which solved the problem.