Unable to resize kate vertically

When i run kate, and open the “Configure Kate” menu item, the bottom is off the screen. This prevents me from getting to the bottom of the page and no access to the buttons to set apply etc. This affects all remaining kate windows until I restart kate, then the initial editing window is ok until i again select “Configure kate” How can i resize it vertically?
I tried the resize menu item but it doesn’t resize
KDE 5.101.0 Plasma 5.26.4
openSUSE Tumbleweed 01/01/2023 (x86_64) on kernel 6.1.1-1-default

No issues here on either of my TW machines using:

Operating System: openSUSE Tumbleweed 20221229
KDE Plasma Version: 5.26.4
KDE Frameworks Version: 5.101.0
Qt Version: 5.15.7
Kate: 22.12.0

Have you tried with a new test user?

My TW version is a couple of snapshots behind yours, did it previously work with snapshots prior to 01012023

Assuming KDE Plasma → on the “Task Manager” right-click the Kate entry – the icon – and, select “move” → move the Kate window until you can access the bottom of the window → resize the Kate window.

I can select move but then i can only move kate either left or right or up till it hits the top of the desktop window and there it stops.

I created a new user - tester. When i switch to tester kate works, but the thing is the desktop has more area and things are extremely tiny. This is the result of a hi-res laptop (3840x2160 which i hate) that constantly causes weird issues and at defaults everything is so tiny its impossible to read (for me). I have made adjustments to “global scale” set to 212.5% to get it larger so maybe that’s the issue

You may have to select “Move” more than once to move the Kate window up enough to access the bottom edge of the Kate window.

There are “high resolution” settings which have to be used.

  • For example, a 32 inch 3840x2160 Monitor (140 dpi) –
 > inxi --filter --admin --graphics
Graphics:
  Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: HDMI-A-1 empty: DP-1 bus-ID: 06:00.0 chip-ID: 1002:15d8
    class-ID: 0300 temp: 39.0 C
  Display: x11 server: X.Org v: 1.20.3 with: Xwayland v: 21.1.4
    compositor: kwin_x11 driver: X: loaded: amdgpu dri: radeonsi gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 140 s-size: 698x393mm (27.48x15.47")
    s-diag: 801mm (31.54")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Idek Iiyama PL3288UH
    serial: <filter> built: 2020 res: 3840x2160 hz: 60 dpi: 140 gamma: 1.2
    size: 698x393mm (27.48x15.47") diag: 801mm (31.5") ratio: 16:9 modes:
    max: 3840x2160 min: 720x400
  API: OpenGL v: 4.6 Mesa 21.2.4 renderer: AMD Radeon Vega 11 Graphics
    (RAVEN DRM 3.42.0 5.14.21-150400.24.38-default LLVM 11.0.1)
    direct render: Yes
 >

I’m on a laptop (Asus Zenbook) with a 15.6" diagonal screen

inxi --filter --admin --graphics
Graphics:
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: ASUSTeK driver: i915
v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
active: eDP-1 off: HDMI-A-2 empty: HDMI-A-1 bus-ID: 00:02.0
chip-ID: 8086:9bc4 class-ID: 0300
Device-2: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: ASUSTeK
driver: nvidia v: 525.60.11 alternate: nouveau,nvidia_drm non-free: 520.xx+
status: current (as of 2022-10) arch: Turing code: TUxxx
process: TSMC 12nm built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 8
link-max: gen: 3 speed: 8 GT/s lanes: 16 ports: active: none
empty: DP-1,HDMI-A-3 bus-ID: 01:00.0 chip-ID: 10de:1f95 class-ID: 0300
Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
bus-ID: 1-9:3 chip-ID: 13d3:56eb class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_x11 driver: X: loaded: N/A unloaded: fbdev,modesetting,vesa
alternate: intel dri: iris,nouveau gpu: i915 note: X driver n/a
display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1015x571mm (39.96x22.48")
s-diag: 1165mm (45.85")
Monitor-1: HDMI-A-2 mapped: HDMI-2 note: disabled
model: Toshiba ScreenXpert- serial: <filter> built: 2011 res: N/A dpi: 457
gamma: 1.2 size: 66x134mm (2.6x5.28") diag: 140mm (5.5") modes:
max: 1080x2160 min: 504x1000
Monitor-2: eDP-1 pos: primary model: BOE Display 0x0866 built: 2019
res: 3840x2160 hz: 60 dpi: 284 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: 3840x2160
API: OpenGL v: 4.6 Mesa 22.3.2 renderer: Mesa Intel UHD Graphics (CML GT2)
direct render: Yes

Did you try to hold the left ALT key and dag the window with the mouse? Using this you can drag from any part of the window , no need to drag from the title bar.

You can also resize from the top down.
Place the cursor on the top edge of the window until it changes in a double arrow, click the left mouse button and keep it pressed while dragging the top edge down. The window will now resize vertically.

A temporary “solution” might be to configure a special “Window Rule” for kate. (You may need to set the “Window Class” and “Window Role” to “Substring Match”)

Define the “Position” and “Size” with the “Force” option, also set “Ignore requested geometry” to “Force” “Yes”.

Doesn’t work with Kate – possibly a KDE Plasma behaviour …

Actually, it might be better to use either “Apply Initially” or “Remember”, rather than “Force”. It may require some experimentation to find a workable “solution”.

What you also do is, to select via right-click on the Task Manager icon the action “Resize” …

Works OK here, just tried kate, dolphin, and ark…

Maybe you’ve changed something here:

Yep!! → the “Modifier Key” is the “Meta” key rather than the “Alt” key … :upside_down_face:

  • And, <Meta+Right-Click> resizes vertically like a dream …

Redefined Meta key. I see…

yeh, cool! Meta works!

sorry I havent responded sooner we had a family emergency and things got very hectic.
I don’t understand the window rule thing mentioned above, can someone elaborate?

Window rules allow the corresponding window’s application’s attribute settings to be overriden and are applied before the window is displayed by KWin.

They can be used to force, iniitally set, remember, etc, various attributes. Such as size, position, arrangement, appearence, etc.

This KDE Userbase article gives a good overview:

KWin Rules - KDE UserBase Wiki

although unfortunately the images shown are of the older GUI, (It received a rewrite relatively recently). Nonetheless the window rule principals remain the same.

For attibutes that can be set/changed see this:

KWin Rules Window Attributes - KDE UserBase Wiki

again, unfortunately still showing the older GUI.