unable to reboot

I am unable to reboot my computer (Dell xps L502X). It just hangs on a blank screen. Shutting down works fine, but rebooting doesn’t. This problem presented itself after installing bumblebee and the nvidia drivers (which seem to be working fine as far as I can tell). Anyone have any idea what might be causing this, or steps I can take to troubleshoot? Thanks.

How long have you waited for it when this happens? It could be something needs to complete before it can continue.

… and, there are other reasons, others may see this thread and chime in.

I’ve waited for a few minutes, probably less than 5 before I just hit the power button and shut it off. Shutting down takes about 10 seconds so I can’t imagine rebooting would take longer. Reboot worked fine before I installed the video drivers, so it’s probably something to do with the graphics card, I just have no idea what it might be.

Next time, as it reaches that stage, try hitting Esc repeatedly to see if you can at least get a message.

I tried that. The status messages only appear for about 1 second at most, all preceded by “[OK]”. Then the screen goes blank and it hangs.

This issue may be related. I’ve also noticed that sometimes (probably 10-20% of the time) when I wake my laptop screen after it shuts off (from inactivity), the screen will remain blank except for the mouse pointer. I can get the GUI back by exiting to console via ctrl-alt-F2, then back to the desktop with ctrl-alt-F7. Anyone have any ideas what might be causing this?

I recently upgraded to 15 and am still having this problem. If I remove the nvidia driver from the bumblebee.conf file, then I can reboot. Otherwise, the computer just hangs on a blank screen (the nvidia driver seems to be working fine, otherwise). Anyone know if there’s a fix for this?

If you did an upgrade did you remove and reinstall the NVIDIA driver?

Yes, I did. Although, the instructions on the wiki page for NVIDIA Bumblebee are incomplete. The driver works just fine without placing the symlinks in the


directories. In fact, if I do put the symlinks in there, it doesn’t work at all. I get an invalid symbol error related to one of the libGL.so links, although I don’t remember which one. I removed a few of them, and the error persisted until I just removed all the symlinks. Although, I did not have the patience to go through them one by one.

Fixed it by reinstalling bumblebee. Also, about half the steps on the wiki for leap are unnecessary, as is the entire section on additional steps for leap 15.0. I’ll try to get around to updating it in the next few days.

Turns out, reinstalling bumblebee did not fix the problem. Today I noticed the discrete graphics card was on so I changed some settings in the bumblebee.conf file, which then turned off the card, but now I’m unable to reboot again.

If I reinstall bumblebee without making any changes to the default configuration, the discrete graphics card works and I can reboot. However, the

optirun --status

command reports that the discrete graphics card is off but I don’t think it actually is off because my laptop is pretty warm, which usually only happens when the graphics card is on.

If I follow the instructions on the wiki, I can’t reboot the computer. Anyone have any ideas?

I’ll just monitor this issue over the next few days to see if it reappears. I reinstalled bumblebee again with no modifications to the settings and it appears to be working (for now). Apparently it just stopped working this morning after working fine for a few days. I know that makes no sense, but I didn’t alter any settings.