Unable to print!!! Error using smbspool!!! openSUSE 11.0

Hello. I just installed openSUSE 11.0 on my PC and was trying to configure the CUPS server to be able to print to a printer connected to a windows xp machine. First I configured CUPS but when I sent test page I got “NT_STATUS_ACCESS_DENIED” and after a while “Unable to connect to CIFS host, will retry in 60 seconds”. I went a little deeper and checked the cupsd.conf and printers.conf configuration files but everything seems OK. In fact it was configured exactly the same as it was before changing my OS from Mandriva to openSUSE. I then tried to print using the smbspool command and, obviously, got the same response:

# smbspool smb://username:passwd@workgroup/netbiosPCname/hpLaserJ 111 username "test" 1 test.txt

timeout connecting to 192.168.XX.XXX:445
cli_start_connection: failed to connect to NETBIOSNAME<20> (0.0.0.0). Error NT_STATUS_ACCESS_DENIED
ERROR: Connection failed: NT_STATUS_ACCESS_DENIED
ERROR: Unable to connect to CIFS host, will retry in 60 seconds...

Then I tried printing text directly to the printer using smbclient like this:

# echo -en "\rHello\r\f" | smbclient "//NetBIOS-hostname/share" "password" -c "print -" -N -U "username" -W "workgroup"

timeout connecting to 192.168.XX.XXX:445
Domain=[NETBIOS-NAME] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]
putting file - as stdin-29812 (3.4 kb/s) (average 3.4 kb/s)

And, after about 3 to 4 seconds the text HELO is printed on the HP printer!!!

Can anybody help me with this please!

Thanks!

On Fri, 15 Aug 2008 16:36:03 GMT
dragonov7 <dragonov7@no-mx.forums.opensuse.org> wrote:

> smbspool smb://username:passwd@workgroup/netbiosPCname/hpLaserJ 111
> username “test” 1 test.txt

I have found that often I cannot connect to a Windows machine if I specify
the workgroup. Try the command without that…

smbspool smb://username:passwd@netbiosPCname/hpLaserJ 111 > username “test”
1 test.txt

(line wrap not included of course)

This also holds true when you set up a windows shared printer through yast
printer setup. Where it asks for the workgroup, leave it blank.

Loni


L R Nix
lornix@lornix.com

Hi Lornix. Thanks for the help… tried what u suggested but still no luck!!! :-(. I have given up on this… I think this is a bug somewhere in smbspool… I have the same configuration in a PC running Mandriva 2008, other in Ubuntu 8 and other in fedora core 8 and I have not had a problem…

I think I’ll have to wait a little longer for openSUSE 11 to get revised a little more and try it on a later release… :frowning: too bad 'cause I really like it!