Unable to play Samba shared video files on XFCE

Hi guys,

              Is this the right place to ask about OS built on SUSE Studio.If so then I have built an image on SUSE Studio with openSUSE 12.3 XFCE DE.After building the image I am unable to play the video files shared in windows systems.If I install the full version then I am able to play video files.As we have a restriction of HDD i.e flash size of 4 GB I have to build it on suse studio removing all unnecessary packages.Any ideas why this is happening.

Thanks in advance.

What kind of video files are this and what media player are you using?

My guess is that you’re just missing the right codecs.

I am using smplayer2 and I am able to play when I copy the video file locally.

OK, so your problem is the SMB access?

Since smplayer2 is just a frontend to mplayer2, does it work if you run mplayer2 on the command line like this?

mplayer2 smb://HOST/SHARE/path_to_file

If not, what error do you get?

Please note that I don’t have mplayer2 installed, but the above works for me like that with mplayer.

If I try playing from command line witht he following command I get the following error

RDP@Linux:~/Desktop> smplayer2 smb://nishanth-pc/abcd/Downloads/ab.mp4
Qt: Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
This is SMPlayer2 v. 0.8.0 running on Linux

and then smplaye opens and nothing happens.

Try “mplayer2”, not “smplayer2”. Maybe that gives more verbose output about the SMB problem.

That error about authentication is GUI related but doesn’t seem to matter, since the window pops up anyway and it works with local files.

If I try running the mplyer2

RDP@Linux:~/Desktop> mplayer2 smb://nishanth-pc/abcd/Downloads/ab.mp4
MPlayer2 UNKNOWN (C) 2000-2012 MPlayer Team
Cannot open file ‘/home/RDP/.mplayer/input.conf’: No such file or directory
Failed to open /home/RDP/.mplayer/input.conf.
Cannot open file ‘/etc/mplayer2/input.conf’: No such file or directory
Failed to open /etc/mplayer2/input.conf.
Can’t open joystick device /dev/input/js0: No such file or directory
Can’t init input joystick

Playing smb://nishanth-pc/abcd/Downloads/ab.mp4.
Using netbios name LINUX.
Using workgroup WORKGROUP.
Could not open from LAN: ‘smb://nishanth-pc/abcd/Downloads/ab.mp4’
Failed to open smb://nishanth-pc/abcd/Downloads/ab.mp4.

Exiting… (End of file)

Well, that’s also not really informative.
libsmbclient fails to open the file, but it doesn’ tell why.

Could you maybe install “samba-client” (if not installed) and try to connect with that?

# smbclient -d 1 //nishanth-pc/abcd
smb: \> cd Downloads
smb: \> ls
smb: \> quit

And can you confirm that the above mplayer2 command line works on your full installation?

Yes I can conform you that the full installation is working absolutely fine.

samba-client is installed and when enter" smbclient -d l //nishanth-pc/abcd"

As root user I get the following error

“tree connect failed:NT_STATUS_ACCESS_DENIED”

As non-root user I get the following error

"Session setup failed:NT_STATUS_LOGON_FAILURE

After the ‘-d’ it should be the digit ‘1’, not the letter ‘l’…
That’s there to raise the level of output.

As root user I get the following error

“tree connect failed:NT_STATUS_ACCESS_DENIED”

As non-root user I get the following error

"Session setup failed:NT_STATUS_LOGON_FAILURE

So this definitely is Network/Samba related.
You do have guest access enabled on the share?

Googling for the error message gives me this: samba - smbclient getting NT_STATUS_LOGON_FAILURE connecting to Windows box - Ask Ubuntu
So could you try to copy over /etc/samba/smb.conf from the working system? (Keep the old one just in case)
And if it helps please post it here (both the working and the not-working one)…

Shall I copy the smb.conf file from the full installation and paste it.

Only paste it if copying it over to the not-working installation helps.
Otherwise it would be of no use…

Sorry for this post I forgot to mention that I am able to play the videos in the GUI but not CLI. If I try to play from CLI with mplayer2 I get the same error.

And what about that smbclient stuff? Do you get the same error there as well?

Do you have write access over samba? When I play a video with SMPlayer2, it creates a file called .directory in the file the video is in.

The same errors with the smbclient also.But the only difference is I am able to play videos in full installation from GUI but not in SUSE Studio built image.

I didn’t get you.Can you elaborate please

This doesn’t matter. That’s the file dialog saving the current display settings I guess. If they can’t be saved, they just won’t be remembered.

Then I’m wondering, how the GUI can get the file if even Samba’s official client fails to connect?
Did you specify a specific username/password in the GUI in the full installation?