unable to open or launch any application or icon from yast


 Yesterday I have installed OpenSuse13.1 on my machine. I have downloaded the iso file using bittorrent and while installing the OS it gave messages as wrong digest due you want to install the package and I answered yes. Upto now the system worked fine. I thought that something is wrong with the system so I opened the software manager and selected update the packages if new version is available it has shown messages regarding package dependencies such as do not install ... and remove the package... I have selected do not install .. option many times. I have installed some other packages related to kernels, hal, udev.

At present I am unable to open any application or icon like bootloader, software repositories, services etc., from Yast.

Another issue is I am unable to use gnome desktop and when I try to login to gnome desktop it is giving warning as Oh something went wrong please logout and try again.

I have tried to login into the system by pressing ALT + F1 and succeeded then I have issued the command yast and then yast window opened and in that I have selected software manager it gave warning as there is problem with ncurses pkg please see the log file.

Please help me to use my system efficiently without any errors.

Well I think it would be better to open a separate thread for each problem.

Let’s concentrate on your YaST problem here.
Your GNOME problem most likely is related to the graphics driver though, so when opening a new thread, also specify which card you have and which driver you’re using.

Regarding YaST, also have a look here:
Please post the last lines of /var/log/YaST/y2log.

Likely your problem is ruby related. Did you make any change to your system in that regard?

Sir sorry for my mistakes I am providing the output of the command /sbin/yast2 sw_single below

linux-p6x0:~/soft # /sbin/yast2 sw_single
terminate called after throwing an instance of ‘YUIPluginException’
what(): Couldn’t load plug-in gtk
YaST got signal 6 at YCP file /usr/share/YaST2/modules/Wizard.rb:818
/sbin/yast2: line 392: 5211 Aborted $ybindir/y2base $module “$@” “$SELECTED_GUI” $Y2_GEOMETRY $Y2UI_ARGS
linux-p6x0:~/soft #

Can you suggest the solution on examining the above output

Some people are suggesting to reinstall the OS due to installation from corrupted iso image and which is a tedious work so please help me.

Well, where are you trying to run that? In a terminal window after running “su”?
That won’t work. You would need to run “su -” (notice the ‘-’) to be able to run GUI applications.

And please, again, post the last lines of the file /var/log/YaST2/y2log (or upload it to SUSE Paste and post a link).
This should provide a clue what’s wrong.

Sir I am providing the last lines of the file you specified below

2014-01-07 00:55:51 <1> linux-p6x0(6650) [Pkg] modules/PackageCallbacks.rb:2901 Pkg Builtin called: CallbackDoneRefresh
2014-01-07 00:55:52 <1> linux-p6x0(6650) [Ruby] modules/Misc.rb:197 ."//etc/os-release".“NAME”: ‘openSUSE’
2014-01-07 00:55:52 <1> linux-p6x0(6650) [ui] YSettings.cc(setProgDir):60 Set progDir to “/usr/share/YaST2”
2014-01-07 00:55:52 <1> linux-p6x0(6650) [ui] YSettings.cc(setProgDir):61 progDir is now locked.
2014-01-07 00:55:52 <1> linux-p6x0(6650) [ui] YSettings.cc(setLocaleDir):146 Set localeDir to “/usr/share/YaST2/locale”
2014-01-07 00:55:52 <1> linux-p6x0(6650) [ui] YSettings.cc(setLocaleDir):147 localeDir is now locked.
2014-01-07 00:55:52 <1> linux-p6x0(6650) [ui] YPath.cc(YPath):49 Given filename: libyui-gtk.so.6
2014-01-07 00:55:52 <1> linux-p6x0(6650) [ui] YSettings.cc(progDir):73 progDir: “/usr/share/YaST2”
2014-01-07 00:55:52 <1> linux-p6x0(6650) [ui] YPath.cc(YPath):65 Preferring subdir: /usr/share/YaST2
2014-01-07 00:55:52 <1> linux-p6x0(6650) [ui] YPath.cc(YPath):66 Subdir given with filename:
2014-01-07 00:55:52 <1> linux-p6x0(6650) [ui] YPath.cc(YPath):67 Looking for: libyui-gtk.so.6
2014-01-07 00:55:52 <1> linux-p6x0(6650) [ui] YPath.cc(lsDir):138 Looking in /usr/lib64/yui
2014-01-07 00:55:52 <1> linux-p6x0(6650) [ui] YPath.cc(YPath):121 Could NOT find libyui-gtk.so.6 by looking recursive inside /usr/lib64/yui
2014-01-07 00:55:52 <3> linux-p6x0(6650) [ui] YUIPlugin.cc(YUIPlugin):50 Could not load UI plugin “gtk”: libyui-gtk.so.6: cannot open shared object file: No such file or directory
2014-01-07 00:55:52 <2> linux-p6x0(6650) [ui] YUILoader.cc(loadPlugin):116 THROW: Couldn’t load plug-in gtk

This is the problem:

2014-01-07 00:55:52 <3> linux-p6x0(6650) [ui] YUIPlugin.cc(YUIPlugin):50 Could not load UI plugin "gtk": libyui-gtk.so.6: cannot open shared object file: No such file or directory

Which openSUSE version do you have installed?
openSUSE 13.1 comes with libyui-gtk5, so yast should use that (not libyui-gtk6)!

You said you installed a few things.
Most likely you added the Facory repo (i.e. the place where the next openSUSE version is developed) to your system and now have an inclompatible mix of packages because of that.

Before we continue, please show your repo list:

zypper lr -d

PS: I just noticed that Factory also still contains libyui-gtk5, so you must have added some YaST development repo…