Unable to mount USB drive after latest update on opensuse 11.4


I did the latest update on the opensuse 11.4 other day and since then my USB drive is not mounting. initially I thought its gone because my son dropped on the floor. But then when I plugged it to Windows 7 machine it mounted then I plugged it into another Ubuntu 10.10 machine it mounted so I figured out the there is some issue in the latest update. Please help me to resolve the issue because I have all the VMs in this drive and my main laptop is with OpenSuse 11.4

Any help is appreciated.


Edit the file /etc/filesystems and add the line “ntfs” there.

Installed Kernel Updates, now get error when mounting USB stick. Why?

I just did but no difference. I even rebooted the system.

Sorry its my fault, it working after I edited the /etc/filesystem

Thanks alot guys

Hi guys. i also had the same problem after updates were installed on 11.4.
I added ntfs to /etc/filesystem and now it complains about permissions.
I tried to access it as root at it is accessdible. unfortunately non superuser is blocked from accessing my external HD.

Thanks in advance for any clue

I’ve seen a similar problem with 11.4. I have a number of usb port external memory devices, formatted with fat32 usually or sometimes ntfs. For SOME BUT NOT ALL of them, thee 11.4 machine refuses to allow a non superuser to mount them. How do you change the system permissions to allow the normal user to insert and mount a usb storage device regardless? And why would the problem arise for only some drives?


check out this:
Automount of external NTFS USB drive fails when using the Device Notifier

I have exactly the same problem here and its really ticking me off! I went to the trouble of resetting the permissions but they didn’t stick either… I also have a related issue where file copies to USB devices look to have completed and then the files mysteriously disappear before I get to read them off using another machine. I am pretty sick of this, I had hoped OS 11.4 would be a low maintenance operating system that I could rely on. Seems it was a foolish dream! Why is the USB stuff so ****ed flunky… grrrr!

Sorry, pretty grumpy as its really painful having to use the superuser mode always. I have more troubles than the USB however, I can’t see any of my other drives when logged in as an ordinary user. All the main filesystem is there but none of my other hard drives show up. In super user mode they all appear in Dolphin and USB devices show as they are plugged. As far as I can tell the device notifier has no knowledge of devices being plugged. This all came from a system update, I think! I had a fully functional system then a change was made that screwed it all up and I’m ****ed if I can find whats wrong.
I have already checked the etc/filesystems and that is correct, I am wondering if it is PolicyKit that is causing the issues, can anyone help me out here??

On 2011-05-02 20:36, please try again wrote:
> Edit the file /etc/filesystems and add the line “ntfs” there.

I hope this has been reported in bugzilla :-? or it will never be corrected.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

The same problem arises only in Dolphin and KDE mount applet. Other file menagers and SU can mount all. Notification in Dolphin "Error …org.freedesktop.UDisks.Error. Failed: Requested filesystem type is neither well-known nor in /proc/filesystems nor in /etc/filesystems. Fle system is Ntfs, and ir type there is in /etc/filesystems.

Dest regards.

I don’t get those messages anymore since I added ntfs to filesystems but nothing is mounted unless I am superuser in Dolphin etc.
Is there something that tells the system to automount all drives when superuser that has not been enabled or is it simply because I have no mount points for them???

Look at /etc/fstab file that is where all the default mounts are defined.

I can confirm that the problem is in KDE and Dolphin. After receiving the somewhat ominous message(s) as in the OP, I immediately wondered if the NTFS-drive (in a USB caddy) had met the choir invisible. I immediately tested the hookup under Windows 7 (OK) and Windows/XP (slow, but working).

I then tested under GNOME (openSUSE 11.3 and 11.4, and Ubuntu). Drive was accessed without problem, including easily unmounting. Lastly, I restarted KDE, and started Nautilus (instead of Dolphin). The drive was accessed again without problem, including unmounting.

Methinks the problem lies in KDE. The circumvention/correction of addition of “ntfs” to /etc/filesystems corrects most of the problem with KDE. I say most, because unmounting (ie: “safely remove”) is problematic, with messages indicating that the drive is in use by another application. It appears that the device indexing is tied up indexing the device at every mount, and is very slow in responding to the device unmount commmand. Eventually, the drive unmounts successfully.

In looking back at my update logs, the problem started after the recent KDE 4.6.3 updates. Needless to say, I only mount external/USB ntfs-drives for semi-monthly backups and emergency/rescue/testing occasions.

I then tested under GNOME (openSUSE 11.3 and 11.4, and Ubuntu). Drive was accessed without problem, including easily unmounting. Lastly, I restarted KDE, and started Nautilus (instead of Dolphin). The drive was accessed again without problem, including unmounting.

I tried via Nautilus and could see the drives but only one partition per drive!
I cannot access the removable USB drive, insufficient permissions. Interesting that permissions for those two drive objects that are identified are not determinable. Looks like something is royally screwed up.
I do believe this is something to do with KDE but fear it may be a combination of things that are making it difficult to get an idea of what is wrong…