Unable to mount usb devise (openSUSE 11.3 )

When I plug-in any kind of usb storage device an error massage appears

Unable to mount (name of the devise)
DBus error org.gtk.Private.RemoteVolumeMonitor.Failed: An operation is already pending
and the window of the devise opens several times.
Everything working just fine, I can store files and read them, but I don’t want to close all the windows that opens-up each time I plug some thing.

What is the problem??

How about a screen shot so we can get our heads round it better.

Does the “auto-mount” option is set?
Are the mount point set on the fstab?
have you edit udev rules?


I don’t realy know what you talking about. How I check all this things???

For the mount point on the fstab… have you modifi the /etc/fstab fil to add an entry for your device? I mean have you open it with an editor and add a line to set a permanent mount point for your device?

For the udev rules, have you create or edit any files locate at /etc/udev/rules.d/, (normaly if you don’t know what I was speaking when I said edit udev rules, you haven’t probably do this)

For the auto-mount, if you haven’t desactivate it on Gnome If I well remember it is activated by default. But when you plug your device does the drive automaticaly get mounted. I mean do you have to say to the system in any way “mount my device”

The device is mounted
You are just getting this error message - which is false. I have seen behaviour like this before but I can’t really account for it. My camera does similar in Gnome, but not in KDE. But I can work it in Gnome regardless.

I didn’t change anything about mount, and after I plug something the device mount and open window automatically.

I didn’t notice any data loss after file transferring. Just window opens multiple times and as I think something trying to mount it several times.


I’m getting the same problem - after inserting a USB key (checked with different ones) it’s mounted automatically, the Nautilus window is opened many times and this error message is displayed, also many times. It’s pretty annoying to close these windows every time, apart from that nothing bad happens. I’m using Gnome if that’s of any significance. I didn’t do anything with fstab or udev. Any idea what’s the problem here? What other information I can supply?

PS I’m not an expert Linux user, so sorry if the message is not very clear…

This happens to me as well, but only when I have a VM running in vmware workstation is running. I think it has to do with vmware interfering with the automount because it is trying to make the device available to connect to the open vm’s

Recently I have the same problems, a few week ago it was still working. Now I can’t access my Camera and my phone anymore while it worked before. I can’t even access all my USB memory sticks any more.

If I want to access my camera with dolphin I says

Unknown error code 150
I/O problem
Please send a full bug report at http://bugs.kde.org.

My USB memory stick gives the following error

An error occurred while accessing ‘BC_STICK1’, the system responded: org.freedesktop.Hal.Device.PermissionDeniedByPolicy: org.freedesktop.hal.storage.mount-removable auth_admin_keep_always ← (action, result).

Does someone has a idea

You wrote:

"My USB memory stick gives the following error

An error occurred while accessing ‘BC_STICK1’, the system responded: org.freedesktop.Hal.Device.PermissionDeniedByPolicy: org.freedesktop.hal.storage.mount-removable auth_admin_keep_always ← (action, result)."

It sounds like you’re running into PolicyKit, which (I think) is new in 11.3. From what I can tell, it’s a horribly complex and badly documented “Security Framework” – is there anything developers like better than creating ‘Frameworks’? – that is used by parts of the system to determine which users have authorization to access system devices. I’ve just started to try to figure it out: I would recommend reading the following man pages:
pklocalauthority (8) - PolicyKit Local Authority
PolicyKit (8) - Centralized policy management
PolicyKit.conf (5) - PolicyKit configuration file
polkit-action (1) - List and modify registered PolicyKit actions
polkit-config-file-validate (1) - Validate a PolicyKit configuration file
polkit-policy-file-validate (1) - Validate a PolicyKit policy file
polkitd (8) - PolicyKit daemon
set_polkit_default_privs (8) - set default privileges for PolicyKit

good luck.

I’ve the feeling that all USB devices suffer from it, the normal Linux copy past mode with pasting text with the MMB or LMB+RMB is giving me a pop-up instead of direct pasting. Had it before, a few versions before but can’t remember how i fixed it.

It worked fin in 11.3 until a update a few weeks ago, I don’t know if it was the small kernel update of the update to KDE 4.5.4, It seems to be a KDE problem because everything works fine in GNOME (I heard).

Latest update fixed my camara access when using Digicam. But still can’t access my camera tru Dophin same for my USB memorystick and my Mobile phone

I too have noticed that Suse 11.3 KDE doesn’t even identify my HTC Android phone. It says “no Device plugged in”. Although other mobile LG is very much identified and gets mounted in openSUSE 11.3 KDE.

It’s broke again. I don’t know what they are doing at suse at the moment but they break a lot lately.

Sometimes it works some times it wont SUSE/KDE makes me crazy. I cant get my photos from my camera now, need Windows :frowning: to do it now. I’m thinking of going to another distro somebody has some experience with for example Aptosid.

As a general advice, perhaps negated by udev rules, you may:

  1. insert the device;
  2. find out the corresponding device name in /dev;
  3. see to what group the device belong and if the group have read/write permissions;
  4. check if your user belong to that group - if not, add yourself to it.

Thanks for that info but, how do you do steps 2, 3, and 4?