unable to mount network shares after update

Before an update this morning, network shares were mounted automatically (using fstab entries). When they did not mount after turning on the pc this afternoon, I tried “sudo mount -a” and entered the password. Even after that, opening Nautilus (using Gnome 3) and clicking on a network share results in the following:

Unbale to mount *sharename* 
This program is not installed setuid root -  "user" CIFS mounts not supported.

I searched a bit and tried a few things I found, but the problem persists.
I’m using Opensuse 12.1, 64bit with Gnome 3.
Any suggestions would be greatly appreciated. I don’t want to have to take the time to install another distro during finals week.

Based on that error message, I might wonder if you forgot to become root (su - in terminal) before trying to mount the share? I see some complain of the new systemd feature causing such problems. This can be disabled per the following thread:


Thank You,

Thanks for the suggestions.
I checked the bash history, and it was the command “sudo mount -a” that was used. Keep in mind that this command attempt came after the entries in /etc/fstab stopped working, even though they hadn’t been changed. Actually, mount -a should try to mount all the entries in the /etc/fstab file anyway. I’d be more than happy to remove whatever offending program caused this to start happening after so many years of working just fine. Is there a history of updates that were made that I could check? My computer is a netbook. I don’t keep documents on it, but on a network share on a little, low-power machine in the closet. Needless to say, without being able to mount those directories, I’m stuck with booting into Windows to get to them. So, from the error message, am I to assume that someone decided to no longer support cifs shares?
Removing systemd-sysvinit and installing the other one instead was among the things I had tried. Sorry. I forgot to mention that.
By the way, how late in the year do the bats keep coming out from under that bridge down there? It’s an impressive sight.

So your network has got to be up for this to work and if it fails after the system is up, I might wonder if something else is wrong. I am using openSUSE 12.1 and Samba shares and have not found it necessary to remove systemd, but I did have to write a procedure to reactivate the after.local file you can find here:

systemd and using the after.local script in openSUSE 12.1 - Blogs - openSUSE Forums

But, if you went back to the old setup, then it must have something to do with the new kernel 3.1 perhaps.

As for your Bat question here in Austin I am not the expert but here is a little info I found:

Bats Flight Schedule for Austin, Texas

January - bats in Latin America
February - migration may begin
March - many bats in Austin
April - most have migrated
May - mothers prepare for birth
June - mothers give birth this month
July - mothers feed at night
August - pups can now fly
September - excellent bat watching
October - bats migrate south
November - bats continue migration
December - bats arive at winter roost

Best Bat-watching guide

Thank You,